Watch, Follow, &
Connect with Us

Please visit our new home
community.embarcadero.com.


Welcome, Guest
Guest Settings
Help

Thread: [Solved] installation teechart : rad studio components toolbar is broken



Permlink Replies: 3 - Last Post: Feb 19, 2018 7:05 AM Last Post By: Yeray Alonso Threads: [ Previous | Next ]
Vincent BEUSELI...

Posts: 3
Registered: 2/14/18
[Solved] installation teechart : rad studio components toolbar is broken
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 8, 2018 12:37 PM
Hello,

I used Rad studio architect trial version delphi 10.2 to evaluate migrating an old software from D7.

Teechart was not included in the basic installation (I didn't remember I used tchart ten years ago).

Googling tchart , I founded steema teechart VCL on the steema site and install it.

After this, I search to instal help files and discover in Rad Studio the tool to download other pltatforms, help files and... teechart.
I decided to install the Embarcadero teechart version. Bad choice.

The toolbar «components» is now empty, uninstalling and reinstalling teechart has no effect. If I try to unactive teechart package, others components appears since the next restart of rad studio.

I begin to reinstall D10.2
:(

So guys , be careful with teechart installation : I lost a few hours

Edited by: Vincent BEUSELINCK on Feb 10, 2018 12:08 PM
Yeray Alonso

Posts: 75
Registered: 6/12/11
Re: installation teechart : rad studio components toolbar is broken
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 8, 2018 11:43 PM   in response to: Vincent BEUSELI... in response to: Vincent BEUSELI...
Vincent BEUSELINCK wrote:
After this, I search to instal help files and discover in Rad Studio the tool to download other pltatforms, help files and... teechart.
I decided to install the Embarcadero teechart version. Bad choice.

Do you mean at GetIt? I find no "teechart" entries there.

Vincent BEUSELINCK wrote:
The toolbar «components» is now empty, uninstalling and reinstalling teechart has no effect. If I try to unactive teechart package, others components appears since the next restart of rad studio.

I begin to reinstall D10.2

Have you tried to manually uninstall / reinstall TeeChart components directly from the "Component\Install Packages..." list?

--
Best Regards,

Yeray Alonso
Steema Software
Facebook, Twitter, GPlus, LinkedIn, YouTube, GitHub, RSS
Support Options
Vincent BEUSELI...

Posts: 3
Registered: 2/14/18
Re: installation teechart : rad studio components toolbar is broken
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 10, 2018 12:07 PM   in response to: Yeray Alonso in response to: Yeray Alonso
First time, I used the online installer from steema to install « evaluation standard» : https://www.steema.com/downloads/vcl and it run fine
After this, I used Tools / platform manager (tab option : you can add help files, intraweb, languages, samples and teechart standard : I checked teechart and french helpfiles). I suppose It was my mistake : installing include version after evaluation version.

Yes I tried to uncheck, to remove it by Component/install package or reinstall by this way. And again after removing backup dir of teechart. And again to Re-use Tools/ platform manager (removing and reinstall). And again, re-use the steema exe…

Yersterday, I reinstalled rad studio 10.2 with all platforms (win32, win64 osX) and standard teechart option, offline helpfiles. (first time, I just installed minimum: D10.2 win32 without options or help). I can continue to evaluate it.

Thanks for vour reply.

Do you mean at GetIt? I find no "teechart" entries there.

Vincent BEUSELINCK wrote:
The toolbar «components» is now empty, uninstalling and reinstalling teechart has no effect. If I try to unactive teechart package, others components appears since the next restart of rad studio.

I begin to reinstall D10.2

Have you tried to manually uninstall / reinstall TeeChart components directly from the "Component\Install Packages..." list?

--
Best Regards,

Yeray Alonso
Steema Software
Facebook, Twitter, GPlus, LinkedIn, YouTube, GitHub, RSS
Support Options
Yeray Alonso

Posts: 75
Registered: 6/12/11
Re: installation teechart : rad studio components toolbar is broken
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 19, 2018 7:05 AM   in response to: Vincent BEUSELI... in response to: Vincent BEUSELI...
Hello,

Vincent BEUSELINCK wrote:
First time, I used the online installer from steema to install « evaluation standard» : https://www.steema.com/downloads/vcl and it run fine
After this, I used Tools / platform manager (tab option : you can add help files, intraweb, languages, samples and teechart standard : I checked teechart and french helpfiles). I suppose It was my mistake : installing include version after evaluation version.

Yes I tried to uncheck, to remove it by Component/install package or reinstall by this way. And again after removing backup dir of teechart. And again to Re-use Tools/ platform manager (removing and reinstall). And again, re-use the steema exe…

Yersterday, I reinstalled rad studio 10.2 with all platforms (win32, win64 osX) and standard teechart option, offline helpfiles. (first time, I just installed minimum: D10.2 win32 without options or help). I can continue to evaluate it.

I've tried to reproduce the problem in a new virtual machine. I found some errors but the IDE looks stable for me.

Here's what I've tried:
- Install Windows 10 and all the updates.
- Install RAD Studio Tokyo 10.2.2 trial version, "Delphi Windows 32-bit" only; no other platforms and no "Additional Options".
- Open the IDE and check no TeeChart components are in the list of components and in the toolbox. Close the IDE.
- Install TeeChart v2017.23 evaluation version.
- Open the IDE and check TeeChart Pro components are in the list of components and in the toolbox.
- Install TeeChart Standard from the "Additional Options"

At this point, when I opened the IDE I got an error saying:

"Can't load package c:\program files (x86)\embarcadero\studio\19.0\bin\dcltee9250.bpl.
Cannot load package 'Tee9250.' It contains unit 'VCLTee.TeeGDIPlus', which is also contained in package 'Tee925'.
Do you want to attempt to load this package the next time a project is loaded?"

I pressed "No" and the IDE continued loading.
Now, opening the "Components\Packages" list I can see the TeeChart Pro packages are selected. That's why the TeeChart Standard package can't be loaded.
I can remove the "Pro" and "TeeTree" packages and select the Standard/Lite packages without problems.
Also note the paths need to be cleaned as references to the Pro installation are still present.

--
Best Regards,

Yeray Alonso
Steema Software
Facebook, Twitter, GPlus, LinkedIn, YouTube, GitHub, RSS
Support Options
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02