Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: New not working anymore



Permlink Replies: 2 - Last Post: Jul 24, 2017 9:55 AM Last Post By: Alex Belo Threads: [ Previous | Next ]
duong anh

Posts: 1
Registered: 8/9/17
New not working anymore
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jul 9, 2017 12:04 AM
This message is no longer available.
Valence Crearer

Posts: 64
Registered: 11/27/99
Re: New not working anymore
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jul 9, 2017 7:13 AM   in response to: duong anh in response to: duong anh
duong anh wrote:
I have a project that I migrated properly in C++ Builder Seattle 10.
Everything was working perfectly.

Now, for some strange reasons, the project in debug mode is freezing on this line and also when I run the application (previously it was working) :

TCompany *myCompany = new TCompany(this);
<Snip>

Can you show the code for TCompany(this)? It is probably locking in this constructor, perhaps not "new"...

If the heap is corrupt due to some other issue, only then would new likely lock... Or if this code is multithreaded and has somehow deadlocked. Let's assume the simple case, though, its locking in TCompany constructor?
Alex Belo

Posts: 626
Registered: 10/8/06
Re: New not working anymore
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jul 9, 2017 8:12 AM   in response to: duong anh in response to: duong anh
duong anh wrote:

Now, for some strange reasons, the project in debug mode is freezing

Does it work without debugger?

If yes then your issue can be related to newly discovered problem

https://forums.embarcadero.com/thread.jspa?messageID=891816&tstart=0#891816

--
Alex
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02