Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Can't deploy anything to macOS Sierra v10.12.1



Permlink Replies: 1 - Last Post: Nov 15, 2016 2:42 PM Last Post By: Sean Hoffman Threads: [ Previous | Next ]
Sean Hoffman

Posts: 126
Registered: 3/28/99
Can't deploy anything to macOS Sierra v10.12.1
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 11, 2016 8:47 AM
I'm running 10.1 Berlin Update 1. I created a new blank multi-device application with just the main form and when I attempt to run it from within the IDE, PAServer is displaying "sentinelFunc n" errors (where the 'n' is a 3 digit number) in the PAServer console. On the Windows side, the IDE appears to freeze when this happens (I'm running Windows 10 version 1607 on the PC side).

I've enabled and disabled incremental link, disabled/enabled "build with runtime packages", Re-deployed PAServer.pkg, deleted both the Connection Profile and the SDK. I even tried building a new Delphi application and am having the same problem. Is anyone able to replicate this problem?

Perhaps related (or perhaps unrelated), when I select OSX as a target platform, it seems to be defaulting to 32 Bit OSX, even though my Mac is 64 bit. Does C++ Builder select 64 Bit OSX applications? This is my first attempt to build an OSX application so forgive my questions if they're uninformed.

Edited by: Sean Hoffman on Nov 11, 2016 11:04 AM
Sean Hoffman

Posts: 126
Registered: 3/28/99
Re: Can't deploy anything to macOS Sierra v10.12.1
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 15, 2016 2:42 PM   in response to: Sean Hoffman in response to: Sean Hoffman
This problem still exists in 10.1 Berlin Update 2. Bug created:
https://quality.embarcadero.com/browse/RSP-16322
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02