Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: I got error - Requied package 'IntraWeb' not found



Permlink Replies: 16 - Last Post: Mar 27, 2018 8:24 AM Last Post By: Thiago Rodrigues Threads: [ Previous | Next ]
Haruhiko Takesh...

Posts: 1
Registered: 8/30/01
I got error - Requied package 'IntraWeb' not found
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 24, 2016 6:05 PM
I use Delphi 10.1 Berlin Starter Edition.
I got IntraWeb XIV (14.0.63) and install it, and I got free license key from Purchase Point, set license key at install.
I want to use sgcWebSocket, so download it and install to my pc.
But, I got error:
E2022 Required package 'IntraWeb' not found.

uses
...
IntraWeb, <- error

I wonder why error on IntraWeb.
Do I need edit the line? or something less to comple it?
Eitan Arbel

Posts: 508
Registered: 2/24/13
Re: I got error - Requied package 'IntraWeb' not found
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 28, 2016 8:46 AM   in response to: Haruhiko Takesh... in response to: Haruhiko Takesh...
hi Haruhiko

here is what i would do:
1. close Delphi if it's opened
2. uninstall intraweb
3. use the IntraWeb Bundled Removal Tool (to make sure there are no traces of an old version of intraweb)
4. re-install intraweb (while Delphi is still closed)
5. restart the computer (just to make sure...)
6. start Delphi and test intraweb

i don't know if the Starter Edition have the bundled version of intraweb or not, but a good start will be to use the IntraWeb Bundled Removal Tool.
look here for info :
http://atozed.com/IntraWeb/Download/IntraWebBundledRemovalTool.EN.aspx

or direct download it from here :
http://downloads.atozed.com/intraweb/IWBundledRemovalTool.zip

if after all that, you still get that message, then maybe check if intraweb's folders are in Delphi's search path.
in Delphi menu Tools-->>Options-->>Environment Options-->>Delphi Option-->>Library
now add intraweb's folders to the "Library path" for both 32 and 64 bit Windows

Alexandre Machado

Posts: 1,754
Registered: 8/10/13
Re: I got error - Requied package 'IntraWeb' not found
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 1, 2016 1:24 AM   in response to: Haruhiko Takesh... in response to: Haruhiko Takesh...
Haruhiko Takeshita wrote:
I use Delphi 10.1 Berlin Starter Edition.
I got IntraWeb XIV (14.0.63) and install it, and I got free license key from Purchase Point, set license key at install.
I want to use sgcWebSocket, so download it and install to my pc.
But, I got error:
E2022 Required package 'IntraWeb' not found.

uses
...
IntraWeb, <- error

I wonder why error on IntraWeb.
Do I need edit the line? or something less to comple it?

Hi,

Eitan nailed it. This page contains all the procedure to install it correctly: http://atozed.com/IntraWeb/Download/IntraWebBundledRemovalTool.EN.aspx

Just make sure that you remove the IntraWeb bundled edition (the one that comes with Delphi) using the Delphi installer itself (as described on that page).

Please let us know it it worked
Aaron Luo

Posts: 1
Registered: 1/12/18
Re: I got error - Requied package 'IntraWeb' not found
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 13, 2017 3:09 PM   in response to: Alexandre Machado in response to: Alexandre Machado
I met the same problem when I compiled the sgcWebSockets.

I use RAD Studio 10.2.1 Tokyo Architect Trial
I got the latest IntraWeb XIV (14.2.5) evaluation edition and install it.
When compile sgcWebSocket, I got error:
E2202 Required package 'Intraweb' not found

I'm sure i have installed the IntraWeb and the RAD Studio has checked the IntraWeb and added the IntraWeb components in IDE environment and included it in the library directory (menu Tools-->>Options-->>Environment Options-->>Delphi Option-->>Library) automatically.

I followed Eitan's instruction to do it again, the problem remained.

The full compile error was as follows:

Checking project dependencies...
Compiling sgcWebSocketsD10_2.dproj (Release, Win32)
dcc32 command line for "sgcWebSocketsD10_2.dpk"
c:\program files (x86)\embarcadero\studio\19.0\bin\dcc32.exe -$D0 -$L- -$Y- --no-config -M -Q -TX.bpl
-AGenerics.Collections=System.Generics.Collections;Generics.Defaults=System.Generics.Defaults;WinTypes=Winapi.Windows;WinProcs=Winapi.Windows;
DbiTypes=BDE;DbiProcs=BDE;DbiErrs=BDE -I..\libD10_2\win32;D:\Aaron\Delphi\sgcWebSockets\source;D:\Aaron\Delphi\sgcWebSockets\libD10_2\win32;
"c:\program files (x86)\embarcadero\studio\19.0\lib\Win32\release";C:\Users\rmaca\OneDrive\Documents\Embarcadero\Studio\19.0\Imports;"c:\program
files (x86)\embarcadero\studio\19.0\Imports";C:\Users\Public\Documents\Embarcadero\Studio\19.0\Dcp;"c:\program files
(x86)\embarcadero\studio\19.0\include";"C:\Users\rmaca\AppData\Roaming\IntraWeb XIV\LibD10_2W64";"C:\Users\rmaca\AppData\Roaming\IntraWeb
XIV\LibD10_2W32" -LEC:\Users\Public\Documents\Embarcadero\Studio\19.0\Bpl -LN..\dcp\win32 -NU..\libD10_2\win32 -NSWinapi;System.Win;Data.Win;
Datasnap.Win;Web.Win;Soap.Win;Xml.Win;Bde;Vcl;Vcl.Imaging;Vcl.Touch;Vcl.Samples;Vcl.Shell;System;Xml;Data;Datasnap;Web;Soap; -O..\libD10_2\win32;
D:\Aaron\Delphi\sgcWebSockets\source;D:\Aaron\Delphi\sgcWebSockets\libD10_2\win32;"c:\program files (x86)\embarcadero\studio\19.0\lib\Win32\release";
C:\Users\rmaca\OneDrive\Documents\Embarcadero\Studio\19.0\Imports;"c:\program files (x86)\embarcadero\studio\19.0\Imports";
C:\Users\Public\Documents\Embarcadero\Studio\19.0\Dcp;"c:\program files (x86)\embarcadero\studio\19.0\include";
"C:\Users\rmaca\AppData\Roaming\IntraWeb XIV\LibD10_2W64";"C:\Users\rmaca\AppData\Roaming\IntraWeb XIV\LibD10_2W32" -R..\libD10_2\win32;
D:\Aaron\Delphi\sgcWebSockets\source;D:\Aaron\Delphi\sgcWebSockets\libD10_2\win32;"c:\program files (x86)\embarcadero\studio\19.0\lib\Win32\release";
C:\Users\rmaca\OneDrive\Documents\Embarcadero\Studio\19.0\Imports;"c:\program files (x86)\embarcadero\studio\19.0\Imports";
C:\Users\Public\Documents\Embarcadero\Studio\19.0\Dcp;"c:\program files (x86)\embarcadero\studio\19.0\include";
"C:\Users\rmaca\AppData\Roaming\IntraWeb XIV\LibD10_2W64";"C:\Users\rmaca\AppData\Roaming\IntraWeb XIV\LibD10_2W32" -U..\libD10_2\win32;
D:\Aaron\Delphi\sgcWebSockets\source;D:\Aaron\Delphi\sgcWebSockets\libD10_2\win32;"c:\program files (x86)\embarcadero\studio\19.0\lib\Win32\release";
C:\Users\rmaca\OneDrive\Documents\Embarcadero\Studio\19.0\Imports;"c:\program files (x86)\embarcadero\studio\19.0\Imports";
C:\Users\Public\Documents\Embarcadero\Studio\19.0\Dcp;"c:\program files (x86)\embarcadero\studio\19.0\include";
"C:\Users\rmaca\AppData\Roaming\IntraWeb XIV\LibD10_2W64";"C:\Users\rmaca\AppData\Roaming\IntraWeb XIV\LibD10_2W32" -K00400000 --description:"SGC
WebSockets" -JL -NB..\dcp\Win32 -NH..\libD10_2\Win32 -NO..\libD10_2\Win32 sgcWebSocketsD10_2.dpk
[dcc32 Fatal Error] sgcWebSocketsD10_2.dpk(36): E2202 Required package 'Intraweb' not found

I didn't changed any code of sgcWebSockets. I wonder how to make it works.

Alexandre Machado wrote:
Haruhiko Takeshita wrote:
I use Delphi 10.1 Berlin Starter Edition.
I got IntraWeb XIV (14.0.63) and install it, and I got free license key from Purchase Point, set license key at install.
I want to use sgcWebSocket, so download it and install to my pc.
But, I got error:
E2022 Required package 'IntraWeb' not found.

uses
...
IntraWeb, <- error

I wonder why error on IntraWeb.
Do I need edit the line? or something less to comple it?

Hi,

Eitan nailed it. This page contains all the procedure to install it correctly: http://atozed.com/IntraWeb/Download/IntraWebBundledRemovalTool.EN.aspx

Just make sure that you remove the IntraWeb bundled edition (the one that comes with Delphi) using the Delphi installer itself (as described on that page).

Please let us know it it worked
Alexandre Machado

Posts: 1,754
Registered: 8/10/13
Re: I got error - Requied package 'IntraWeb' not found
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 18, 2017 12:11 AM   in response to: Aaron Luo in response to: Aaron Luo
E2202 Required package 'Intraweb' not found

A package named "IntraWeb" doesn't actually exist. Not sure how this package references IW runtime package.
I'll have to download and try it however, once this is not a free component pack and sources are not freely available, I'm somehow limited...
Thiago Rodrigues

Posts: 7
Registered: 7/4/08
Re: I got error - Requied package 'IntraWeb' not found
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 26, 2018 12:16 PM   in response to: Alexandre Machado in response to: Alexandre Machado
Alexandre Machado wrote:
E2202 Required package 'Intraweb' not found

A package named "IntraWeb" doesn't actually exist. Not sure how this package references IW runtime package.
I'll have to download and try it however, once this is not a free component pack and sources are not freely available, I'm somehow limited...

Hello,

I just found this topic, I´m having the same issue, has this been solved?

I was using XE8 with Intraweb 14.0.0, and I was able to install sgcWebSockets 4.1.5 flawlessly. But it wasn´t working (no connection to Websocket server), I thought it would be an issue with Intraweb. I updated it to 14.2.7 and now I´m having this "Required Package Intraweb not found" error when I try to install the sgcWebSockets again. I followed the instructions from Atozed.

There is also a second issue when I try to open a project made in Intraweb and sgc, an error message saying "Error reading IWServerController.AllowSubFolders does not exist".

Any ideas?
Chad Hower

Posts: 613
Registered: 3/2/07
Re: I got error - Requied package 'IntraWeb' not found
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 26, 2018 1:17 PM   in response to: Thiago Rodrigues in response to: Thiago Rodrigues
On 2/26/2018 4:16 PM, Thiago Rodrigues wrote:
I was using XE8 with Intraweb 14.0.0, and I was able to install sgcWebSockets 4.1.5 flawlessly. But it wasn´t working (no connection to Websocket server), I thought it would be an issue with Intraweb. I updated it to 14.2.7 and now I´m having this "Required Package Intraweb not found" error when I try to install the sgcWebSockets again. I followed the instructions from Atozed.

There is also a second issue when I try to open a project made in Intraweb and sgc, an error message saying "Error reading IWServerController.AllowSubFolders does not exist".

It sounds like:

1) sgcWebSockets is bound to a very old version of IntraWeb.

2) That you have 2 versions of IW installed. Did you remove the bundled
and run the cleaner first?
Thiago Rodrigues

Posts: 7
Registered: 7/4/08
Re: I got error - Requied package 'IntraWeb' not found
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 27, 2018 4:12 AM   in response to: Chad Hower in response to: Chad Hower
Chad Hower wrote:
On 2/26/2018 4:16 PM, Thiago Rodrigues wrote:
I was using XE8 with Intraweb 14.0.0, and I was able to install sgcWebSockets 4.1.5 flawlessly. But it wasn´t working (no connection to Websocket server), I thought it would be an issue with Intraweb. I updated it to 14.2.7 and now I´m having this "Required Package Intraweb not found" error when I try to install the sgcWebSockets again. I followed the instructions from Atozed.

There is also a second issue when I try to open a project made in Intraweb and sgc, an error message saying "Error reading IWServerController.AllowSubFolders does not exist".

It sounds like:

1) sgcWebSockets is bound to a very old version of IntraWeb.

2) That you have 2 versions of IW installed. Did you remove the bundled
and run the cleaner first?

2) That is strange, I followed Atozed´s instructions to remove the old one and use the bundle removal tool... I´ll try it again.

1) Is it OK to ignore those errors from the old version?
Chad Hower

Posts: 613
Registered: 3/2/07
Re: I got error - Requied package 'IntraWeb' not found
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 27, 2018 9:57 AM   in response to: Thiago Rodrigues in response to: Thiago Rodrigues
On 2/27/2018 8:12 AM, Thiago Rodrigues wrote:
1) Is it OK to ignore those errors from the old version?

Im not familiar with sgcWebSockets so I cannot say. But if it is working
against 14.0.0 that is many years old and not binary compat with other
releases.
Thiago Rodrigues

Posts: 7
Registered: 7/4/08
Re: I got error - Requied package 'IntraWeb' not found
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 27, 2018 11:15 AM   in response to: Chad Hower in response to: Chad Hower
Chad Hower wrote:
On 2/27/2018 8:12 AM, Thiago Rodrigues wrote:
1) Is it OK to ignore those errors from the old version?

Im not familiar with sgcWebSockets so I cannot say. But if it is working
against 14.0.0 that is many years old and not binary compat with other
releases.

Another thing is that Intraweb is working properly after the update, when I start an empty project. I only get the error msg during the SGC component install process.
Chad Hower

Posts: 613
Registered: 3/2/07
Re: I got error - Requied package 'IntraWeb' not found
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 28, 2018 6:20 AM   in response to: Thiago Rodrigues in response to: Thiago Rodrigues
On 2/27/2018 3:15 PM, Thiago Rodrigues wrote:
Another thing is that Intraweb is working properly after the update,
when I start an empty project. I only get the error msg during the
SGC component install process.

Do you have source for sgc?
Thiago Rodrigues

Posts: 7
Registered: 7/4/08
Re: I got error - Requied package 'IntraWeb' not found
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 28, 2018 8:32 AM   in response to: Chad Hower in response to: Chad Hower
Chad Hower wrote:
On 2/27/2018 3:15 PM, Thiago Rodrigues wrote:
Another thing is that Intraweb is working properly after the update,
when I start an empty project. I only get the error msg during the
SGC component install process.

Do you have source for sgc?

No...
Alexandre Machado

Posts: 1,754
Registered: 8/10/13
Re: I got error - Requied package 'IntraWeb' not found
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 27, 2018 11:09 PM   in response to: Thiago Rodrigues in response to: Thiago Rodrigues
Thiago Rodrigues wrote:
Alexandre Machado wrote:
E2202 Required package 'Intraweb' not found

A package named "IntraWeb" doesn't actually exist. Not sure how this package references IW runtime package.
I'll have to download and try it however, once this is not a free component pack and sources are not freely available, I'm somehow limited...

Hello,

I just found this topic, I´m having the same issue, has this been solved?

This is not a problem that Atozed can resolve. When someone creates a package "B" based in another package "A", when package "A" is updated (e.g. changing its interface), package "B" needs to be recompiled using newer version of package "A".
sgcWebSocket producers are the only one capable of doing it....
Thiago Rodrigues

Posts: 7
Registered: 7/4/08
Re: I got error - Requied package 'IntraWeb' not found
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 28, 2018 8:33 AM   in response to: Alexandre Machado in response to: Alexandre Machado
Alexandre Machado wrote:
Thiago Rodrigues wrote:
Alexandre Machado wrote:
E2202 Required package 'Intraweb' not found

A package named "IntraWeb" doesn't actually exist. Not sure how this package references IW runtime package.
I'll have to download and try it however, once this is not a free component pack and sources are not freely available, I'm somehow limited...

Hello,

I just found this topic, I´m having the same issue, has this been solved?

This is not a problem that Atozed can resolve. When someone creates a package "B" based in another package "A", when package "A" is updated (e.g. changing its interface), package "B" needs to be recompiled using newer version of package "A".
sgcWebSocket producers are the only one capable of doing it....

Yeah... I´m in contact with the developer, maybe he can provide a solution for that...
Thiago Rodrigues

Posts: 7
Registered: 7/4/08
Re: I got error - Requied package 'IntraWeb' not found
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 3, 2018 6:45 PM   in response to: Alexandre Machado in response to: Alexandre Machado
Alexandre Machado wrote:
Thiago Rodrigues wrote:
Alexandre Machado wrote:
E2202 Required package 'Intraweb' not found

A package named "IntraWeb" doesn't actually exist. Not sure how this package references IW runtime package.
I'll have to download and try it however, once this is not a free component pack and sources are not freely available, I'm somehow limited...

Hello,

I just found this topic, I´m having the same issue, has this been solved?

This is not a problem that Atozed can resolve. When someone creates a package "B" based in another package "A", when package "A" is updated (e.g. changing its interface), package "B" needs to be recompiled using newer version of package "A".
sgcWebSocket producers are the only one capable of doing it....

I got it working with Delphi 2010, after the developer told me the version he used.

If I had the source code (available for purchase), it is possible to recompile it and make it work with newer versions, like XE8, right?
Alexandre Machado

Posts: 1,754
Registered: 8/10/13
Re: I got error - Requied package 'IntraWeb' not found
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 3, 2018 11:52 PM   in response to: Thiago Rodrigues in response to: Thiago Rodrigues
I got it working with Delphi 2010, after the developer told me the version he used.

If I had the source code (available for purchase), it is possible to recompile it and make it work with newer versions, like XE8, right?

Yes, definitely. Probably you just need to recompile with proper IW version in place.
Thiago Rodrigues

Posts: 7
Registered: 7/4/08
Re: I got error - Requied package 'IntraWeb' not found
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 27, 2018 8:24 AM   in response to: Alexandre Machado in response to: Alexandre Machado
Alexandre Machado wrote:
I got it working with Delphi 2010, after the developer told me the version he used.

If I had the source code (available for purchase), it is possible to recompile it and make it work with newer versions, like XE8, right?

Yes, definitely. Probably you just need to recompile with proper IW version in place.

Great! Thanks for your support!
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02