Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: IWDBEdit can not write data to TField



Permlink Replies: 6 - Last Post: May 17, 2016 3:26 AM Last Post By: Alexandre Machado
Guest
IWDBEdit can not write data to TField
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 14, 2016 10:47 PM
IntraWeb Version: 14.0.56
Delphi XE / 10 Seattlo

IWDBEdit.Text not write TField.Value when cds.post.
Step:
1. Click IWDBNavigator1.Edit Button.
2. Edit FirstName value in TIWDBEdit component.
3. Click IWDBNavigator1.Post Button.

TIWDBEdit.Text rollback to original value.

Demo Source: [IWDBGridTest|https://db.tt/O6QQETlw]

Please help me. Thank you!
Alexandre Machado

Posts: 1,754
Registered: 8/10/13
Re: IWDBEdit can not write data to TField
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 15, 2016 4:20 AM   in response to: Guest in response to: Guest
Eden WU wrote:
IntraWeb Version: 14.0.56
Delphi XE / 10 Seattlo

IWDBEdit.Text not write TField.Value when cds.post.
Step:
1. Click IWDBNavigator1.Edit Button.
2. Edit FirstName value in TIWDBEdit component.
3. Click IWDBNavigator1.Post Button.

TIWDBEdit.Text rollback to original value.

Demo Source: [IWDBGridTest|https://db.tt/O6QQETlw]

Please help me. Thank you!

I'll take a look at this demo, but there is no such IW version. Probably 14.0.52?

Also, if you have 2 controls connected to the same field, the second control can post a different content and overwrite the first...
Guest
Re: IWDBEdit can not write data to TField
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 15, 2016 4:38 AM   in response to: Alexandre Machado in response to: Alexandre Machado
Alexandre Machado wrote:
Eden WU wrote:
IntraWeb Version: 14.0.56
Delphi XE / 10 Seattlo

IWDBEdit.Text not write TField.Value when cds.post.
Step:
1. Click IWDBNavigator1.Edit Button.
2. Edit FirstName value in TIWDBEdit component.
3. Click IWDBNavigator1.Post Button.

TIWDBEdit.Text rollback to original value.

Demo Source: [IWDBGridTest|https://db.tt/O6QQETlw]

Please help me. Thank you!

I'll take a look at this demo, but there is no such IW version. Probably 14.0.52?

Also, if you have 2 controls connected to the same field, the second control can post a different content and overwrite the first...

Yes! I am wrong, It is 14.0.52!
Thanks your solutions!
I will try it , thank you!
Guest
Re: IWDBEdit can not write data to TField
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 15, 2016 4:13 PM   in response to: Alexandre Machado in response to: Alexandre Machado
Alexandre Machado wrote:
Eden WU wrote:
IntraWeb Version: 14.0.56
Delphi XE / 10 Seattlo

IWDBEdit.Text not write TField.Value when cds.post.
Step:
1. Click IWDBNavigator1.Edit Button.
2. Edit FirstName value in TIWDBEdit component.
3. Click IWDBNavigator1.Post Button.

TIWDBEdit.Text rollback to original value.

Demo Source: [IWDBGridTest|https://db.tt/O6QQETlw]

Please help me. Thank you!

I'll take a look at this demo, but there is no such IW version. Probably 14.0.52?

Also, if you have 2 controls connected to the same field, the second control can post a different content and overwrite the first...

Hi Alexandre,

Editing value In TIWDBGrid (TIWDBGridColumn.Control = TIWDBEdit) will no effect when posting the modified values.

But, IWDBEdit controls without the IWDBGrid. It works!

Maybe my design idea is wrong?

Thank you, Alexandre!

Alexandre Machado

Posts: 1,754
Registered: 8/10/13
Re: IWDBEdit can not write data to TField
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 19, 2016 7:50 AM   in response to: Guest in response to: Guest
Hi,

Your design seems correct and it is not working as it should. I'm still investigating it. I should have an answer soon. If this is a bug, it will be fixed in the next version, but I still can't confirm it.
Guest
Re: IWDBEdit can not write data to TField
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 16, 2016 6:47 AM   in response to: Alexandre Machado in response to: Alexandre Machado
Alexandre Machado wrote:
Hi,

Your design seems correct and it is not working as it should. I'm still investigating it. I should have an answer soon. If this is a bug, it will be fixed in the next version, but I still can't confirm it.

The problem is not fix in IW14.0.53...

Alexandre Machado

Posts: 1,754
Registered: 8/10/13
Re: IWDBEdit can not write data to TField
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 17, 2016 3:26 AM   in response to: Guest in response to: Guest
Eden WU wrote:
Alexandre Machado wrote:
Hi,

Your design seems correct and it is not working as it should. I'm still investigating it. I should have an answer soon. If this is a bug, it will be fixed in the next version, but I still can't confirm it.

The problem is not fix in IW14.0.53...


Seems that you was able to install it then?

The issue you reported is not fixed right now. I could recreate the issue here, but the fix is not ready yet. It is in our list and we are working on it.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02