Watch, Follow, &
Connect with Us

Welcome, Guest
Guest Settings
Help

Thread: 10 Seattle / Update 1 Open File Problem?


This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 3 - Last Post: Mar 9, 2016 12:20 PM Last Post By: Alexandre Machado
Chris LeFebvre

Posts: 64
Registered: 10/24/99
10 Seattle / Update 1 Open File Problem?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 30, 2015 2:08 PM
I've noticed strange behavior within Delphi 10 Seattle and update 1 didn't do anything to fix it. The problem is that since Delphi 6 I've developed a large number of projects and it's not unusual when I'm working on something new for me to use File / Open to open a .pas file / form (from another project) and copy code or elements from the form and paste them into the project I'm working on and then File / Close when I'm finished. Within the first 10-15 minutes of starting the IDE I don't have any problem doing that but suddenly I'll go to File / Open and the IDE responds with a dialog that says "Save changes to XXXXX?" (like it wants to close the current project before opening a file) or sometimes the IDE just closes i.e. I click or use Alt-F, O and the IDE closes without ever displaying a dialog but it's not a crash as there's no information to that effect in the system application log.

I was wondering if anyone else has seen this or can reproduce this problem?
Remy Lebeau (Te...


Posts: 8,471
Registered: 12/23/01
Re: 10 Seattle / Update 1 Open File Problem?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 30, 2015 2:54 PM   in response to: Chris LeFebvre in response to: Chris LeFebvre
Chris wrote:

Within the first 10-15 minutes of starting the IDE I don't have any problem
doing that but suddenly I'll go to File / Open and the IDE responds with a
dialog that says "Save changes to XXXXX?" (like it wants to close the
current project before opening a file) or sometimes the IDE just closes
i.e.
I click or use Alt-F, O and the IDE closes without ever displaying a dialog

The File/Open and File/Exit actions have been swapped. That is a known issue
related to the IDE's copy protection:

Action event handlers for the File|Open and File|Exit menu handlers are swapped
http://qc.embarcadero.com/wc/qcmain.aspx?d=124919
http://support.embarcadero.com/article/44075

This happens when any non-Embarcadero files have been placed in the IDE's
\bin folder, where they do not belong. Only official Embarcadero files are
allowed in that folder.

This issue has existed since at least XE6, and someone always manages to
encounter it in each new release.

--
Remy Lebeau (TeamB)
Chris LeFebvre

Posts: 64
Registered: 10/24/99
Re: 10 Seattle / Update 1 Open File Problem?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 30, 2015 9:21 PM   in response to: Remy Lebeau (Te... in response to: Remy Lebeau (Te...
Ok, I tried looking this problem up any number of different ways before posting. I'm sorry I must not have hit upon the right search terms to turn up other posts on this subject.
Alexandre Machado

Posts: 1,600
Registered: 8/10/13
Re: 10 Seattle / Update 1 Open File Problem?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 9, 2016 12:20 PM   in response to: Chris LeFebvre in response to: Chris LeFebvre
Chris LeFebvre wrote:
I've noticed strange behavior within Delphi 10 Seattle and update 1 didn't do anything to fix it. The problem is that since Delphi 6 I've developed a large number of projects and it's not unusual when I'm working on something new for me to use File / Open to open a .pas file / form (from another project) and copy code or elements from the form and paste them into the project I'm working on and then File / Close when I'm finished. Within the first 10-15 minutes of starting the IDE I don't have any problem doing that but suddenly I'll go to File / Open and the IDE responds with a dialog that says "Save changes to XXXXX?" (like it wants to close the current project before opening a file) or sometimes the IDE just closes i.e. I click or use Alt-F, O and the IDE closes without ever displaying a dialog but it's not a crash as there's no information to that effect in the system application log.

I was wondering if anyone else has seen this or can reproduce this problem?

Not sure if this is the cause, but have in mind to remove ANY 3rd party DLL which was not installed by Delphi installer from the Delphi\Bin directory. There can't be any "foreign" DLLs sitting there...
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02