Watch, Follow, &
Connect with Us

Please visit our new home
community.embarcadero.com.


Welcome, Guest
Guest Settings
Help

Thread: Why are drop-down menus so slow to load?


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 2 - Last Post: Nov 20, 2015 5:01 PM Last Post By: Lance Rasmussen Threads: [ Previous | Next ]
Lance Rasmussen

Posts: 5
Registered: 7/22/14
Why are drop-down menus so slow to load?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 19, 2015 10:11 AM
The drop-down menu loading for edn.embarcadero.com is horrifically slow at around 15-30 seconds using several different browsers and several different machines from several different ISP's. On the forums site, since the changeover to a new server, the menu loading is as expected and the forums have been the snappiest I've seen. But on the other EDN's, you have to wait some time before ability to use a sub-menu.

What's going on? I've cleared cookies and all that. Even disabled A/V and no joy.
David Clegg

Posts: 90
Registered: 2/11/01
Re: Why are drop-down menus so slow to load?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 19, 2015 4:11 PM   in response to: Lance Rasmussen in response to: Lance Rasmussen
Lance Rasmussen wrote:

The drop-down menu loading for edn.embarcadero.com is horrifically
slow at around 15-30 seconds using several different browsers and
several different machines from several different ISP's. On the
forums site, since the changeover to a new server, the menu loading
is as expected and the forums have been the snappiest I've seen. But
on the other EDN's, you have to wait some time before ability to use
a sub-menu.

What's going on? I've cleared cookies and all that. Even disabled
A/V and no joy.

There appears to be some site tracking code that is getting in the way.
One of the resources it is trying to resolves is timing out. I'd hazard
a guess that the javascript required for the menus isn't fully resolved
until after this unrelated resource fetching has timed out.

This would be in a common page template, which is why it would affect
many sites (Forums has a slightly tweaked version of this).

I'd recommend sending David Intersimone an email to see if he can get a
resource to look into it.

(Disclaimer: Theory formed after 2 minutes of not so deep spelunking of
the page source)

Lance Rasmussen

Posts: 5
Registered: 7/22/14
Re: Why are drop-down menus so slow to load?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 20, 2015 5:01 PM   in response to: David Clegg in response to: David Clegg
It looks like they are using addthis.com javascript, which has been reported to slow other websites dramatically. There's a resolution that delays activating those items to be after the page loads.

I pinged David.

Thanks David.

David Clegg wrote:
Lance Rasmussen wrote:

The drop-down menu loading for edn.embarcadero.com is horrifically
slow at around 15-30 seconds using several different browsers and
several different machines from several different ISP's. On the
forums site, since the changeover to a new server, the menu loading
is as expected and the forums have been the snappiest I've seen. But
on the other EDN's, you have to wait some time before ability to use
a sub-menu.

What's going on? I've cleared cookies and all that. Even disabled
A/V and no joy.

There appears to be some site tracking code that is getting in the way.
One of the resources it is trying to resolves is timing out. I'd hazard
a guess that the javascript required for the menus isn't fully resolved
until after this unrelated resource fetching has timed out.

This would be in a common page template, which is why it would affect
many sites (Forums has a slightly tweaked version of this).

I'd recommend sending David Intersimone an email to see if he can get a
resource to look into it.

(Disclaimer: Theory formed after 2 minutes of not so deep spelunking of
the page source)

Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02