Watch, Follow, &
Connect with Us

Please visit our new home
community.embarcadero.com.


Welcome, Guest
Guest Settings
Help

Thread: BDE Broken with C++ Builder 5. How to get it to work properly with Windows



Permlink Replies: 6 - Last Post: Jun 30, 2014 9:41 AM Last Post By: Frank M. Cook
John MacDonald

Posts: 179
Registered: 3/22/98
BDE Broken with C++ Builder 5. How to get it to work properly with Windows
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 5, 2014 9:38 PM
I've been having issues with the Borland Database engine for some time. I get a General protection fault when shutting down.
While trying to setup a directory that is not part of program files I have broken the whole thing.
I believe it is because of the Newer file systems with XP and more recently with Win 7.

Does someone have a listing of the locations and then settings used to get it to work properly?

Thanks

John

--
JMAC out
John MacDonald

Posts: 179
Registered: 3/22/98
Re: BDE Broken with C++ Builder 5. How to get it to work properly with Windows
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 7, 2014 5:43 AM   in response to: John MacDonald in response to: John MacDonald
Ok I have it working again, but, still getting protection errors.

After I close down the database desktop I get a general protection fault.
I'm guessing this is when the software tries to make entries into the saved environment.

I guess I have learned to live with it except that recently I realized that the OS is causing this with the security in the directories where the software does the install.
We are moving to XE6 soon and likely we wont have to worry about this problem.

John


John MacDonald wrote:
I've been having issues with the Borland Database engine for some time. I get a General protection fault when shutting down.
While trying to setup a directory that is not part of program files I have broken the whole thing.
I believe it is because of the Newer file systems with XP and more recently with Win 7.

Does someone have a listing of the locations and then settings used to get it to work properly?

Thanks

John

--
JMAC out

--
JMAC out
quinn wildman

Posts: 856
Registered: 12/2/99
Re: BDE Broken with C++ Builder 5. How to get it to work properly with Windows
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 9, 2014 8:40 AM   in response to: John MacDonald in response to: John MacDonald
John MacDonald wrote:
We are moving to XE6 soon and likely we wont have to worry about this problem.

No changes in BDE in a very long time. It is unlikely XE6 will make any
difference with a BDE issue.
Frank M. Cook

Posts: 5
Registered: 9/22/00
Re: BDE Broken with C++ Builder 5. How to get it to work properly with Windows
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 24, 2014 11:32 AM   in response to: John MacDonald in response to: John MacDonald
In BDE Admin make sure the Win3.1 Option is checked. That puts everything
in the config file rather than the registry. Also make sure everyone has
rights to the config file.

--
Frank M. Cook
www.funeralhomesoftware.info
"John MacDonald" wrote in message news:679293 at forums dot embarcadero dot com...
Ok I have it working again, but, still getting protection errors.

After I close down the database desktop I get a general protection fault.
I'm guessing this is when the software tries to make entries into the
saved environment.

I guess I have learned to live with it except that recently I realized
that the OS is causing this with the security in the directories where the
software does the install.
We are moving to XE6 soon and likely we wont have to worry about this
problem.

John


John MacDonald wrote:
I've been having issues with the Borland Database engine for some time. I
get a General protection fault when shutting down.
While trying to setup a directory that is not part of program files I
have broken the whole thing.
I believe it is because of the Newer file systems with XP and more
recently with Win 7.

Does someone have a listing of the locations and then settings used to
get it to work properly?

Thanks

John

--
JMAC out

--
JMAC out
John MacDonald

Posts: 179
Registered: 3/22/98
Re: BDE Broken with C++ Builder 5. How to get it to work properly with Windows
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 26, 2014 5:42 PM   in response to: Frank M. Cook in response to: Frank M. Cook
Hello Frank:
It's been a while since I posted this. Thanks for your reply.
I'm sorry I didn't find the Win3.1 option in bde admin.
Is this a change to be made in a file or is it supposed to be in the configuration and then System tab?

John


Frank M. Cook wrote:
In BDE Admin make sure the Win3.1 Option is checked. That puts everything
in the config file rather than the registry. Also make sure everyone has
rights to the config file.

--
Frank M. Cook
www.funeralhomesoftware.info
"John MacDonald" wrote in message news:679293 at forums dot embarcadero dot com...
Ok I have it working again, but, still getting protection errors.

After I close down the database desktop I get a general protection fault.
I'm guessing this is when the software tries to make entries into the
saved environment.

I guess I have learned to live with it except that recently I realized
that the OS is causing this with the security in the directories where the
software does the install.
We are moving to XE6 soon and likely we wont have to worry about this
problem.

John


John MacDonald wrote:
I've been having issues with the Borland Database engine for some time. I
get a General protection fault when shutting down.
While trying to setup a directory that is not part of program files I
have broken the whole thing.
I believe it is because of the Newer file systems with XP and more
recently with Win 7.

Does someone have a listing of the locations and then settings used to
get it to work properly?

Thanks

John

--
JMAC out

--
JMAC out

--
JMAC out
Leslie Milburn

Posts: 12
Registered: 10/29/00
Re: BDE Broken with C++ Builder 5. How to get it to work properly with Windows
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 26, 2014 7:15 PM   in response to: John MacDonald in response to: John MacDonald
<John MacDonald> wrote:

I'm sorry I didn't find the Win3.1 option in bde admin.
Is this a change to be made in a file or is it supposed to be in the
configuration and then System tab?

John

From the Object - Options Menu

Leslie.
Frank M. Cook

Posts: 5
Registered: 9/22/00
Re: BDE Broken with C++ Builder 5. How to get it to work properly with Windows
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 30, 2014 9:41 AM   in response to: John MacDonald in response to: John MacDonald
You click on Objects and then at the bottom click on Options.

It is also a registry key HKEY_LOCAL_MACHINE, Software\Borland\Database
Engine, SaveConfig. set the value to WIN31. use all caps.

I set the value and give full rights to idapi32.cfg in an installation
program I wrote that wraps around the bde installation routine. I use QSetup
for my installation scripts. if anyone uses QSetup and needs help with a
BDE script, they can contact me directly.

--
Frank M. Cook
www.funeralhomesoftware.info
"John MacDonald" wrote in message news:682796 at forums dot embarcadero dot com...
Hello Frank:
It's been a while since I posted this. Thanks for your reply.
I'm sorry I didn't find the Win3.1 option in bde admin.
Is this a change to be made in a file or is it supposed to be in the
configuration and then System tab?

John


Frank M. Cook wrote:
In BDE Admin make sure the Win3.1 Option is checked. That puts
everything
in the config file rather than the registry. Also make sure everyone has
rights to the config file.

--
Frank M. Cook
www.funeralhomesoftware.info
"John MacDonald" wrote in message news:679293 at forums dot embarcadero dot com...
Ok I have it working again, but, still getting protection errors.

After I close down the database desktop I get a general protection
fault.
I'm guessing this is when the software tries to make entries into the
saved environment.

I guess I have learned to live with it except that recently I realized
that the OS is causing this with the security in the directories where
the
software does the install.
We are moving to XE6 soon and likely we wont have to worry about this
problem.

John


John MacDonald wrote:
I've been having issues with the Borland Database engine for some
time. I
get a General protection fault when shutting down.
While trying to setup a directory that is not part of program files I
have broken the whole thing.
I believe it is because of the Newer file systems with XP and more
recently with Win 7.

Does someone have a listing of the locations and then settings used to
get it to work properly?

Thanks

John

--
JMAC out

--
JMAC out

--
JMAC out
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02