Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Why do I get an error when accessing TGrid.DefautDrawColumnCell


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 3 - Last Post: Mar 22, 2018 11:35 AM Last Post By: Bob Rasmusens
Bob Rasmusens

Posts: 10
Registered: 5/18/00
Why do I get an error when accessing TGrid.DefautDrawColumnCell  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 21, 2018 2:34 PM
I have just updated to Tokyo Rad Studio 10.2.2 (10.2 Version 25.0.29899.2631 )
After installation I am getting the following error in a Multi Device Application when I try to compile it.
TGrid does not contain a member named 'DefaultDrawColumnCell' at line...
As far as I can see in the documentation this is still present.
Any help would be appreciated

I have edited this to correct the typo for 'DefaultDrawColumnCell' - missed l in Default.

Also this application that I am compiling worked fine before the update.

Edited by: Bob Rasmusens on Mar 21, 2018 3:06 PM
Dave Nottage

Posts: 1,850
Registered: 1/7/00
Re: Why do I get an error when accessing TGrid.DefautDrawColumnCell  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 21, 2018 2:46 PM   in response to: Bob Rasmusens in response to: Bob Rasmusens
Bob Rasmusens wrote:

I have just updated to Tokyo Rad Studio 10.2.2 (10.2 Version 25.0.29899.2631 )
After installation I am getting the following error in a Multi Device Application when I try to compile it.
TGrid does not contain a member named 'DefautDrawColumnCell' at line...
As far as I can see in the documentation this is still present.
Any help would be appreciated

Not with that spelling it doesn't. It's: DefaultDrawColumnCell

--
Dave Nottage [MVP, TeamB]
Find hints, tips and tricks at Delphi Worlds blog: http://www.delphiworlds.com
Dave Nottage

Posts: 1,850
Registered: 1/7/00
Re: Why do I get an error when accessing TGrid.DefautDrawColumnCell [Edit]  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 21, 2018 3:36 PM   in response to: Bob Rasmusens in response to: Bob Rasmusens
Bob Rasmusens wrote:

I have edited this to correct the typo for 'DefaultDrawColumnCell' - missed l in Default.

Also this application that I am compiling worked fine before the update.

The method is definitely public in 10.2.3. You might need to show the code that does not compile.

--
Dave Nottage [MVP, TeamB]
Find hints, tips and tricks at Delphi Worlds blog: http://www.delphiworlds.com
Bob Rasmusens

Posts: 10
Registered: 5/18/00
Re: Why do I get an error when accessing TGrid.DefautDrawColumnCell  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 22, 2018 11:35 AM   in response to: Bob Rasmusens in response to: Bob Rasmusens
I have done a bit more research and determined that
TGrid.DefaultDrawColumnCell disappeared in 10.1 Berlin and from what I can see was replaced with TColumn.DefaultDrawCell.
The context help for 10.0 Seattle shows TGrid.DefaultDrawColumnCell but it does not appear in 10.1 Berlin.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02