Watch, Follow, &
Connect with Us

Please visit our new home
community.embarcadero.com.


Welcome, Guest
Guest Settings
Help

Thread: Can't bind address: Address already in use. Exiting ?


This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 3 - Last Post: Mar 26, 2018 3:27 AM Last Post By: Frederic Bell Threads: [ Previous | Next ]
GAI CHEW KAI

Posts: 53
Registered: 7/29/04
Can't bind address: Address already in use. Exiting ?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 9, 2017 5:20 AM
Embarcadero® C++Builder 10.2 Version 25.0.26309.314
Android 7.0.1
Microsoft Windows 10 x64 Pro [Version 10.0.14393]

I have changed a project name eg. "MyProject" ---> "My Project" then each time I deploy to Android phone from IDE I received this error message:

Can' bind address: Address already in use. Exiting.

I have tried the following.

1. Manually remove the installed app from the Android phone.

2. put in the -cleaninstall under the IDE->Run->Parameter.

But the result still keeps prompting with the error message above.

Please advise.
GAI CHEW KAI

Posts: 53
Registered: 7/29/04
Re: Can't bind address: Address already in use. Exiting ?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 9, 2017 1:30 PM   in response to: GAI CHEW KAI in response to: GAI CHEW KAI
...I do the following methods, the next deploy working fine.

1. Manually uninstalled the App on the Android phone.
2. Re-start the Android phone.
3. At the project directory, grep "My Project" *, if found edit and remove the line.
4. Remove any redundant files ( those renamed old compiled cpp .o generated files ).
5. Select "clean" at the project group.
6. Click run debug.
7. DONE.

Somehow, I hopes this work for others if found similar error.
Frederic Bell

Posts: 5
Registered: 12/8/01
Re: Can't bind address: Address already in use. Exiting ?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 16, 2018 5:22 AM   in response to: GAI CHEW KAI in response to: GAI CHEW KAI
In Android - Android SDK ver 24.3.3 32bit - Libraries , right click and "Revert System Files to default".
That seems to have solved the problem for me.
Frederic Bell

Posts: 5
Registered: 12/8/01
Re: Can't bind address: Address already in use. Exiting ?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 26, 2018 3:27 AM   in response to: GAI CHEW KAI in response to: GAI CHEW KAI
I got this problem again! It appeared out of nowhere (after nothing unusual), just the next deploy of many today already. I managed to solve it by using -autolaunch in the Run->Parameters.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02