Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: GDS db change port on Windows 10 2 back to 3050



Permlink Replies: 2 - Last Post: Feb 9, 2018 9:53 PM Last Post By: Jeff Overcash (...
Christopher Hart

Posts: 1
Registered: 3/19/00
GDS db change port on Windows 10 2 back to 3050
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 9, 2018 10:03 AM
I do not know where the Interbase client XE7 is getting its configuration information from. All of the articals that I have looked up do not seem to apply to version 10.2
I need to change the port from 3054 to 3050 the default.

Interbase has been on and off this machine. Version 2017 was loaded for a short time but need to get back to XE7 for client compatibility. The Developers version of Interbase included with Rad Studio 10.2 (Tokyo is what I need to run.
The current port number that fails to connect needs to be changed.
quinn wildman

Posts: 856
Registered: 12/2/99
Re: GDS db change port on Windows 10 2 back to 3050
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 9, 2018 12:39 PM   in response to: Christopher Hart in response to: Christopher Hart
What are you using to connect? Most likely, what needs to happen is the connection string in the application you using needs to change.

Christopher Hart wrote:
I do not know where the Interbase client XE7 is getting its configuration information from. All of the articals that I have looked up do not seem to apply to version 10.2
I need to change the port from 3054 to 3050 the default.

Interbase has been on and off this machine. Version 2017 was loaded for a short time but need to get back to XE7 for client compatibility. The Developers version of Interbase included with Rad Studio 10.2 (Tokyo is what I need to run.
The current port number that fails to connect needs to be changed.
Jeff Overcash (...

Posts: 1,529
Registered: 9/23/99
Re: GDS db change port on Windows 10 2 back to 3050
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 9, 2018 9:53 PM   in response to: Christopher Hart in response to: Christopher Hart
On 2/9/2018 1:03 PM, Christopher Hart wrote:
I do not know where the Interbase client XE7 is getting its configuration information from. All of the articals that I have looked up do not seem to apply to version 10.2
I need to change the port from 3054 to 3050 the default.

Interbase has been on and off this machine. Version 2017 was loaded for a short time but need to get back to XE7 for client compatibility. The Developers version of Interbase included with Rad Studio 10.2 (Tokyo is what I need to run.
The current port number that fails to connect needs to be changed.

If this is happening inside the IDE you probably have the default IBPROTOCOL
environment variable still in the configuration. go into the settings and find
the environment variables and remove the IBPROTOCOL.

Personally I have all my instances set to port 3050 and set them all to manual
except for my main default one (which for my primary customer is XE3).
Switching is as simple as stopping the running server and starting the one I want.

--
Jeff Overcash (TeamB)
(Please do not email me directly unless asked. Thank You)
Learning is finding out what you already know. Doing is demonstrating that you
know it. Teaching is reminding others that they know it as well as you. We are
all leaners, doers, teachers. (R Bach)
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02