Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: August 2018: New apps required to target API level 26 (Android 8.0) or high


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 3 - Last Post: Feb 1, 2018 2:42 AM Last Post By: Dalija Prasnikar Threads: [ Previous | Next ]
Bart Kindt

Posts: 33
Registered: 12/16/07
August 2018: New apps required to target API level 26 (Android 8.0) or high  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 30, 2018 2:58 PM
https://android-developers.googleblog.com/2017/12/improving-app-security-and-performance.html

So what is the situation with this?
My latest Delphi 10.2.2 still uses 24.3.3 32 bit...

Bart

---
Bart Kindt
CEO & Developer
SARTrack Limited New Zealand
http://www.sartrack.nz
Remy Lebeau (Te...


Posts: 9,447
Registered: 12/23/01
Re: August 2018: New apps required to target API level 26 (Android 8.0) or high  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 30, 2018 4:06 PM   in response to: Bart Kindt in response to: Bart Kindt
Bart Kindt wrote:

So what is the situation with this?

No official word on this yet. Or on the added requirement that Android
apps must support 64bit soon. Embarcadero doesn't have a 64bit Android
compiler on the radar yet.

--
Remy Lebeau (TeamB)
loki loki

Posts: 787
Registered: 7/1/02
Re: August 2018: New apps required to target API level 26 (Android 8.0) or high  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 31, 2018 4:21 AM   in response to: Bart Kindt in response to: Bart Kindt
https://android-developers.googleblog.com/2017/12/improving-app-security-and-performance.html

So what is the situation with this?
My latest Delphi 10.2.2 still uses 24.3.3 32 bit...

Bart

That is a big problem because delphi don't support right now api level
26 in target SDK (i try and have many problems)

Off course it doesn't support 64 bit compilation either, and afraid to
be in 2019 in the same situation as we are now with macOS and we was
with iOS :(

i create a bug report, please vote for it !

https://quality.embarcadero.com/browse/RSP-19857
Dalija Prasnikar

Posts: 2,325
Registered: 11/9/99
Re: August 2018: New apps required to target API level 26 (Android 8.0) or high  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 1, 2018 2:42 AM   in response to: Bart Kindt in response to: Bart Kindt
Bart Kindt wrote:
https://android-developers.googleblog.com/2017/12/improving-app-security-and-performance.html

So what is the situation with this?
My latest Delphi 10.2.2 still uses 24.3.3 32 bit...

Quoting Marco Cantu from linked QP report

https://quality.embarcadero.com/browse/RSP-19857

"Thanks for the report. We are fully aware of these deadline and are aligning our
internal plans with them. We'll soon also publish a blog post with indications of our
roadmap updates, and later a full new roadmap."

--
Dalija Prasnikar
Embarcadero MVP
https://dalijap.blogspot.com/
Delphi Memory Management for Classic and ARC Compilers
https://dalija.prasnikar.info/delphimm/
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02