Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: 14.2.5 is incompatible with delphi 10.2.2 2004 ?


This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 11 - Last Post: Jan 7, 2018 12:42 PM Last Post By: Alexandre Machado
tonzi zhou

Posts: 8
Registered: 3/1/14
14.2.5 is incompatible with delphi 10.2.2 2004 ?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 20, 2017 2:38 AM
[http://downloads.atozed.com/intraweb/iw14.2.5.exe]

is incompatible with Delphi 10.2.2 2004.

[dcc32 Fatal Error] dclIntraweb_14_D10_2.dpk(62): F2051 Unit IWDsnStrListVisualizer was compiled with a different version of ToolsAPI.IOTADebuggerVisualizer

pls, when time to release newest version?
Chad Hower

Posts: 613
Registered: 3/2/07
Re: 14.2.5 is incompatible with delphi 10.2.2 2004 ? [Edit]  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 20, 2017 7:26 AM   in response to: tonzi zhou in response to: tonzi zhou
On 12/20/2017 6:44 AM, tonzi zhou wrote:
is incompatible with Delphi 10.2.2 2004.

[dcc32 Fatal Error] dclIntraweb_14_D10_2.dpk(62): F2051 Unit IWDsnStrListVisualizer was compiled with a different version of ToolsAPI.IOTADebuggerVisualizer

pls, when time to release newest version?

Did you install 10.2.2 1978 prior to 2004?
Alexandre Machado

Posts: 1,754
Registered: 8/10/13
Re: 14.2.5 is incompatible with delphi 10.2.2 2004 ?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 20, 2017 2:34 PM   in response to: tonzi zhou in response to: tonzi zhou
tonzi zhou wrote:
[http://downloads.atozed.com/intraweb/iw14.2.5.exe]

is incompatible with Delphi 10.2.2 2004.

[dcc32 Fatal Error] dclIntraweb_14_D10_2.dpk(62): F2051 Unit IWDsnStrListVisualizer was compiled with a different version of ToolsAPI.IOTADebuggerVisualizer

pls, when time to release newest version?

14.2.5 (And previous versions) should be binary compatible with 10.2.2.2004.

Are you trying to recompile IntraWeb design time packages? This is not required (and not possible at all). Your packages should load just fine and you should be able to rebuild your application as always.

tonzi zhou

Posts: 8
Registered: 3/1/14
Re: 14.2.5 is incompatible with delphi 10.2.2 2004 ?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 21, 2017 2:56 AM   in response to: Alexandre Machado in response to: Alexandre Machado
14.2.5 (And previous versions) should be binary compatible with 10.2.2.2004.

Are you trying to recompile IntraWeb design time packages? This is not required (and not possible at all). Your packages should load just fine and you should be able to rebuild your application as always.

Obviously, component compatibility issues exist.
No service customer mentality, not the strict requirements of their own products, Atozed will go farther hard.
Eitan Arbel

Posts: 508
Registered: 2/24/13
Re: 14.2.5 is incompatible with delphi 10.2.2 2004 ?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 21, 2017 3:20 AM   in response to: tonzi zhou in response to: tonzi zhou
No service customer mentality, not the strict requirements of their own products, Atozed will go farther hard.

dude... you blame Atozed for embarcadero's bug...?

Alexandre and Chad both asked you something and you didn't really answered.

did you COMPLETELY remove ALL the "left overs" of 1978 (including cleaning the registry), and then install 2004?
if 2004 fixed the problem for other iw users, then it's not an intraweb problem, right?

and just to be sure : run the Bundled Removal Tool, and clean reinstall iw again.
Chad Hower

Posts: 613
Registered: 3/2/07
Re: 14.2.5 is incompatible with delphi 10.2.2 2004 ?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 21, 2017 6:08 AM   in response to: tonzi zhou in response to: tonzi zhou
On 12/21/2017 6:56 AM, tonzi zhou wrote:
Are you trying to recompile IntraWeb design time packages? This is
not required (and not possible at all). Your packages should load
just fine and you should be able to rebuild your application as
always.

Obviously, component compatibility issues exist. No service customer
mentality, not the strict requirements of their own products, Atozed
will go farther hard.

You ignored my question. Its very difficult to provide you with support
if you ignore my technical queries.

EMBT released a broken build. That is not our fault.

I need to verify if you had 1978 or not. Also why are you trying to
rebuild the design time package?
tonzi zhou

Posts: 8
Registered: 3/1/14
Re: 14.2.5 is incompatible with delphi 10.2.2 2004 ?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 22, 2017 4:09 PM   in response to: Chad Hower in response to: Chad Hower
I need to verify if you had 1978 or not. Also why are you trying to
rebuild the design time package?

First of all, don't mention 1978. My environment is a new 2004, my problem is very clear.
Second, I have a custom component that needs to call Dclintraweb and must be recompiled, you understand?
Chad Hower

Posts: 613
Registered: 3/2/07
Re: 14.2.5 is incompatible with delphi 10.2.2 2004 ?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 23, 2017 7:15 AM   in response to: tonzi zhou in response to: tonzi zhou
On 12/22/2017 8:09 PM, tonzi zhou wrote:
First of all, don't mention 1978. My environment is a new 2004, my problem is very clear.

No. Its not clear because you are being rather evasive in answering
questions designed to help you. I asked if you had ever installed 1978
first and it took about 4x of asking for you to answer it.

Second, I have a custom component that needs to call Dclintraweb and must be recompiled, you understand?

Why do you need to recompile this for a custom component? If you have a
new component simply make your own new design time package. Even if you
could recompile our design time package to add your component that is
not the proper method to do so.
tonzi zhou

Posts: 8
Registered: 3/1/14
Re: 14.2.5 is incompatible with delphi 10.2.2 2004 ?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 4, 2018 1:26 AM   in response to: Chad Hower in response to: Chad Hower
Now I have to recompile with version 10.2 and then overwrite this file in 10.2.2.
version 14.2.6 is also implemented in this way.
Alexandre Machado

Posts: 1,754
Registered: 8/10/13
Re: 14.2.5 is incompatible with delphi 10.2.2 2004 ?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 7, 2018 12:35 PM   in response to: tonzi zhou in response to: tonzi zhou
tonzi zhou wrote:
14.2.5 (And previous versions) should be binary compatible with 10.2.2.2004.

Are you trying to recompile IntraWeb design time packages? This is not required (and not possible at all). Your packages should load just fine and you should be able to rebuild your application as always.

Obviously, component compatibility issues exist.
No service customer mentality, not the strict requirements of their own products, Atozed will go farther hard.

1- All compatibility issues were caused by a bug in Delphi update itself, not IntraWeb.
2- You are not supposed to rebuild IntraWeb design time packages. They should install just fine with 10.2.2.2004. If they are not installing, you have some environment issue there, maybe an old incompatible version of Delphi, IW or some dependent package (TMS, CG, etc).
Alexandre Machado

Posts: 1,754
Registered: 8/10/13
Re: 14.2.5 is incompatible with delphi 10.2.2 2004 ?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 7, 2018 12:35 PM   in response to: tonzi zhou in response to: tonzi zhou
tonzi zhou wrote:
14.2.5 (And previous versions) should be binary compatible with 10.2.2.2004.

Are you trying to recompile IntraWeb design time packages? This is not required (and not possible at all). Your packages should load just fine and you should be able to rebuild your application as always.

Obviously, component compatibility issues exist.
No service customer mentality, not the strict requirements of their own products, Atozed will go farther hard.

1- All compatibility issues were caused by a bug in Delphi update itself, not IntraWeb.
2- You are not supposed to rebuild IntraWeb design time packages. They should install just fine with 10.2.2.2004. If they are not installing, you have some environment issue there, maybe an old incompatible version of Delphi, IW or some dependent package (TMS, CG, etc).
Alexandre Machado

Posts: 1,754
Registered: 8/10/13
Re: 14.2.5 is incompatible with delphi 10.2.2 2004 ?  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 7, 2018 12:42 PM   in response to: tonzi zhou in response to: tonzi zhou
tonzi zhou wrote:
14.2.5 (And previous versions) should be binary compatible with 10.2.2.2004.

Are you trying to recompile IntraWeb design time packages? This is not required (and not possible at all). Your packages should load just fine and you should be able to rebuild your application as always.

Obviously, component compatibility issues exist.
No service customer mentality, not the strict requirements of their own products, Atozed will go farther hard.

1- All compatibility issues were caused by a bug in Delphi update itself, not IntraWeb.
2- You are not supposed to rebuild IntraWeb design time packages. They should install just fine with 10.2.2.2004. If they are not installing, you have some environment issue there, maybe an old incompatible version of Delphi, IW or some dependent package (TMS, CG, etc).
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02