Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: XE7 tethering apps won't pair with 10.2 apps


This question is answered.


Permlink Replies: 2 - Last Post: Nov 15, 2017 3:35 AM Last Post By: Antonio Tortosa...
Michael Leahy

Posts: 239
Registered: 5/9/07
XE7 tethering apps won't pair with 10.2 apps  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 13, 2017 3:42 PM
I cannot get the simplest app or any of the sample apps to pair if one is made by Delphi XE7 and the other is made by Delphi 10.2.

What would prevent XE7 and 10.2 apps from pairing?
Ronald Klitsche

Posts: 326
Registered: 8/26/01
Re: XE7 tethering apps won't pair with 10.2 apps
Helpful
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 14, 2017 2:04 AM   in response to: Michael Leahy in response to: Michael Leahy
Michael Leahy wrote:
I cannot get the simplest app or any of the sample apps to pair if one is made by Delphi XE7 and the other is made by Delphi 10.2.

What would prevent XE7 and 10.2 apps from pairing?
The protocol has incompatible been changed between XE7 and XE8. Maybe after XE8 again.
Antonio Tortosa...

Posts: 6
Registered: 1/12/08
Re: XE7 tethering apps won't pair with 10.2 apps
Correct
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 15, 2017 3:35 AM   in response to: Michael Leahy in response to: Michael Leahy
Michael Leahy wrote:
I cannot get the simplest app or any of the sample apps to pair if one is made by Delphi XE7 and the other is made by Delphi 10.2.

What would prevent XE7 and 10.2 apps from pairing?

There was a change in the protocol to improve communications and adapters support, and there was also an inprovement to manage protocol versions to accept and establish communications with different tethering versions.
But before that we needed to do a bigger change that become incompatible. You only need to recompile the application and it should communicate.
I recommend to use the latest delphi version, Tou can use a multicast TCP4 adapter instead the broadcast TCP4, communications over wireless networks can be blocked when using broadcast.

Un saludo, Antonio Tortosa.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02