Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: OS X High Sierra


This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 3 - Last Post: Oct 12, 2017 11:17 AM Last Post By: Markus Humm
Richard Simon

Posts: 54
Registered: 10/7/07
OS X High Sierra  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 4, 2017 5:39 AM
Delphi Firemonkey 10.2

When compiling my project to High Sierra on a mac PA Server gives the error:

/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Common/ChunkCompression.cpp:50 Error unsupported compressor 8
Also:
Error: unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/Exceptions.plist'

My application seems to run okay but the errors did not appear under Sierra.

Could someone help with the meaning of this and maybe point to a solution please?

Thanks
Eli M

Posts: 1,346
Registered: 11/9/13
Re: OS X High Sierra  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 7, 2017 3:59 PM   in response to: Richard Simon in response to: Richard Simon
10.2.1 is out and there is a Hotfix that can be applied to it as well.

http://cc.embarcadero.com/Item/30785
http://cc.embarcadero.com/Item/30805
Peter Tomcsanyi

Posts: 1
Registered: 5/26/00
Re: OS X High Sierra  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 12, 2017 4:34 AM   in response to: Eli M in response to: Eli M
The patch is for iOS 11.
But the problem mentioned by the original poster is for macOS 10.13 (High Sierra).
So the proposed hotfix does not solve the problem of the original poster.
I can still see the same problem on my computer.
Even when I create an empty project and run it on macOS 10.13.
The mentioned error message appears on the PAServer console.
I filed an error report:
https://quality.embarcadero.com/browse/RSP-19227

Eli M wrote:
10.2.1 is out and there is a Hotfix that can be applied to it as well.

http://cc.embarcadero.com/Item/30785
http://cc.embarcadero.com/Item/30805
Markus Humm

Posts: 5,113
Registered: 11/9/03
Re: OS X High Sierra  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 12, 2017 11:17 AM   in response to: Peter Tomcsanyi in response to: Peter Tomcsanyi
Am 12.10.2017 um 13:34 schrieb Peter Tomcsanyi:
The patch is for iOS 11.
But the problem mentioned by the original poster is for macOS 10.13 (High Sierra).
So the proposed hotfix does not solve the problem of the original poster.
I can still see the same problem on my computer.
Even when I create an empty project and run it on macOS 10.13.
The mentioned error message appears on the PAServer console.
I filed an error report:
https://quality.embarcadero.com/browse/RSP-19227

Good that you filed that report, but it would be good as well to put
your answers below the text answering to in the furture as this is
considered standard here. Good luck with that bugreport.

Greetings

Markus
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02