Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Delphi app. for Windows Store



Permlink Replies: 3 - Last Post: Dec 14, 2017 7:30 AM Last Post By: Ede Csanádi
Ede Csanádi

Posts: 40
Registered: 10/9/06
Delphi app. for Windows Store
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 22, 2017 11:15 AM
Hi!

Trying to publish a Delphi XE7 Win64 app. in the Windows Store and it has been rejected a couple of times because it doesn't work as it should, although here with my development computer and on a family computer as well, works fine.

First issue is that the TListView does not display the groups (it does here). The grouping functionality was introduced with Windows XP and is activated with the manifest stating it requires "common controls version 6". The manifest used is the Delphi built-in "Enable runtime themes" and it is working fine here, if it wouldn't work, it wouldn't display gropus here either. The report also says that it does work on a computer where Visual Studio is installed. On the family computer there is no Visual Studio installed, in fact there is basically nothing installed but maybe Firefox?

The second problem is that the reply says the appx does not install on Windows 10S. I don't have Windows 10S here so I can not test that. Could it be that Win64 is the problem?

Anybody can comment on these?

Thank you!

Best regards
3delite
Brian Hamilton ...

Posts: 556
Registered: 10/14/04
Re: Delphi app. for Windows Store
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 25, 2017 2:19 AM   in response to: Ede Csanádi in response to: Ede Csanádi
the windows10S issue I have had problems with as well (have not figured out what is wrong)
Marcel Hofstede

Posts: 1
Registered: 1/16/12
Re: Delphi app. for Windows Store
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 14, 2017 5:30 AM   in response to: Brian Hamilton ... in response to: Brian Hamilton ...
Brian Hamilton Hamilton wrote:
the windows10S issue I have had problems with as well (have not figured out what is wrong)

I do have the same problem but still no solution.
Do you figured out what the reason is/was?
Ede Csanádi

Posts: 40
Registered: 10/9/06
Re: Delphi app. for Windows Store
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 14, 2017 7:30 AM   in response to: Marcel Hofstede in response to: Marcel Hofstede
It was a missing .dll in my case, there was no problem with the TListView. It didn't display the images as they were not created after all.
Don't remember about the Windows 10 S issue, it was solved somehow in the mean time, sorry.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02