Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.

Welcome, Guest
Guest Settings

Thread: CPort installation doesn't work in Delphi 10.1 after installing in XE

Permlink Replies: 0
Veit Zimmermann

Posts: 1
Registered: 2/10/17
CPort installation doesn't work in Delphi 10.1 after installing in XE
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 22, 2017 7:41 AM
I had a working installation of ComPort 4.11f in my Delphi 10.1. After I had to set up Delphi XE with TComPort for an older project (installation worked flawless), I started to work with 10.1 again without problems. Until I opened a DataModule that contained a TComPort object:

An error message came up (sorry, I don't remeber what the message said). Also ComPort was not in the Tool Palette any more. But when I tried to reinstall I realised that the TComPort Projekt had the option to unsinstall, which is only visible if it is still installed. So I uninstalled it.

Then I tried to reinstall.

Loading the CPortLibDXE package works as long as you don't open the CPortSetup.pas file. This gives you the error message "class TComComboBox not found". No problem this is the runtime package. Don't fuzz with it. Compiling was OK.

Same with DsgnCPortDXE package: Loading and compiling is fine. But when I try to install the control things are getting bad. I get this error messages:

Der Prozedureinsprungpunkt "@Cport@EnumComPorts$qqrp23System@Classes@TStrings" wurde in der DLL "C:\Users\Public\Documents\Embarcadero\Studio\18.0\Bpl\DsgnCPortDXE.bpl" nicht gefunden.
(The procedure entry point (?) "@Cport@EnumComPorts$qqrp23System@Classes@TStrings" was not found in DLL "C:\Users\Public\Documents\Embarcadero\Studio\18.0\Bpl\DsgnCPortDXE.bpl". )

Looks like it is missing a entry point for method EnumComPorts having a TStrings as parameter. But why is it missing when I compile it with D10.1 and not with DXE?

After closing this message I get a second error messge:

2. Can't load package C:\Users\Public\Documents\Embarcadero\Studio\18.0\Bpl\DsgnCPortDXE.bpl.
Die angegebene Prozedur wurde nicht gefunden.
(Can't load package C:\Users\Public\Documents\Embarcadero\Studio\18.0\Bpl\DsgnCPortDXE.bpl.
The given procedure has not been found.)

Sources and reuslt of the compilation are in a separate folder for each Delphi version. The resulting bpl does exist in the given path.

I also tried removing TComPort from XE, which didn't help. Later I resintalled TComPort in XE using the same steps that wouldn't work in 10.1 again and it works fine there.

Any help would be greatly appreciated!


Edited by: Veit Zimmermann on Sep 22, 2017 7:42 AM
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02