Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Trackpad scroll down in IDE goes to end of file: Delphi XE6


This question is answered. Helpful answers available: 1. Correct answers available: 1.


Permlink Replies: 7 - Last Post: Sep 12, 2017 7:41 AM Last Post By: Ngoni Simelane
Ian Johnson

Posts: 43
Registered: 3/14/06
Trackpad scroll down in IDE goes to end of file: Delphi XE6  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 15, 2015 8:29 PM
Hello,

When I use the trackpad to scroll down a file in XE6, it goes to the end of the file. Scrolling up works fine.

I've tested this on other applications - eg a very large file in Word - and it works fine.

Has anyone else seen this problem and managed to fix it?

I'm running windows 7 on a mac using Parallels 10.

Thanks, Ian
David Millington

Posts: 257
Registered: 5/29/05
Re: Trackpad scroll down in IDE goes to end of file: Delphi XE6
Helpful
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 16, 2015 5:59 AM   in response to: Ian Johnson in response to: Ian Johnson
I don't have that problem, but something similar: when I scroll with the trackpad (say, a swipe down) the code sometimes scrolls a long way down, then up again - and sometimes down and up again after that.)

Chances are it's something odd to do with the messages the driver is sending the editor control. I haven't investigated. Try using Spy++ and seeing what happens...

Cheers,

David
Ian Johnson

Posts: 43
Registered: 3/14/06
Re: Trackpad scroll down in IDE goes to end of file: Delphi XE6  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 16, 2015 2:50 PM   in response to: David Millington in response to: David Millington
Thanks David - I've found that everything works fine on my old machine with Parallels 8 - maybe it's something to do with that. I'll keep checking...

Cheers, Ian

David Millington wrote:
I don't have that problem, but something similar: when I scroll with the trackpad (say, a swipe down) the code sometimes scrolls a long way down, then up again - and sometimes down and up again after that.)

Chances are it's something odd to do with the messages the driver is sending the editor control. I haven't investigated. Try using Spy++ and seeing what happens...

Cheers,

David
Ian Johnson

Posts: 43
Registered: 3/14/06
Re: Trackpad scroll down in IDE goes to end of file: Delphi XE6  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 17, 2015 11:37 PM   in response to: Ian Johnson in response to: Ian Johnson
Just to let anyone interested know...

Talking to the very helpful Parallels support, the problem is with 'smooth scrolling' implemented. When this is turned off, the editor in Delphi works fine. This apparently does happen with some programs and seems to be a Delphi problem rather than Parallels.

Ian

Ian Johnson wrote:
Hello,

When I use the trackpad to scroll down a file in XE6, it goes to the end of the file. Scrolling up works fine.

I've tested this on other applications - eg a very large file in Word - and it works fine.

Has anyone else seen this problem and managed to fix it?

I'm running windows 7 on a mac using Parallels 10.

Thanks, Ian
David Millington

Posts: 257
Registered: 5/29/05
Re: Trackpad scroll down in IDE goes to end of file: Delphi XE6  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 18, 2015 2:37 AM   in response to: Ian Johnson in response to: Ian Johnson
Ian Johnson wrote:
Talking to the very helpful Parallels support, the problem is with 'smooth scrolling' implemented. When this is turned off, the editor in Delphi works fine. This apparently does happen with some programs and seems to be a Delphi problem rather than Parallels.

Thanks Ian! That's a Windows setting, not host Mac setting?
Ian Johnson

Posts: 43
Registered: 3/14/06
Re: Trackpad scroll down in IDE goes to end of file: Delphi XE6  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 19, 2015 2:39 AM   in response to: David Millington in response to: David Millington
Hi David,

It's a Parallels setting: Configure, Hardware tab, Mouse and Keyboard, 'Enable smooth scrolling' checkbox.

Cheers, Ian

ps - bit slow to reply as I'm in Australia and the forums seem to be down quite a bit for maintenance which I presume is their nighttime.

David Millington wrote:
Ian Johnson wrote:
Talking to the very helpful Parallels support, the problem is with 'smooth scrolling' implemented. When this is turned off, the editor in Delphi works fine. This apparently does happen with some programs and seems to be a Delphi problem rather than Parallels.

Thanks Ian! That's a Windows setting, not host Mac setting?
David Millington

Posts: 257
Registered: 5/29/05
Re: Trackpad scroll down in IDE goes to end of file: Delphi XE6  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 19, 2015 3:45 AM   in response to: Ian Johnson in response to: Ian Johnson
Ian Johnson wrote:
It's a Parallels setting: Configure, Hardware tab, Mouse and Keyboard, 'Enable smooth scrolling' checkbox.

Thanks! Unfortunately I already have that turned off. (It seems to be off by default for my VM.)

ps - bit slow to reply as I'm in Australia and the forums seem to be down quite a bit for maintenance which I presume is their nighttime.

I have /no idea/ why they are down so often, but... I hope maintenance means they will be down less often soon :)

Cheers,

David
Ngoni Simelane

Posts: 4
Registered: 8/25/97
Re: Trackpad scroll down in IDE goes to end of file: Delphi XE6  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 12, 2017 7:41 AM   in response to: Ian Johnson in response to: Ian Johnson
I know that I am responding to a thread that is several years old... but I'd just like to thank Ian for this tip... This was becoming a major productivity drag for me, until I stumbled upon this thread.

Having to turn off "smooth scrolling" is a pain because it affects all the applications in the vm - ironically as the scrolling becomes smoother in the RAD Studio IDE, it becomes very jerky in other Windows applications running in that VM. I have overcome this by running RAD Studio in its own VM with "smooth scrolling" turned off, and all other Windows applications in a separate VM with "smooth scrolling" turned on. This consumes ton more hardware resources, but it stops me from throwing the whole computer out the window or switching to a magic mouse (assuming that works)... which would be the saner thing to do, I guess.

Anyway... I just wanted to say thanks, Ian... much appreciated. It is however disappointing that this problem has still not been fixed.

Ian Johnson wrote:
Hi David,

It's a Parallels setting: Configure, Hardware tab, Mouse and Keyboard, 'Enable smooth scrolling' checkbox.

Cheers, Ian

ps - bit slow to reply as I'm in Australia and the forums seem to be down quite a bit for maintenance which I presume is their nighttime.

David Millington wrote:
Ian Johnson wrote:
Talking to the very helpful Parallels support, the problem is with 'smooth scrolling' implemented. When this is turned off, the editor in Delphi works fine. This apparently does happen with some programs and seems to be a Delphi problem rather than Parallels.

Thanks Ian! That's a Windows setting, not host Mac setting?
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02