Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: ZOOM gesture not working FMX win32


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 0 Threads: [ Previous | Next ]
William Brookfi...

Posts: 55
Registered: 1/1/10
ZOOM gesture not working FMX win32  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Aug 31, 2017 7:07 AM
Version: DELPHI 10.1 Berlin Update 2

We have a customer that has IN-HOUSE GIS mapping that we are trying to use using TWebBrowser in a 32 bit windows FMX app.
Everything works except Pinch to zoom.
We do not have the interactive gesture turn on, but we did try it both ways.
When we try and use google maps URL (www.google.com/maps) we have the same issue.
At first we could not get google maps to work at all, until we add our apps to the registry setting for Internet Explorer
HKEY_LOCAL_MACHINE (or HKEY_CURRENT_USER)
SOFTWARE
Microsoft
Internet Explorer
Main
FeatureControl
FEATURE_BROWSER_EMULATION
YourExeNameGoesHere.exe = (DWORD) 00009999

After this change google maps comes up and everything but Pinch to zoom works.
If I go to CNN.COM and our company web site, Pinch to zoom works. What is strange is that if I create an OLE object
ie := CreateOleObject('InternetExplorer.Application') as iwebbrowser2;
The pinch to zoom works correctly, but I have no way to render it as a child control within our form..
OleContainer is not available on FMX.

We have also tried to embed the Mapping URL in an Iframe to force specific UserAgent and have the same issue.

UPDATE:
I just tried using chromiumFMX (Rebuilt for Delphi Berlin) and it also has the same issue. My guess is that when the a WebBrowser object is hosted in an FMX form, the pinch zoom gesture is being intercepted even though I have it turn off on the form and web component.

Any suggestions.

Edited by: William Brookfield on Aug 31, 2017 3:41 PM
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02