Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Autocompletion bug in Tokyo



Permlink Replies: 3 - Last Post: Aug 29, 2017 6:11 AM Last Post By: MA Y
MA Y

Posts: 5
Registered: 7/14/04
Autocompletion bug in Tokyo
Click to report abuse...   Click to reply to this thread Reply
  Posted: Aug 27, 2017 9:30 AM
We are using Delphi Tokyo and it seems there is a bug in autocompletion. Let's say we have TListView with name lView. It should complete lView.Items but after dot, commands scroll is empty or never shown.

Example: lView.Items. If I start with lowercase "i", the problem occurs, if i start with uppercase "I" the problem is gone.

BUT

Let's say TQuery,

q: TQuery

and if i try to write q.Fields... After F, all is gone. No codes!

Edited by: MA Y on Aug 27, 2017 9:36 AM
MA Y

Posts: 5
Registered: 7/14/04
Re: Autocompletion bug in Tokyo
Click to report abuse...   Click to reply to this thread Reply
  Posted: Aug 27, 2017 9:57 AM   in response to: MA Y in response to: MA Y
Well still no luck

Edited by: MA Y on Aug 27, 2017 11:04 AM
Zoran M

Posts: 11
Registered: 11/2/08
Re: Autocompletion bug in Tokyo [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Aug 27, 2017 11:44 AM   in response to: MA Y in response to: MA Y
All working ok here. Maybe something went wrong during Tokyo
installation, or some file got currupted later?


MA Y wrote:

We are using Delphi Tokyo and it seems there is a bug in
autocompletion. Let's say we have TListView with name lView. It
should complete lView.Items but after dot, commands scroll is empty
or never shown.

Example: lView.Items. If I start with lowercase "i", the problem
occurs, if i start with uppercase "I" the problem is gone.

BUT

Let's say TQuery,

q: TQuery

and if i try to write q.Fields... After F, all is gone. No codes!

Edited by: MA Y on Aug 27, 2017 9:36 AM
MA Y

Posts: 5
Registered: 7/14/04
Re: Autocompletion bug in Tokyo [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Aug 29, 2017 6:11 AM   in response to: Zoran M in response to: Zoran M
I don't think so! This is a known error i think. I am using Win81 64bit edition with Turkish keyboard and the problem occurs because of "i" char. Whatever you do, after typing "i", code completion get cleared.

Zoran M wrote:
All working ok here. Maybe something went wrong during Tokyo
installation, or some file got currupted later?


MA Y wrote:

We are using Delphi Tokyo and it seems there is a bug in
autocompletion. Let's say we have TListView with name lView. It
should complete lView.Items but after dot, commands scroll is empty
or never shown.

Example: lView.Items. If I start with lowercase "i", the problem
occurs, if i start with uppercase "I" the problem is gone.

BUT

Let's say TQuery,

q: TQuery

and if i try to write q.Fields... After F, all is gone. No codes!

Edited by: MA Y on Aug 27, 2017 9:36 AM
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02