Watch, Follow, &
Connect with Us

Please visit our new home
community.embarcadero.com.


Welcome, Guest
Guest Settings
Help

Thread: Switching to clang -> IDE crashes


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 6 - Last Post: Jul 17, 2017 7:30 AM Last Post By: Jan Dijkstra Threads: [ Previous | Next ]
Herwig Huber

Posts: 5
Registered: 2/19/02
Switching to clang -> IDE crashes  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 30, 2017 12:59 AM
Hello World,

I am using C++ Builder XE10 Seattle Enterprise.

Because I wanted to use the parallel compiling and some C++11 features I switched my project over to use the clang compiler instead of the classic borland compiler.
After solving a couple of issues (e.g. Components that were compiled with the classic compiler) and after reinstalling the complete IDE I am still facing a lot of probems.

- Code completion is horrible slow - the IDE hangs on every second typed letter for a couple of seconds up to 2 minutes.
- The IDE crashes every 5 minutes.

I have absolutely no idea how to solve these problems: Are there any logs that will point me to the right direction?

Herwig
Oliver Weinheimer

Posts: 73
Registered: 8/20/04
Re: Switching to clang -> IDE crashes  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 30, 2017 3:04 AM   in response to: Herwig Huber in response to: Herwig Huber
Hi Herwig,

"Code completion" does not work.
You have to disable it - via Options -> Editor Options.
Also unchecked "Code parameters" and "Tooltip symbol insight" .
I am on RAD Tokyo coding for Win 64 - but these features did not work since at least ten years - not in Seattle, not in Berlin, not in Tokyo (I think they are slightly improved, but waiting 30 seconds is just as unacceptable as waiting 60 seconds).

As far as I can remember the stability of Seattle was Ok - so maybe you have also some other problems with your installation.

Best - Oliver
Herwig Huber

Posts: 5
Registered: 2/19/02
Re: Switching to clang -> IDE crashes  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 30, 2017 8:01 AM   in response to: Oliver Weinheimer in response to: Oliver Weinheimer
Thanks for your answer

As far as I can remember the stability of Seattle was Ok - so maybe you have also some other problems with your installation.

My Installation should be ok: I alredy re-installed cppbuilder.
Maybe there is something wrong with some 3rd party components I am using:
- TMS Component Pack
- SiComponents
Or maybe there is something wrong with my project settings or in the code itself.

The problem is: I have no idea where to start looking for, because the IDE crashes without any message...
Martin Stratmann

Posts: 18
Registered: 5/26/00
Re: Switching to clang -> IDE crashes  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 2, 2017 7:07 AM   in response to: Herwig Huber in response to: Herwig Huber
Am 30.03.2017 um 17:01 schrieb Herwig Huber:
Thanks for your answer

As far as I can remember the stability of Seattle was Ok - so maybe you have also some other problems with your installation.

My Installation should be ok: I alredy re-installed cppbuilder.
Maybe there is something wrong with some 3rd party components I am using:
- TMS Component Pack
- SiComponents
Or maybe there is something wrong with my project settings or in the code itself.

The problem is: I have no idea where to start looking for, because the IDE crashes without any message...
I've the same problem. IDE crashed every 5..10 Minutes. I guess, c++11
is unusable in RAD Studio

Martin
Herwig Huber

Posts: 5
Registered: 2/19/02
Re: Switching to clang -> IDE crashes  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jul 16, 2017 4:09 AM   in response to: Martin Stratmann in response to: Martin Stratmann
Martin Stratmann wrote:
Am 30.03.2017 um 17:01 schrieb Herwig Huber:
Thanks for your answer

As far as I can remember the stability of Seattle was Ok - so maybe you have also some other problems with your installation.

My Installation should be ok: I alredy re-installed cppbuilder.
Maybe there is something wrong with some 3rd party components I am using:
- TMS Component Pack
- SiComponents
Or maybe there is something wrong with my project settings or in the code itself.

The problem is: I have no idea where to start looking for, because the IDE crashes without any message...
I've the same problem. IDE crashed every 5..10 Minutes. I guess, c++11
is unusable in RAD Studio

Martin

I still have not been successful using C++ Builder Seattle with c++11.
I spent a lot of money (Enterprise Version) that does not work and nobody @Embarcadero is willing to fix these issues.
Is there any chance to get my money back?

Herwig
Brett Wilton

Posts: 45
Registered: 10/1/11
Re: Switching to clang -> IDE crashes  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 30, 2017 1:43 PM   in response to: Herwig Huber in response to: Herwig Huber
Some suggestions.

Turn off all code completion, that can make the IDE hang and is just plain terrible.

If your still getting crashes, remove all third party plugins. Test, if better start adding them back in to figure out which could be causing the issue.
Jan Dijkstra

Posts: 206
Registered: 11/4/99
Re: Switching to clang -> IDE crashes  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jul 17, 2017 7:30 AM   in response to: Brett Wilton in response to: Brett Wilton
Brett Wilton wrote:
Some suggestions.

Turn off all code completion, that can make the IDE hang and is just plain terrible.

If your still getting crashes, remove all third party plugins. Test, if better start adding them back in to figure out which could be causing the issue.

For me (still on XE8 Enterprise) the IDE instability was caused by Castalia. I had to go into the registry and remove the key that causes the IDE to load the Castalia BPL. Before I did that, I had access violations on virtually every single key stroke I typed in the editor. After I removed Castalia completely from the IDE, it has been rock solid.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02