Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: IBREDISTDIR is missing


This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 1 - Last Post: Jul 5, 2017 8:49 AM Last Post By: Paul Jackson
Paul Jackson

Posts: 61
Registered: 3/2/17
IBREDISTDIR is missing  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jul 4, 2017 7:20 PM
So I had serious issues with getting Interbase installed and am still in the process of working with support on getting it all straightened out. So after deleting everything that had the name Interbase attached to it for several re-installs of Interbase I no longer have the "redist" directory structures on my drive in the public directories, i.e. IBREDISTDIR points nowhere.

I cannot deploy embedded DB projects because I the needed files are missing in the deployment manager.

Does anyone know how I can rebuild the directory structure and get the appropriate files needed.

Just as a throw in, in case anyone has any ideas. When I install Interbase 2017 using the media kit and submitting the registered license, I cannot get any connections to work through the IDE, however when I use the Platform manager to install XE7, connections can be made and used, but I still have the deployment issue.

New to Embarcadero and I've been reading every docwiki I can find, but it is all very complex to put together. I not sure how the deployment mechanism works just yet. So any help or reply would be greatly appreciated.

C++ Builder Pro Tokyo 10.2

Edited by: Paul Jackson on Jul 4, 2017 10:31 PM
Paul Jackson

Posts: 61
Registered: 3/2/17
Re: IBREDISTDIR is missing  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jul 5, 2017 8:49 AM   in response to: Paul Jackson in response to: Paul Jackson
So I kinda answered my own question. If anyone is looking there is a Catalog Repository in the public folder that has a copy of the redist files and folders. Just need to rebuild the path and put the files/folders back into where they belong.

However, the thingy below about the Interbase 2017 and XE7 connections in the IDE are still an outstanding question. Just strange that XE7 works and 2017 struggles, being that it is a newer distro...

Paul Jackson wrote:
So I had serious issues with getting Interbase installed and am still in the process of working with support on getting it all straightened out. So after deleting everything that had the name Interbase attached to it for several re-installs of Interbase I no longer have the "redist" directory structures on my drive in the public directories, i.e. IBREDISTDIR points nowhere.

I cannot deploy embedded DB projects because I the needed files are missing in the deployment manager.

Does anyone know how I can rebuild the directory structure and get the appropriate files needed.

Just as a throw in, in case anyone has any ideas. When I install Interbase 2017 using the media kit and submitting the registered license, I cannot get any connections to work through the IDE, however when I use the Platform manager to install XE7, connections can be made and used, but I still have the deployment issue.

New to Embarcadero and I've been reading every docwiki I can find, but it is all very complex to put together. I not sure how the deployment mechanism works just yet. So any help or reply would be greatly appreciated.

C++ Builder Pro Tokyo 10.2

Edited by: Paul Jackson on Jul 4, 2017 10:31 PM
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02