Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Cannot get Android apps to install


This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 4 - Last Post: Jun 25, 2017 8:07 PM Last Post By: Bob Carson
Bob Carson

Posts: 62
Registered: 10/8/04
Cannot get Android apps to install  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 25, 2017 4:41 PM
I am using DX10.2 with the latest patch installed for android. I have the latest Android SDK Installed, rev 26 with items from rev 25, 24, 23. I have had this problem since Tokyo release, now I have it on Berlin and Seattle. For any app or sample or new project in new folder with nothing in folders from any Delphi version, I keep getting on install to Nexus 9 with latest Android updates (automatic updates) I keep getting the message: INSTALLED_FAILED_INVALID_APK Package could not be installed in ..... base.apk code is missing. I have Android SDK 25.2.5 32 bit as current, but have also used SDK 24.3.3 32 bit with same problem. Before Android SDK downloads, I was functional under Seattle and Berlin, but not Tokyo. Now all 3 won't install on Android. Is anyone else running into this problem, or knows anything about this result.
Thank you for any Help,
Bob Carson
Dave Nottage

Posts: 1,850
Registered: 1/7/00
Re: Cannot get Android apps to install  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 25, 2017 5:56 PM   in response to: Bob Carson in response to: Bob Carson
I have Android SDK 25.2.5 32 bit as current, but have also used SDK 24.3.3 32 bit with same problem

Download 24.0.3 if you're able to, and see how it goes with that. Alternatively, just use 22 or 23, which are known to work.

--
Dave Nottage [TeamB]
Find hints tips and tricks at Delphi Worlds blog: http://www.delphiworlds.com
Bob Carson

Posts: 62
Registered: 10/8/04
Re: Cannot get Android apps to install  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 25, 2017 6:22 PM   in response to: Dave Nottage in response to: Dave Nottage
Thank you Dave for your quick response. I tried going back to previous SDK installs using Seattle adding new Android SDK from Delphi versions 15 and 16 loaded from different folders than SDK ver24 and 25, but still getting the same message. I must have a mix of SDK files from different downloads. At this point, I'll just wait until Delphi catches up to SDK v24 or later.
Eli M

Posts: 1,346
Registered: 11/9/13
Re: Cannot get Android apps to install  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 25, 2017 7:22 PM   in response to: Bob Carson in response to: Bob Carson
Maybe make sure any existing apps with the same name are uninstalled before you try to install.
Bob Carson

Posts: 62
Registered: 10/8/04
Re: Cannot get Android apps to install  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 25, 2017 8:05 PM   in response to: Eli M in response to: Eli M
Eli M wrote:
Maybe make sure any existing apps with the same name are uninstalled before you try to install.
I was doing that yesterday, as many times before. I don't remember what error I would get when not removing app on android device, and trying to update, but deleting the app on android and reinstall would always work. Not this time. Yesterday I was trying samples I never put on my device before, creating new apps with new names (just window with one control) with the same result. I think I would need to remove android SDK 26, 25, and 24 completely using the SDK manager, and have only v23 on my computer, then add new SDK using Delphi for v23 SDK. When adding back older versions now, Delphi is still calling them v24.3.3 or v24,3,1 although choosing folder from older versions of Delphi. The latest SDKs are all installing to Delphi 17 (Seattle) folder location (Documents Folder) since Tokyo and Berlin are all part of 10). Going back to Folders containing SDK from Delphi 15 and 16 may have SDK files that are outdated for even Seattle, thus the same error. I'll just wait for 10.3, September or October? I need to come up with better app ideas anyway.

Edited by: Bob Carson on Jun 25, 2017 8:07 PM
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02