Watch, Follow, &
Connect with Us

Please visit our new home
community.embarcadero.com.


Welcome, Guest
Guest Settings
Help

Thread: Fast report with Delphi 10.1 Berlin update 2



Permlink Replies: 13 - Last Post: Mar 27, 2017 7:19 AM Last Post By: Robert Evans
Ricky Lie

Posts: 14
Registered: 10/2/05
Fast report with Delphi 10.1 Berlin update 2
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 16, 2016 3:22 AM
Hello.

I just upgrade Delphi 10.1 berlin from update 1 to update 2, found out problem with fast report preview display,

When an appearance style applied other than default "Windows" style there is a line appear on the fast report preview menu bar, I never came with this problem on Delphi 10 Seattle, 10.1 berlin and 10,1 berlin update1.

Does anyone know how to work out on the problem?

To all comments and helps, are welcome and thank you.

Regards
Ricky
Ricky Lie

Posts: 14
Registered: 10/2/05
Re: Fast report with Delphi 10.1 Berlin update 2
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 18, 2016 9:34 PM   in response to: Ricky Lie in response to: Ricky Lie
Ricky Lie wrote:
Hello.

I just upgrade Delphi 10.1 berlin from update 1 to update 2, found out problem with fast report preview display,

When an appearance style applied other than default "Windows" style there is a line appear on the fast report preview menu bar, I never came with this problem on Delphi 10 Seattle, 10.1 berlin and 10,1 berlin update1.

Does anyone know how to work out on the problem?

To all comments and helps, are welcome and thank you.

Regards
Ricky

Have already uninstall and reinstall Delphi 10.1 berlin update 2, still have the problem

FYI, recompiling the project with Delphi 10 seattle update 1 doesn't show the problem, any comment from fastreport guys?
Ricky Lie

Posts: 14
Registered: 10/2/05
Re: Fast report with Delphi 10.1 Berlin update 2
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 23, 2016 6:17 AM   in response to: Ricky Lie in response to: Ricky Lie
Ricky Lie wrote:
Ricky Lie wrote:
Hello.

I just upgrade Delphi 10.1 berlin from update 1 to update 2, found out problem with fast report preview display,

When an appearance style applied other than default "Windows" style there is a line appear on the fast report preview menu bar, I never came with this problem on Delphi 10 Seattle, 10.1 berlin and 10,1 berlin update1.

Does anyone know how to work out on the problem?

To all comments and helps, are welcome and thank you.

Regards
Ricky

Have already uninstall and reinstall Delphi 10.1 berlin update 2, still have the problem

FYI, recompiling the project with Delphi 10 seattle update 1 doesn't show the problem, any comment from fastreport guys?

HI,

I'm very curious that am I the only one who face this problem, try every possible way to solve this problem but couldn't help my self, could anybody confirm this by reproducing as follow:

1) create a vcl form application
2) drop a button control to the form
3) drop a fastreport control TfrxReport> frxReport1
4) set application appearance: Project> Option> Application> Appearance> Windows10
5) On button click set frxReport1.ShowReport;
6) compile, build and run the project, in my machine there is annoying line in the fastreport preview tollbar.

I didn't get such problem by compiling, build and run the project with Delphi 10.1 berlin update1 or Delphi 10 seattle update 1.

Please help, thank you

Anyone ???, has similar problem ???

Edited by: Ricky Lie on Nov 25, 2016 10:55 AM

Edited by: Ricky Lie on Nov 25, 2016 10:56 AM
Jeff Overcash (...

Posts: 1,417
Registered: 9/23/99
Re: Fast report with Delphi 10.1 Berlin update 2 [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 24, 2016 9:22 PM   in response to: Ricky Lie in response to: Ricky Lie
Ricky Lie wrote:
Ricky Lie wrote:
Ricky Lie wrote:
Hello.

I just upgrade Delphi 10.1 berlin from update 1 to update 2, found out problem with fast report preview display,

When an appearance style applied other than default "Windows" style there is a line appear on the fast report preview menu bar, I never came with this problem on Delphi 10 Seattle, 10.1 berlin and 10,1 berlin update1.

Does anyone know how to work out on the problem?

To all comments and helps, are welcome and thank you.

Regards
Ricky
Have already uninstall and reinstall Delphi 10.1 berlin update 2, still have the problem

FYI, recompiling the project with Delphi 10 seattle update 1 doesn't show the problem, any comment from fastreport guys?

HI,

I'm very curious that am I the only one who face this problem, try every possible way to solve this problem but couldn't help my self, could anybody confirm this by reproducing as follow:

1) create a vcl form application
2) drop a button control to the form
3) drop a fastreport control TfrxReport> frxReport1
4) set application appearance: Project> Option> Application> Appearance> Windows10
5) On button click set frxReport1.ShowReport;
6) compile, build and run the project, in my machine there is annoying line in the fastreport preview tollbar.

I didn't get such problem by compiling, build and run the project with Delphi 10.1 berlin update1 or Delphi 10 seattle update 1.

Please help, thank you

Anyone ???, has similar problem ???

Edited by: Ricky Lie on Nov 25, 2016 10:55 AM

Edited by: Ricky Lie on Nov 25, 2016 10:56 AM

I see that too, since Embarcadero does not own this you probably need to report
it directly to the FR guys. They would have to deliver a fixed updated
deliverable for Embarcadero.

https://www.fast-report.com

--
Jeff Overcash (TeamB)
(Please do not email me directly unless asked. Thank You)
Learning is finding out what you already know. Doing is demonstrating that you
know it. Teaching is reminding others that they know it as well as you. We are
all leaners, doers, teachers. (R Bach)

Ricky Lie

Posts: 14
Registered: 10/2/05
Re: Fast report with Delphi 10.1 Berlin update 2 [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 24, 2016 10:20 PM   in response to: Jeff Overcash (... in response to: Jeff Overcash (...
Jeff Overcash (TeamB) wrote:
Ricky Lie wrote:
Ricky Lie wrote:
Ricky Lie wrote:
Hello.

I just upgrade Delphi 10.1 berlin from update 1 to update 2, found out problem with fast report preview display,

When an appearance style applied other than default "Windows" style there is a line appear on the fast report preview menu bar, I never came with this problem on Delphi 10 Seattle, 10.1 berlin and 10,1 berlin update1.

Does anyone know how to work out on the problem?

To all comments and helps, are welcome and thank you.

Regards
Ricky
Have already uninstall and reinstall Delphi 10.1 berlin update 2, still have the problem

FYI, recompiling the project with Delphi 10 seattle update 1 doesn't show the problem, any comment from fastreport guys?

HI,

I'm very curious that am I the only one who face this problem, try every possible way to solve this problem but couldn't help my self, could anybody confirm this by reproducing as follow:

1) create a vcl form application
2) drop a button control to the form
3) drop a fastreport control TfrxReport> frxReport1
4) set application appearance: Project> Option> Application> Appearance> Windows10
5) On button click set frxReport1.ShowReport;
6) compile, build and run the project, in my machine there is annoying line in the fastreport preview tollbar.

I didn't get such problem by compiling, build and run the project with Delphi 10.1 berlin update1 or Delphi 10 seattle update 1.

Please help, thank you

Anyone ???, has similar problem ???

Edited by: Ricky Lie on Nov 25, 2016 10:55 AM

Edited by: Ricky Lie on Nov 25, 2016 10:56 AM

I see that too, since Embarcadero does not own this you probably need to report
it directly to the FR guys. They would have to deliver a fixed updated
deliverable for Embarcadero.

https://www.fast-report.com

--
Jeff Overcash (TeamB)
(Please do not email me directly unless asked. Thank You)
Learning is finding out what you already know. Doing is demonstrating that you
know it. Teaching is reminding others that they know it as well as you. We are
all leaners, doers, teachers. (R Bach)

Hi Jeff,

Thank you, at least I know that the problem is not only with my pc. Thank you for response.

I'm using fastreport embarcadero edition, does the fastreport team response on the my prolem?

Regards
Ricky Lie

Jeff Overcash (...

Posts: 1,417
Registered: 9/23/99
Re: Fast report with Delphi 10.1 Berlin update 2 [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 25, 2016 7:14 AM   in response to: Ricky Lie in response to: Ricky Lie

Hi Jeff,

Thank you, at least I know that the problem is not only with my pc. Thank you for response.

I'm using fastreport embarcadero edition, does the fastreport team response on the my prolem?

Regards
Ricky Lie

I do not know, I do not use FastReports. I see no reason why they would not be
interested in fixing known bugs no matter what edition it is though. You just
might have to wait until they deliver something new to Embarcadero as opposed to
getting it faster if you have an upgraded version from them. Leaving bugs in
the Embarcadero version is not the way to drive sales for the fuller version IMO
so makes little sense for them to do that.

--
Jeff Overcash (TeamB)
(Please do not email me directly unless asked. Thank You)
Learning is finding out what you already know. Doing is demonstrating that you
know it. Teaching is reminding others that they know it as well as you. We are
all leaners, doers, teachers. (R Bach)
Robert Evans

Posts: 111
Registered: 10/16/99
Re: Fast report with Delphi 10.1 Berlin update 2 [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 25, 2016 11:34 AM   in response to: Jeff Overcash (... in response to: Jeff Overcash (...
In article <898790 at forums dot embarcadero dot com>, Jeff Overcash
<raelon3 at gmail dot com> wrote

Hi Jeff,

Thank you, at least I know that the problem is not only with my pc.
Thank you for response.

I'm using fastreport embarcadero edition, does the fastreport team
response on the my prolem?

Regards
Ricky Lie

I do not know, I do not use FastReports. I see no reason why they
would not be interested in fixing known bugs no matter what edition it
is though. You just might have to wait until they deliver something
new to Embarcadero as opposed to getting it faster if you have an
upgraded version from them. Leaving bugs in the Embarcadero version is
not the way to drive sales for the fuller version IMO so makes little
sense for them to do that.

I am seeing the same issue in FastReports VCL5 Enterprise Edition and
have raised a support ticket.

--
Bob Evans
Ricky Lie

Posts: 14
Registered: 10/2/05
Re: Fast report with Delphi 10.1 Berlin update 2 [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 25, 2016 7:27 PM   in response to: Robert Evans in response to: Robert Evans
Robert Evans wrote:
In article <898790 at forums dot embarcadero dot com>, Jeff Overcash
<raelon3 at gmail dot com> wrote

Hi Jeff,

Thank you, at least I know that the problem is not only with my pc.
Thank you for response.

I'm using fastreport embarcadero edition, does the fastreport team
response on the my prolem?

Regards
Ricky Lie

I do not know, I do not use FastReports. I see no reason why they
would not be interested in fixing known bugs no matter what edition it
is though. You just might have to wait until they deliver something
new to Embarcadero as opposed to getting it faster if you have an
upgraded version from them. Leaving bugs in the Embarcadero version is
not the way to drive sales for the fuller version IMO so makes little
sense for them to do that.

I am seeing the same issue in FastReports VCL5 Enterprise Edition and
have raised a support ticket.

--
Bob Evans

Hi Bob,

Thank you for your confirmation and it's even better because yours is a full version copy of fastreport.

Please tell us whatever result of your support ticket.

Thank you and best regards
Ricky Lie
Robert Evans

Posts: 111
Registered: 10/16/99
Re: Fast report with Delphi 10.1 Berlin update 2 [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 1, 2016 12:54 PM   in response to: Ricky Lie in response to: Ricky Lie
In article <898831 at forums dot embarcadero dot com>, Ricky Lie <?@?.?.invalid>
wrote
Robert Evans wrote:

I am seeing the same issue in FastReports VCL5 Enterprise Edition and
have raised a support ticket.

Please tell us whatever result of your support ticket.

In fact I received a response from Paul at FR within less than three
hours after I opened the ticket (and quite late on Friday evening in the
UK).

He suggested that, as a work-around, I could try inserting code to set
the application back to the default style before invoking the preview
mode, i.e. via the class method: TStyleManager.SetStyle('Windows');

That does remove the spurious horizontal line, but only at the cost of
(a) making the preview window look different to the rest of the
application and (b) some flickering during the style switching.

I have asked that this be resolved properly, hopefully in time for the
next release of FR VCL5 but have heard nothing further.

Regards,
--
Bob Evans
Ricky Lie

Posts: 14
Registered: 10/2/05
Re: Fast report with Delphi 10.1 Berlin update 2 [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 1, 2016 6:32 PM   in response to: Robert Evans in response to: Robert Evans
Hi Robert,

Thank you for sharing with us, lucky for you, until today I didn't get any response to my support ticket, maybe because of embarcadero edition.

As I mentioned before for sure with style appearance "windows" is ok, but in some application I make use of windows 10 control such as ToggleSwitch, it would look like just a boring rectangle shape in style windows than a smooth curve form in windows 10 style.

They mentioned that the problem will be solved in the next release of FR VCL 5, that mean we have to buy a full version of FR.?

He suggested that, as a work-around, I could try inserting code to set
the application back to the default style before invoking the preview
mode, i.e. via the class method: TStyleManager.SetStyle('Windows');

What I did coding and test with Delphi 10.1 update 2, compile and build with Delphi 10.1 Seattle update 1 (can't down grade to Delphi 10.1 upgrade 1), it works for now.

Thank you and best regards
Ricky Lie
Robert Evans

Posts: 111
Registered: 10/16/99
Re: Fast report with Delphi 10.1 Berlin update 2 [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 2, 2016 3:00 AM   in response to: Ricky Lie in response to: Ricky Lie
In article <899347 at forums dot embarcadero dot com>, Ricky Lie <?@?.?.invalid>
wrote
As I mentioned before for sure with style appearance "windows" is ok,
but in some application I make use of windows 10 control such as
ToggleSwitch, it would look like just a boring rectangle shape in style
windows than a smooth curve form in windows 10 style.

What was being suggested was something like:

<code>
procedure TForm1.Button1Click(Sender: TObject);
var
OrigStyle: string;
begin
OrigStyle := TStyleManager.ActiveStyle.Name;
TStyleManager.SetStyle('Windows'); // or perhaps the next line
// TStyleManager.SetStyle(TStyleManager.SystemStyle.Name);
frxReport1.ShowReport;
TStyleManager.SetStyle(OrigStyle);
end;
</code>

So it is only the FastReport preview window that would be rendered in
the basic Windows style. All the other windows can be styled however
you wish.

Two other thoughts:
Strictly speaking it is not compulsory to show a preview before printing
or exporting a report (although you may prefer to do so);
You could perhaps avoid the problem by constructing your own custom
preview window via the TfrxPreview component? (I have not tested this.)

They mentioned that the problem will be solved in the next release of
FR VCL 5,

I requested that but they have not given me any promise.

that mean we have to buy a full version of FR.?

I don't know about that, but in my opinion (as a satisfied customer who
has used the product for several years) it is well worth the money.

Regards,
--
Bob Evans
Ricky Lie

Posts: 14
Registered: 10/2/05
Re: Fast report with Delphi 10.1 Berlin update 2 [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 25, 2016 7:23 PM   in response to: Jeff Overcash (... in response to: Jeff Overcash (...
Jeff Overcash (TeamB) wrote:

Hi Jeff,

Thank you, at least I know that the problem is not only with my pc. Thank you for response.

I'm using fastreport embarcadero edition, does the fastreport team response on the my prolem?

Regards
Ricky Lie

I do not know, I do not use FastReports. I see no reason why they would not be
interested in fixing known bugs no matter what edition it is though. You just
might have to wait until they deliver something new to Embarcadero as opposed to
getting it faster if you have an upgraded version from them. Leaving bugs in
the Embarcadero version is not the way to drive sales for the fuller version IMO
so makes little sense for them to do that.

--
Jeff Overcash (TeamB)
(Please do not email me directly unless asked. Thank You)
Learning is finding out what you already know. Doing is demonstrating that you
know it. Teaching is reminding others that they know it as well as you. We are
all leaners, doers, teachers. (R Bach)

Hi Jeff,

Thank you for reply.

I've submit a support ticket to fastreport team and will post to whatever outcome of the ticket.

Best regards
Ricky Lie
Ricky Lie

Posts: 14
Registered: 10/2/05
Re: Fast report with Delphi 10.1 Berlin update 2 [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 6, 2017 6:09 PM   in response to: Ricky Lie in response to: Ricky Lie
Hello,

Quit sometime ago I have got a reply from Fastreport team that the issue will be solved, but until now haven't get any further information.

Does anyone knows that the fastreport vcl has been updated? (full version or embarcadero edition)

Thank you for all responses
Ricky Lie
Robert Evans

Posts: 111
Registered: 10/16/99
Re: Fast report with Delphi 10.1 Berlin update 2 [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 27, 2017 7:19 AM   in response to: Ricky Lie in response to: Ricky Lie
In article <910067 at forums dot embarcadero dot com>, Ricky Lie <?@?.?.invalid>
wrote
Quit sometime ago I have got a reply from Fastreport team that the
issue will be solved, but until now haven't get any further information.

Does anyone knows that the fastreport vcl has been updated? (full
version or embarcadero edition)

This shows it as fixed as of version 5.6

https://www.fast-report.com/en/product/fast-report-vcl-5/changes/

Regards,
--
Bob Evans
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02