Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: IDE crashing when trying to debug OS X program


This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 1 - Last Post: Feb 7, 2017 1:42 PM Last Post By: Ivan Johansen
Ivan Johansen

Posts: 27
Registered: 3/17/00
IDE crashing when trying to debug OS X program  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 27, 2017 4:12 AM
I am using C++ Builder XE6.

I have created an empty FireMonkey application which I am trying to run (F9) through the debugger on OSX. However every time the IDE hangs, and I have to kill it. Also the application never starts. If I try to run it without the debugger (Shirt+Ctrl+F9), the application runs fine.

The PAServer console shows this:
Process Control Server Started pid 11401 exe  built Apr 18 2014
sentinelFunc 11403

I have tried installing C++ Builder XE6 on another computer with the same result, and I have just tried the trial version of C++ Builder 10.1 again with the same result. Does anyone know how to get the debugger working with OSX?

Ivan Johansen
Ivan Johansen

Posts: 27
Registered: 3/17/00
Re: IDE crashing when trying to debug OS X program  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 7, 2017 1:42 PM   in response to: Ivan Johansen in response to: Ivan Johansen
I am going to answer my own question. It looks like it is only a problem with OS X 10.12. I have installed OS X 10.11 in a Parallels virtual machine and that works.

Ivan Johansen
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02