Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Intraweb 14.1.4 install problem


This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 10 - Last Post: Feb 7, 2017 2:30 PM Last Post By: S. Mahaux
Steve Forshaw

Posts: 5
Registered: 12/17/03
Intraweb 14.1.4 install problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 25, 2017 9:15 AM
Having cleared out previous versions and then installed version 14.1.4 in Delphi XE8, created a new Intraweb project and then syntax checked. The result was an error:
"[dcc32 Fatal Error] IWLicenseKey.pas(41): F2051 Unit InSSLOpenSSL was compiled with a different version of InServerIOHandler.TInServerIOHandler.Notification"

Any help on how to get around this would be appreciated. Thanks. Steve
Eitan Arbel

Posts: 508
Registered: 2/24/13
Re: Intraweb 14.1.4 install problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 25, 2017 9:47 AM   in response to: Steve Forshaw in response to: Steve Forshaw
Steve Forshaw wrote:
Having cleared out previous versions and then installed version 14.1.4 in Delphi XE8, created a new Intraweb project and then syntax checked. The result was an error:
"[dcc32 Fatal Error] IWLicenseKey.pas(41): F2051 Unit InSSLOpenSSL was compiled with a different version of InServerIOHandler.TInServerIOHandler.Notification"

Any help on how to get around this would be appreciated. Thanks. Steve

did you use the IWBundledRemovalTool before you re-installed, or just uninstalled the previous version?

i don't use SSL so i don't know much about it, but if there is something to install to use SSL, is it's version compatible with IW (not too old, and maybe even not too new) ?

Chad Hower

Posts: 613
Registered: 3/2/07
Re: Intraweb 14.1.4 install problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 25, 2017 12:15 PM   in response to: Eitan Arbel in response to: Eitan Arbel
On 1/25/2017 1:47 PM, Eitan Arbel wrote:
did you use the IWBundledRemovalTool before you re-installed, or just
uninstalled the previous version?

+1
Steve Forshaw

Posts: 5
Registered: 12/17/03
Re: Intraweb 14.1.4 install problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 26, 2017 2:01 AM   in response to: Steve Forshaw in response to: Steve Forshaw
Etan and Chad - thanks for quick response. I had used that uninstall tool and I have deleted any files/folders/registry entries that I can find and re-installed 14.1.4 but still the same problem. Just been informed 14.1.5 is available so will try that.
Eitan Arbel

Posts: 508
Registered: 2/24/13
Re: Intraweb 14.1.4 install problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 26, 2017 4:59 AM   in response to: Steve Forshaw in response to: Steve Forshaw
Just been informed 14.1.5 is available so will try that.

don't forget to use the IWBundledRemovalTool before every IW installation
Steve Forshaw

Posts: 5
Registered: 12/17/03
Re: Intraweb 14.1.4 install problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 26, 2017 7:01 AM   in response to: Eitan Arbel in response to: Eitan Arbel
Yes, I do use the IWBundledRemovalTool before installing IntraWeb but it always says
"IntraWeb bundled files were not found. Probably they have been already removed."
Still have same error on version 14.1.5
Alexandre Machado

Posts: 1,754
Registered: 8/10/13
Re: Intraweb 14.1.4 install problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 30, 2017 12:47 AM   in response to: Steve Forshaw in response to: Steve Forshaw
Steve Forshaw wrote:
Yes, I do use the IWBundledRemovalTool before installing IntraWeb but it always says
"IntraWeb bundled files were not found. Probably they have been already removed."
Still have same error on version 14.1.5

You probably have other versions of IntraWeb Indy units around.

How is your Library path configured? Does it contain other versions of IntraWeb?

Can you please try to find other In*.dcu files in your system and see what you get?
Steve Forshaw

Posts: 5
Registered: 12/17/03
Re: Intraweb 14.1.4 install problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 30, 2017 3:29 AM   in response to: Alexandre Machado in response to: Alexandre Machado
Alexandre Machado wrote:
You probably have other versions of IntraWeb Indy units around.

How is your Library path configured? Does it contain other versions of IntraWeb?

Can you please try to find other In*.dcu files in your system and see what you get?

This was my immediate thought as well (I am not a newbie to Delphi). This is on my Windows 8 machine and I had searched it for InSSL*.dcu files and didn't find any after my cleardown. Still had same problem after re-install of IW. This morning I was working on my Server 2008 machine and at random decided to search my Win8 drives from the Server. Lo & behold, it found some old InSSL... files in studio\16.0\lib\win32\debug and release that my frequent searches in Win8 did not show!!!

Problem solved and thanks to all who helped with this (except Microsoft who didn't)
Eitan Arbel

Posts: 508
Registered: 2/24/13
Re: Intraweb 14.1.4 install problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 30, 2017 5:37 AM   in response to: Steve Forshaw in response to: Steve Forshaw
This morning I was working on my Server 2008 machine and at random decided to search my Win8 drives from the Server. Lo & behold, it found some old InSSL... files in studio\16.0\lib\win32\debug and release that
my frequent searches in Win8 did not show!!!

Problem solved and thanks to all who helped with this (except Microsoft who didn't)

i had cases where i saw a file i needed right in front of me, and the Windows search (8, 8.1, and 10) didn't find.
i use Total Commander to search for files...
Steve Forshaw

Posts: 5
Registered: 12/17/03
Re: Intraweb 14.1.4 install problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 30, 2017 6:56 AM   in response to: Eitan Arbel in response to: Eitan Arbel
i had cases where i saw a file i needed right in front of me, and the Windows search (8, 8.1, and 10) didn't find.
i use Total Commander to search for files...

Thanks, Eitan - it's nice to know I'm not yet completely bonkers. I'll give Total Commander a try.
S. Mahaux

Posts: 40
Registered: 4/4/02
Re: Intraweb 14.1.4 install problem  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 7, 2017 2:30 PM   in response to: Eitan Arbel in response to: Eitan Arbel
Eitan Arbel wrote:
i had cases where i saw a file i needed right in front of me, and the Windows search (8, 8.1, and 10) didn't find.
i use Total Commander to search for files...

I love Search Everything from Void Tools. It's incredibly fast.
http://www.voidtools.com/
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02