Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Set Active Language not updating registry key



Permlink Replies: 1 - Last Post: Sep 22, 2016 7:26 AM Last Post By: Geoff Von Allmen Threads: [ Previous | Next ]
Geoff Von Allmen

Posts: 6
Registered: 4/17/16
Set Active Language not updating registry key
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 22, 2016 6:47 AM
When I change the active language from Project->Languages->Set Active Language, it always shows the English version regardless of what is selected.

I can see the translated version in the translation manager only if I select 'show the translated form' and then click the 'refresh translated form' button.

The following three registry keys exist in HK_CURRENT_USER/Software/Embarcadero/Locales

[String (value)]
C:\Projects\Test\Test.exe (en-US)
C:\Projects\Test\Source\..\Test.exe (en-US)
C:\Projects\Test\Source\Test.groupproj (en-US)

When I change the active language to simplified chinese (CHS), the only key that updates is the Test.groupproj key, which will change to CHS. The other two stay as en-US. This remains true after rebuilding all, etc.

I found if I manually change the ..Source\..\Test.exe value to CHS it properly displays the translated version or whatever version represents the key, but I don't think manually switching registry keys is how this is supposed to work.

I have not done any other manual manipulation up to this point (aside from having to copy the DBLOGDLG.dfm and DBPWDLG.dfm into the CHS/vcl folder upon language addition in order to get it to compile... they are always missing when you first add a new language it would seem).

Has anyone else ever encountered anything like this?

Thanks for your time -
Geoff Von Allmen

Posts: 6
Registered: 4/17/16
Re: Set Active Language not updating registry key
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 22, 2016 7:26 AM   in response to: Geoff Von Allmen in response to: Geoff Von Allmen
Geoff Von Allmen wrote:
When I change the active language from Project->Languages->Set Active Language, it always shows the English version regardless of what is selected.

I can see the translated version in the translation manager only if I select 'show the translated form' and then click the 'refresh translated form' button.

The following three registry keys exist in HK_CURRENT_USER/Software/Embarcadero/Locales

[String (value)]
C:\Projects\Test\Test.exe (en-US)
C:\Projects\Test\Source\..\Test.exe (en-US)
C:\Projects\Test\Source\Test.groupproj (en-US)

When I change the active language to simplified chinese (CHS), the only key that updates is the Test.groupproj key, which will change to CHS. The other two stay as en-US. This remains true after rebuilding all, etc.

I found if I manually change the ..Source\..\Test.exe value to CHS it properly displays the translated version or whatever version represents the key, but I don't think manually switching registry keys is how this is supposed to work.

I have not done any other manual manipulation up to this point (aside from having to copy the DBLOGDLG.dfm and DBPWDLG.dfm into the CHS/vcl folder upon language addition in order to get it to compile... they are always missing when you first add a new language it would seem).

Has anyone else ever encountered anything like this?

Thanks for your time -

I was able to resolve this by opening the original project file (not the group one), deleting the CHS directory, and re-creating everything from that. I had been trying to re-create the language from the groupproj before, and it would seem that groupproj had become disconnected from the registry somehow.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02