Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Error if upload Delphi 10 Seattle app to Apple TestFlight for beta testing


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 1 - Last Post: Sep 7, 2016 10:59 AM Last Post By: Dave Nottage
Knud van Eeden

Posts: 1
Registered: 11/27/97
Error if upload Delphi 10 Seattle app to Apple TestFlight for beta testing  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 7, 2016 7:11 AM
PLATFORM AND VERSION
iOS
Apple MacBook Air (13 inch MID 2012)
OS X El Captitan version 10.11.5
Memory 8 gigabytes 1600 MHz DD3
Delphi 10 Seattle and also Delphi 10.1 Berlin

DESCRIPTION OF PROBLEM
I try to upload an Delphi 10.ipa file to TestFlight but always get an error in Apple 'Application Loader':

'Application loader is unable to upload your package.
No suitable application records were found.
Verify your bundle identifier 'com.projectname' is correct.

Note: My guess about what is happening is that 'Application Loader' connects to and checks on 'iTunes connect' for the app details and can not find anything it looks for, then rejects it.

STEPS TO REPRODUCE

1. Get the Delphi generated .ipa file to your Apple Mac computer (e.g. use Dropbox or FTP)

2. Run as usual the Apple 'Application Loader' program (here version 3.5 (921) is used)

3. I then always get the error:

'Application loader is unable to upload your package.
No suitable application records were found.
Verify your bundle identifier 'com.yourprojectname' is correct.'

4. Have you maybe seen this error? If so how to resolve it?

5. I tried further several bundle names and tried some variations of bundle id in my app names on iTunes connect.

Thanks

Edited by: Knud van Eeden on Sep 7, 2016 4:11 PM

Edited by: Knud van Eeden on Sep 7, 2016 4:12 PM

Edited by: Knud van Eeden on Sep 7, 2016 5:31 PM
Dave Nottage

Posts: 1,850
Registered: 1/7/00
Re: Error if upload Delphi 10 Seattle app to Apple TestFlight for beta testing [Edit]  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 7, 2016 10:59 AM   in response to: Knud van Eeden in response to: Knud van Eeden
Knud van Eeden wrote:

'Application loader is unable to upload your package.
No suitable application records were found.
Verify your bundle identifier 'com.projectname' is correct.

The bundle identifier needs to match what you've specified on iTunesConnect. The bundle identifier in your project is
in the project options, in the Version Info section, and is the CFBundleIdentifier value.

On iTunesConnect, the bundle identifier is the Bundle ID value in the App Information section.

These two need to match.

--
Dave Nottage [TeamB]
Hints, tips and tricks at: http://www.delphiworlds.com/blog
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02