Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: DCC Error E2597 Id: file to small (length=0) for architecture armv7 error


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 8 - Last Post: Nov 26, 2016 5:10 PM Last Post By: Dave Nottage
Mahmut Buyukoglu

Posts: 3
Registered: 7/16/06
DCC Error E2597 Id: file to small (length=0) for architecture armv7 error  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Aug 30, 2016 5:20 AM
Hi ,

My compiler is Delphi 10 Seattle.
I developed IOS and Android applications.
When I run my program on IOS platform,
get this error message and not run my application.

"[DCC Error] E2597 ld: file too small (length=0) for architecture armv7"
"[DCC Fatal Error] F2588 Linker error code: 1 ($00000001)"
"Failed"

How can I solve this problem.
Please help me :)
Dave Nottage

Posts: 1,850
Registered: 1/7/00
Re: DCC Error E2597 Id: file to small (length=0) for architecture armv7 error  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Aug 31, 2016 12:42 AM   in response to: Mahmut Buyukoglu in response to: Mahmut Buyukoglu
Mahmut Buyukoglu wrote:

When I run my program on IOS platform,
get this error message and not run my application.

"[DCC Error] E2597 ld: file too small (length=0) for architecture armv7"
"[DCC Fatal Error] F2588 Linker error code: 1 ($00000001)"
"Failed"

Compiling for which target? i.e. iOS Device 32-bit, or 64-bit? Have you done a Clean, then Build?

--
Dave Nottage [TeamB]
Hints, tips and tricks at: http://www.delphiworlds.com/blog
Zoltán Kelemen

Posts: 4
Registered: 4/2/11
Re: DCC Error E2597 Id: file to small (length=0) for architecture armv7 error  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 15, 2016 3:47 AM   in response to: Dave Nottage in response to: Dave Nottage
Hi!

I have the same problem as I wrote yesterday.
I use Delphi 10 Seattle without Update. Can it be the problem? Should I have to upgrade my Delphi?

Thanks!
Zoltán Kelemen

Posts: 4
Registered: 4/2/11
Re: DCC Error E2597 Id: file to small (length=0) for architecture armv7 error  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 14, 2016 1:50 AM   in response to: Mahmut Buyukoglu in response to: Mahmut Buyukoglu
Hello!

Have you found a solution? I have the same problem after I updated xcode to 8.1 and I tried to build my project to iOS 10.1 32 bit.

Thanks!
Zoli

Edited by: Zoltán Kelemen on Nov 14, 2016 1:52 AM
Zoltán Kelemen

Posts: 4
Registered: 4/2/11
Re: DCC Error E2597 Id: file to small (length=0) for architecture armv7 error  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 25, 2016 4:32 AM   in response to: Mahmut Buyukoglu in response to: Mahmut Buyukoglu
I've just found the solution:

The problem was that the SystemConfiguration file was incorrect at C:\Users\username\Documents\Embarcadero\Studio\SDKs\iPhoneOS10.1.sdk\System\Library\Frameworks\SystemConfiguration.framework\

Steps to correct it:
1. Delete the SystemConfiguration file
2. Go to: Delphi -> Tools -> Options -> Environment Options -> SDK Manager -> your SDK Version
3. At the Remote paths window click the "Add a new path item" button.
4. Fill the Path on remote machine section with this: $(SDKROOT)/System/Library/Frameworks
5. Fill the Framework name section with this: SystemConfiguration
6. Don't check anything else!!!
7. Click OK
8. Click the Update Local File Cache button

These steps'll solve this problem!
Onur KOCA

Posts: 31
Registered: 2/12/12
Re: DCC Error E2597 Id: file to small (length=0) for architecture armv7 error  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 25, 2016 1:19 PM   in response to: Zoltán Kelemen in response to: Zoltán Kelemen
hi, first im getting after updated xcode, this error,

[DCC Error] E2597 ld: warning: directory not found for option '-FD:\Home\Documents\Embarcadero\Studio\SDKs\iPhoneOS10.1.sdk\System\Library\PrivateFrameworks'
ld: file too small (length=0) for architecture armv7

after, i deleted framework UIFoundation, "directory not found problem" gone.
but still architecture stay.

i do, added and updated SystemConfiguration, but problem is still continuing.

(XCODE 8.1 - PA17.0 - OSX 10.11.6 El Capitan) (Win764Bit - Seatle 10 Without Update )

Edited by: Onur KOCA on Nov 25, 2016 1:29 PM
Dave Nottage

Posts: 1,850
Registered: 1/7/00
Re: DCC Error E2597 Id: file to small (length=0) for architecture armv7 error [Edit]  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 25, 2016 4:11 PM   in response to: Onur KOCA in response to: Onur KOCA
Onur KOCA wrote:

(XCODE 8.1 - PA17.0 - OSX 10.11.6 El Capitan) (Win764Bit - Seatle 10 Without Update )

Even if you were able to compile, that combination will not allow you to debug (i.e. Xcode 8.1 and Seattle 10). You
either need to revert to Xcode 7.3, or update to Delphi 10.1 Berlin Update 1.

PS: Kudos for supplying that information!

--
Dave Nottage [MVP, TeamB]
Hints, tips and tricks at: http://www.delphiworlds.com/blog
Onur KOCA

Posts: 31
Registered: 2/12/12
Re: DCC Error E2597 Id: file to small (length=0) for architecture armv7 error [Edit]  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 26, 2016 1:52 AM   in response to: Dave Nottage in response to: Dave Nottage
Even if you were able to compile, that combination will not allow you to debug (i.e. Xcode 8.1 and Seattle 10). You
either need to revert to Xcode 7.3, or update to Delphi 10.1 Berlin Update 1.

i cant do this, because application loader getting error messages, for compiled xcode7.3 softwares and doesnt allow upload.

im installed xe10.up2 with paserver18 problem gone.
Dave Nottage

Posts: 1,850
Registered: 1/7/00
Re: DCC Error E2597 Id: file to small (length=0) for architecture armv7 error [Edit]  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 26, 2016 5:10 PM   in response to: Onur KOCA in response to: Onur KOCA
Onur KOCA wrote:

im installed xe10.up2 with paserver18 problem gone.

Good to know, thanks.

--
Dave Nottage [MVP, TeamB]
Hints, tips and tricks at: http://www.delphiworlds.com/blog
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02