Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: IW 14.0.53 - ISAPI is not responding the content-type



Permlink Replies: 6 - Last Post: Jun 2, 2016 8:24 AM Last Post By: Pedro Lopes
Pedro Lopes

Posts: 97
Registered: 3/2/00
IW 14.0.53 - ISAPI is not responding the content-type
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 1, 2016 3:20 AM
Hello

As we have posted in news.atozed.com

IW14.0.53 ISAPI is not responding the content-type for css / js files, which is the case of internal IWNotify.css

This generates errors in IE mainly.

Please check

Best Regards

cgdevtools
Shane Stump

Posts: 138
Registered: 2/16/01
Re: IW 14.0.53 - ISAPI is not responding the content-type
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 1, 2016 7:50 PM   in response to: Pedro Lopes in response to: Pedro Lopes
Howdy Pedro!

I was getting ready to ask on the CGDevTools the status with Berlin and I guess this answers it <lol>!

All the best!

Shane

P.S. Say howdy to Jorge!

Pedro Lopes wrote:
Hello

As we have posted in news.atozed.com

IW14.0.53 ISAPI is not responding the content-type for css / js files, which is the case of internal IWNotify.css

This generates errors in IE mainly.

Please check

Best Regards

cgdevtools
Alexandre Machado

Posts: 1,754
Registered: 8/10/13
Re: IW 14.0.53 - ISAPI is not responding the content-type
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 2, 2016 12:55 AM   in response to: Pedro Lopes in response to: Pedro Lopes
Pedro Lopes wrote:
Hello

As we have posted in news.atozed.com

IW14.0.53 ISAPI is not responding the content-type for css / js files, which is the case of internal IWNotify.css

This generates errors in IE mainly.

Please check

Best Regards

cgdevtools

If is not inconvenient for you, could you please report these kind of issues directly to our e-mail? I think it will be faster for everybody, once we usually check newsgroups once a day...
Alexandre Machado

Posts: 1,754
Registered: 8/10/13
Re: IW 14.0.53 - ISAPI is not responding the content-type
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 2, 2016 1:59 AM   in response to: Pedro Lopes in response to: Pedro Lopes
Pedro Lopes wrote:
Hello

As we have posted in news.atozed.com

IW14.0.53 ISAPI is not responding the content-type for css / js files, which is the case of internal IWNotify.css

This generates errors in IE mainly.

Please check

Best Regards

cgdevtools

Pedro,

This issue is already fixed in our code base, so you can test it.
We are building a new release for general use right now.

Thanks for your report.
Pedro Lopes

Posts: 97
Registered: 3/2/00
Re: IW 14.0.53 - ISAPI is not responding the content-type
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 2, 2016 2:11 AM   in response to: Alexandre Machado in response to: Alexandre Machado
Hello Alexandre

We sent you an email on May/23 about another subject, and May/30 about this subject.

We've already tested your recent changes in unit IW.Isapi.Extension.pas, and everything is working as expected, please notify if you plan to release a new version.

With Best Regards

cgdevtools

Alexandre Machado wrote:
Pedro Lopes wrote:
Hello

As we have posted in news.atozed.com

IW14.0.53 ISAPI is not responding the content-type for css / js files, which is the case of internal IWNotify.css

This generates errors in IE mainly.

Please check

Best Regards

cgdevtools

Pedro,

This issue is already fixed in our code base, so you can test it.
We are building a new release for general use right now.

Thanks for your report.
Alexandre Machado

Posts: 1,754
Registered: 8/10/13
Re: IW 14.0.53 - ISAPI is not responding the content-type
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 2, 2016 3:22 AM   in response to: Pedro Lopes in response to: Pedro Lopes
Pedro Lopes wrote:
Hello Alexandre

We sent you an email on May/23 about another subject, and May/30 about this subject.

Man... There are dozens of genuine e-mails in my SPAM folder, including yours. I don't know why, yet... I apologize for that.

The new release is ready: http://atozed.com/IntraWeb/Blog/20160602.EN.aspx

Kind regards
Pedro Lopes

Posts: 97
Registered: 3/2/00
Re: IW 14.0.53 - ISAPI is not responding the content-type
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 2, 2016 8:24 AM   in response to: Alexandre Machado in response to: Alexandre Machado
Ok, thanks

Our previous email from May/23 is as follows (translated):

About this function:

function TIWIsapiExtension.HasFiles: Boolean;
begin
Result := False;
if SameText(FMethod, 'POST') then begin
Result := StartsText('multipart/form-data', FContentType);
if not Result then begin
Result := (SameText(FContentType, 'application/octet-stream') and (FQueryFields.IndexOfName('IWFileUploader') >= 0)) or
CanParseContentType(FContentType);
end;
end;
end;

Since we cannot access to the “raw content” in THttpRequest, how can we make sure that ARequest.Files be filled with data.

We need this for some of our components, like IWCGJQWebCam (to get a snapshot) and IWCGJQSignature (to get an image of what the user signed).

Our workaround was adding IWFileUploader to the ajax request's url.

Best Regards

cgdevtools

Alexandre Machado wrote:
Pedro Lopes wrote:
Hello Alexandre

We sent you an email on May/23 about another subject, and May/30 about this subject.

Man... There are dozens of genuine e-mails in my SPAM folder, including yours. I don't know why, yet... I apologize for that.

The new release is ready: http://atozed.com/IntraWeb/Blog/20160602.EN.aspx

Kind regards
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02