Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Two Questions About dbExpress & Interbase under XE7


This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 3 - Last Post: Oct 21, 2015 8:54 AM Last Post By: Frederick Wilt Threads: [ Previous | Next ]
Frederick Wilt

Posts: 38
Registered: 9/27/99
Two Questions About dbExpress & Interbase under XE7  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 24, 2014 12:29 PM
See image:

https://dl.dropboxusercontent.com/u/66399228/XE6%20dbExpress%20Files.png

Should XE7 have files like these which I have in XE6?

See image

https://dl.dropboxusercontent.com/u/66399228/XE7%20dbExpress%20Error.png

When trying to create a new dbExpress connection for Interbase I get this error.

Any ideas why?

Edited by: Frederick Wilt on Nov 24, 2014 3:30 PM

Edited by: Frederick Wilt on Nov 24, 2014 3:31 PM
quinn wildman

Posts: 856
Registered: 12/2/99
Re: Two Questions About dbExpress & Interbase under XE7 [Edit]  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 25, 2014 3:31 PM   in response to: Frederick Wilt in response to: Frederick Wilt
This problem is known to happen when you install for just yourself
instead of for all users. Copy the XE6 versions of the files to where
XE7 should go to fix it.

Frederick Wilt wrote:
See image:

https://dl.dropboxusercontent.com/u/66399228/XE6%20dbExpress%20Files.png

Should XE7 have files like these which I have in XE6?

See image

https://dl.dropboxusercontent.com/u/66399228/XE7%20dbExpress%20Error.png

When trying to create a new dbExpress connection for Interbase I get this error.

Any ideas why?

Edited by: Frederick Wilt on Nov 24, 2014 3:30 PM

Edited by: Frederick Wilt on Nov 24, 2014 3:31 PM
Frederick Wilt

Posts: 38
Registered: 9/27/99
Re: Two Questions About dbExpress & Interbase under XE7 [Edit]  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 25, 2014 3:35 PM   in response to: quinn wildman in response to: quinn wildman
quinn wildman wrote:
This problem is known to happen when you install for just yourself
instead of for all users. Copy the XE6 versions of the files to where
XE7 should go to fix it.

Interesting to know.

Regards copying the XE6 files:

In one of the files (I forget which and I'm not at my computer) there is some version information - such as a file name that matches the XE6 file (which as a 200 in the name if I recall) where as the XE7 file has a 210 (I think).

Do all of these references need to be changed?

Thanks!
Frederick Wilt

Posts: 38
Registered: 9/27/99
Re: Two Questions About dbExpress & Interbase under XE7  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 21, 2015 8:54 AM   in response to: Frederick Wilt in response to: Frederick Wilt
Thanks to all.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02