Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Android deploying files to a user accessible location


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 3 - Last Post: Oct 2, 2015 5:56 AM Last Post By: Rick Waltemire
Rick Waltemire

Posts: 2
Registered: 1/10/15
Android deploying files to a user accessible location  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 1, 2015 7:49 AM
I can't get this to work in Seattle.

In XE7, I could deploy a file to .\assets\GraceData\ and when I download the apk and install it, it would create a folder under android\data\com.graceindustries.graceaic\files\GraceData where it would put my files. I could then browse to and access them from the device or from windows connected to the device.

In Seattle, it does not create this folder when I install the apk.

On both XE7 and Seattle when deploying my app via debugging from Rad Studio, it does deploy correctly and create the folder structure.

Thanks for any help.
Remy Lebeau (Te...


Posts: 9,447
Registered: 12/23/01
Re: Android deploying files to a user accessible location  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 1, 2015 2:08 PM   in response to: Borja Serrano in response to: Borja Serrano
Borja wrote:


Those functions are for accessing folders at runtime. Rick is saying that
Deployment is not working correctly, before the app is even run.

--
Remy Lebeau (TeamB)
Rick Waltemire

Posts: 2
Registered: 1/10/15
Re: Android deploying files to a user accessible location  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 2, 2015 5:56 AM   in response to: Remy Lebeau (Te... in response to: Remy Lebeau (Te...

Those functions are for accessing folders at runtime. Rick is saying that
Deployment is not working correctly, before the app is even run.

--
Remy Lebeau (TeamB)

That is correct. I understand how to access the different locations. The problem is when the package installs it is not putting the files where I specified in the deployment setup. Specifically the files I'm putting into a user accessible location. It worked fine in XE7 so maybe this could be a bug?

Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02