Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Delphi XE10 Seattle - App crash under IOS9.01 when a



Permlink Replies: 7 - Last Post: Sep 29, 2015 6:01 PM Last Post By: Mario Gagne
Mario Gagne

Posts: 93
Registered: 2/17/12
Delphi XE10 Seattle - App crash under IOS9.01 when a
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 25, 2015 1:03 PM
Hi

I have a problem with my application (ipa) When I open my application first time it is very long time more 10 sec.

My application is app failed during a test.

Error message

During review, your app failed to launch on iPhone running iOS 9.0.1 on both Wi-Fi and cellular networks. Specifically, when we selected the application on the Home screen, the app displayed a launch image then quit unexpectedly. This may be because iOS 9 uses a watchdog timer for applications; if an application takes too long to complete its initial startup, the operating system terminates the application.

I check my application(ipa) I dont find my problem.

Thank for your help.

Mario
Brian Hamilton ...

Posts: 556
Registered: 10/14/04
Re: Delphi XE10 Seattle - App crash under IOS9.01 when a
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 25, 2015 2:53 PM   in response to: Mario Gagne in response to: Mario Gagne
try not having too much start up code in the onshow
instead use a timer for that start up code
also problems can occur if lots of images on the form...you could load them from a resource file via the one time fire timer
Eli M

Posts: 1,346
Registered: 11/9/13
Re: Delphi XE10 Seattle - App crash under IOS9.01 when a
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 25, 2015 11:46 PM   in response to: Mario Gagne in response to: Mario Gagne
Put any network calls in an anonymous thread. Network calls in the main thread will cause the app to close out if they take longer than 10 seconds.
Mario Gagne

Posts: 93
Registered: 2/17/12
Re: Delphi XE10 Seattle - App crash under IOS9.01 when a
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 26, 2015 5:42 AM   in response to: Eli M in response to: Eli M
Eli M wrote:
Put any network calls in an anonymous thread. Network calls in the main thread will cause the app to close out if they take longer than 10 seconds.

Thank for your help

Can you explain more '' Put any network calls in an anonymous thread.''

I dont underdstand your awnser. It's not clear for me

Thank again

Mario

Mario Gagne

Posts: 93
Registered: 2/17/12
Re: Delphi XE10 Seattle - App crash under IOS9.01 when a
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 26, 2015 8:20 AM   in response to: Mario Gagne in response to: Mario Gagne
Mario Gagne wrote:
Eli M wrote:
Put any network calls in an anonymous thread. Network calls in the main thread will cause the app to close out if they take longer than 10 seconds.

Thank for your help

Can you explain more '' Put any network calls in an anonymous thread.''

I dont underdstand your awnser. It's not clear for me

Thank again

Mario


Just additional information I did a test with
only a form and a button and it takes at least 20 seconds to open and close my application automatically.

I use XE10 with ios 9.01. AD_HOC mode

I no longer understand why.
Mario
Markus Humm

Posts: 5,113
Registered: 11/9/03
Re: Delphi XE10 Seattle - App crash under IOS9.01 when a
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 27, 2015 1:07 AM   in response to: Mario Gagne in response to: Mario Gagne
Am 26.09.2015 um 17:20 schrieb Mario Gagne:
Mario Gagne wrote:
Eli M wrote:
Put any network calls in an anonymous thread. Network calls in the main thread will cause the app to close out if they take longer than 10 seconds.

Thank for your help

Can you explain more '' Put any network calls in an anonymous thread.''

I dont underdstand your awnser. It's not clear for me

Thank again

Mario


Just additional information I did a test with
only a form and a button and it takes at least 20 seconds to open and close my application automatically.

I use XE10 with ios 9.01. AD_HOC mode

I no longer understand why.
Mario

Hello,

has your app. a OnCreate or OnShow event with code in it?

Greetings

Markus
Mario Gagne

Posts: 93
Registered: 2/17/12
Re: Delphi XE10 Seattle - App crash under IOS9.01 when a
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 27, 2015 8:32 AM   in response to: Markus Humm in response to: Markus Humm
Markus Humm wrote:
Am 26.09.2015 um 17:20 schrieb Mario Gagne:
Mario Gagne wrote:
Eli M wrote:
Put any network calls in an anonymous thread. Network calls in the main thread will cause the app to close out if they take longer than 10 seconds.

Thank for your help

Can you explain more '' Put any network calls in an anonymous thread.''

I dont underdstand your awnser. It's not clear for me

Thank again

Mario


Just additional information I did a test with
only a form and a button and it takes at least 20 seconds to open and close my application automatically.

I use XE10 with ios 9.01. AD_HOC mode

I no longer understand why.
Mario

Hello,

has your app. a OnCreate or OnShow event with code in it?

Greetings

Markus

Thank for information

I take a lot a test with my application

Time to open first time

...................................... simulator on mac.................developpement 32 bits (iphone5)..........Ad-hoc iPhone 5............Distribution apple ............Note
Test 1 (iPhone 5 ios 9.0)...............3 sec.....................................................................................................................................................................nophone ok no crash

test 2............................................................................................8sec...................................................................................................................... All ok no crash

test 3......................................................................................................................................+-20 sec......................................................................crash first time and ok second time

test 4....................................................................................................................................................................Refuse by apple............................crash first time time too long to open

delete oncreate............................same time

delete inifile .................................same time

delete all icons and picture...........same time

My next test is to rebuild my application step by step to find my error.

Thank a lot for your help

Mario

Edited by: Mario Gagne on Sep 27, 2015 4:04 PM
Mario Gagne

Posts: 93
Registered: 2/17/12
Re: Delphi XE10 Seattle - App crash under IOS9.01 first time
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 29, 2015 6:01 PM   in response to: Mario Gagne in response to: Mario Gagne
Mario Gagne wrote:
Markus Humm wrote:
Am 26.09.2015 um 17:20 schrieb Mario Gagne:
Mario Gagne wrote:
Eli M wrote:
Put any network calls in an anonymous thread. Network calls in the main thread will cause the app to close out if they take longer than 10 seconds.

Thank for your help

Can you explain more '' Put any network calls in an anonymous thread.''

I dont underdstand your awnser. It's not clear for me

Thank again

Mario


Just additional information I did a test with
only a form and a button and it takes at least 20 seconds to open and close my application automatically.

I use XE10 with ios 9.01. AD_HOC mode

I no longer understand why.
Mario

Hello,

has your app. a OnCreate or OnShow event with code in it?

Greetings

Markus

Thank for information

I take a lot a test with my application

Time to open first time

...................................... simulator on mac.................developpement 32 bits (iphone5)..........Ad-hoc iPhone 5............Distribution apple ............Note
Test 1 (iPhone 5 ios 9.0)...............3 sec.....................................................................................................................................................................nophone ok no crash

test 2............................................................................................8sec...................................................................................................................... All ok no crash

test 3......................................................................................................................................+-20 sec......................................................................crash first time and ok second time

test 4....................................................................................................................................................................Refuse by apple............................crash first time time too long to open

delete oncreate............................same time

delete inifile .................................same time

delete all icons and picture...........same time

My next test is to rebuild my application step by step to find my error.

Thank a lot for your help

Mario

Edited by: Mario Gagne on Sep 27, 2015 4:04 PM

When I test with Ad-Hoc 32 bits my software is ok 8 sec to open first time but I test with Ad-Hoc 64 bits + 20 sec and scrach.

If you have one idea.

Thank you

Mario
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02