Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: ERROR ITMS-90094 & INFO ITMS-90111


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 4 - Last Post: Sep 24, 2015 12:59 AM Last Post By: Thomas Schulz
Thomas Degen

Posts: 5
Registered: 4/29/04
ERROR ITMS-90094 & INFO ITMS-90111  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jul 24, 2015 7:12 AM
I am trying to submit an App made with XE8 (Xcode 6.4) using the Application Loader

and I am getting 2 errors:

1) ERROR ITMS-90094: "Invalid Launch Image - Your app contains a launch image with a

size modifier that is only supported for apps built with the iOS 6.0 SDK or later

2) INFO-X: INFO ITMS-90111: "Your app is built with a beta version of Xcode or iOS SDK.

Only apps distributed for beta testing may be built with beta software. To submit an app

for distribution on the App Store, you will need to build the app with release versions of

Xcode and iOS SDK.

I am of course linking against iPhone SK8.4

($(BDSPLATFORMSDKSDIR)\iPhoneOS8.4.sdk)

Does anyone know what is going on here,please?

Rudy Velthuis (...


Posts: 7,731
Registered: 9/22/99
Re: ERROR ITMS-90094 & INFO ITMS-90111  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Aug 18, 2015 10:39 AM   in response to: Thomas Degen in response to: Thomas Degen
Thomas Degen wrote:

I am of course linking against iPhone SK8.4

($(BDSPLATFORMSDKSDIR)\iPhoneOS8.4.sdk)

Does anyone know what is going on here,please?

As you already quoted:

for distribution on the App Store, you will need to build the app
with release versions of Xcode and iOS SDK.

--
Rudy Velthuis http://www.rvelthuis.de

"The greatest deception men suffer is from their own opinions."
-- Leonardo da Vinci

Thomas Schulz

Posts: 62
Registered: 12/6/99
Re: ERROR ITMS-90094 & INFO ITMS-90111  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 23, 2015 2:31 AM   in response to: Rudy Velthuis (... in response to: Rudy Velthuis (...
Rudy Velthuis (TeamB) wrote:
Thomas Degen wrote:

I am of course linking against iPhone SK8.4

($(BDSPLATFORMSDKSDIR)\iPhoneOS8.4.sdk)

Does anyone know what is going on here,please?

As you already quoted:

for distribution on the App Store, you will need to build the app
with release versions of Xcode and iOS SDK.

It has been a while since I am been using Delphi for mobile, but does this not collide with the problems mentioned here?
https://forums.embarcadero.com/thread.jspa?threadID=117612&tstart=0
https://forums.embarcadero.com/thread.jspa?threadID=117751&tstart=0
Thomas Degen

Posts: 5
Registered: 4/29/04
Re: ERROR ITMS-90094 & INFO ITMS-90111  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 23, 2015 4:32 AM   in response to: Thomas Schulz in response to: Thomas Schulz
Thomas Schulz wrote:
Rudy Velthuis (TeamB) wrote:
Thomas Degen wrote:

I am of course linking against iPhone SK8.4

($(BDSPLATFORMSDKSDIR)\iPhoneOS8.4.sdk)

Does anyone know what is going on here,please?

As you already quoted:

for distribution on the App Store, you will need to build the app
with release versions of Xcode and iOS SDK.

It has been a while since I am been using Delphi for mobile, but does this not collide with the problems mentioned here?
https://forums.embarcadero.com/thread.jspa?threadID=117612&tstart=0
https://forums.embarcadero.com/thread.jspa?threadID=117751&tstart=0

No, the initial problem was about some wrong/outdated items in the info.plist file, as I found out later. The executable(app) was fine.
Thomas Schulz

Posts: 62
Registered: 12/6/99
Re: ERROR ITMS-90094 & INFO ITMS-90111  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 24, 2015 12:59 AM   in response to: Thomas Degen in response to: Thomas Degen
for distribution on the App Store, you will need to build the app
with release versions of Xcode and iOS SDK.

It has been a while since I am been using Delphi for mobile, but does this not collide with the problems mentioned here?
https://forums.embarcadero.com/thread.jspa?threadID=117612&tstart=0
https://forums.embarcadero.com/thread.jspa?threadID=117751&tstart=0

No, the initial problem was about some wrong/outdated items in the info.plist file, as I found out later. The executable(app) was fine.

Okay - thanks for the info. That means xcode 6.4 should work for my needs
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02