Watch, Follow, &
Connect with Us

Please visit our new home
community.embarcadero.com.


Welcome, Guest
Guest Settings
Help

Thread: ASPX Deployment



Permlink Replies: 3 - Last Post: May 19, 2015 4:20 AM Last Post By: Chad Hower
Lou Feliz

Posts: 114
Registered: 7/16/97
ASPX Deployment
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 28, 2015 8:49 AM
Hello,

Tried deploying ASPX app and no luck after a few tries. It does work as
stand alone and ISAPI. I created new version of project specifically for
ASPX making sure it looked similar to the empty ASPX project.

Has anyone had success with this? I would appreciate if you could take a
look at my notes and config below

I have followed steps to deploy as ASPX as outlined at
http://docs.atozed.com/docs.dll/deployment/ASPX%20Deployment.html

Using IW 14.0.37 (Plan to update once I get this working).

Stand Alone server 2008R2
I setup a user appu and group appg

I give group appg full rights to the App folder, web folder and aspx folder

default website root path: c:\inetpub\wwwroot\

ASPX path : c:\inetpub\wwwroot\aspxpth (my intention is to deploy
eventually deploy 2 apps on server)

ASPX path has the bin folder and files where they are supposed to be (as
specified in documentation)

App path : c:\inetpub\wwwroot\pthapp (contains the .dll wwroot folder for
IW app etc....

Created Pool object and application according to the web documentation and
set user to the user created.

updated web.config (see end of message for actual file)

browse localhost\pthapp

HTTP Error 403.14 - Forbidden
The Web server is configured to not list the contents of this directory.

Module DirectoryListingModule
Notification ExecuteRequestHandler
Handler StaticFile
Error Code 0x00000000
Requested URL http://localhost:80/pthapp/
Physical Path C:\inetpub\wwwroot\ASPXPTH\
Logon Method Anonymous
Logon User Anonymous


web.config

<configuration>

<appSettings>
<add key="webpages:Version" value="2.0.0.0"/>
<add key="webpages:Enabled" value="false"/>
<add key="PreserveLoginUrl" value="true"/>
<add key="ClientValidationEnabled" value="true"/>
<add key="UnobtrusiveJavaScriptEnabled" value="true"/>

<!-- STEP 1: Change "value" below to match your application name under
IIS -->
<add key="wwwroot" value="wwwroot\pthapp"/>

<!-- STEP 2: Change "value" below to match your IntraWeb Library (DLL)
module -->
<add key="Application" value="C:\inetpub\wwwroot\pthapp\Training.dll"/>

<!-- STEP 3: Change "value" below to "true" if you are using IWP
(IntraWeb pages). Otherwise leave it as "false" -->
<add key="IWPEnabled" value="false"/>
</appSettings>

<system.web>
<!-- STEP 4: Change "debug" value below to "false" if you are deploying
in PRODUCTION environment -->
<compilation debug="true" targetFramework="4.5"/>
<pages>
<namespaces>
<add namespace="System.Web.Routing"/>
<add namespace="System.Web.WebPages"/>
</namespaces>
</pages>
</system.web>

<system.webServer>
<validation validateIntegratedModeConfiguration="false"/>
<modules runAllManagedModulesForAllRequests="true"/>
</system.webServer>

</configuration>

Lou Feliz

Posts: 114
Registered: 7/16/97
Re: ASPX Deployment
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 28, 2015 1:28 PM   in response to: Lou Feliz in response to: Lou Feliz
Update:

1) Found suggestion when having .net ASPX issues to do following:

C:\windows\Microsoft.NET\Framework64\v4.0.30319> .\aspnet_regiis.exe -ir
C:\windows\Microsoft.NET\Framework64\v4.0.30319> iisreset

2) Then try and I get new ASPX error

The current identity (CT11251\PTH) does not have write access to
'C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files'.

3) Gave security group modify rights to folder

4) now getting an IW Application Error...

Error message: Cannot change thread mode after it is set

Depending on the error condition, it might be possible to restart the
application.

5) Now its time to go back and to check IWServerController Co-Init setting
to see if that is the problem.

Cheers!

"Lou Feliz" <lou at feliz dot net> wrote in message
news:722195 at forums dot embarcadero dot com...
Hello,

Tried deploying ASPX app and no luck after a few tries. It does work as
stand alone and ISAPI. I created new version of project specifically for
ASPX making sure it looked similar to the empty ASPX project.

Has anyone had success with this? I would appreciate if you could take a
look at my notes and config below

I have followed steps to deploy as ASPX as outlined at
http://docs.atozed.com/docs.dll/deployment/ASPX%20Deployment.html

Using IW 14.0.37 (Plan to update once I get this working).

Stand Alone server 2008R2
I setup a user appu and group appg

I give group appg full rights to the App folder, web folder and aspx
folder

default website root path: c:\inetpub\wwwroot\

ASPX path : c:\inetpub\wwwroot\aspxpth (my intention is to deploy
eventually deploy 2 apps on server)

ASPX path has the bin folder and files where they are supposed to be (as
specified in documentation)

App path : c:\inetpub\wwwroot\pthapp (contains the .dll wwroot folder
for IW app etc....

Created Pool object and application according to the web documentation
and set user to the user created.

updated web.config (see end of message for actual file)

browse localhost\pthapp

HTTP Error 403.14 - Forbidden
The Web server is configured to not list the contents of this directory.

Module DirectoryListingModule
Notification ExecuteRequestHandler
Handler StaticFile
Error Code 0x00000000
Requested URL http://localhost:80/pthapp/
Physical Path C:\inetpub\wwwroot\ASPXPTH\
Logon Method Anonymous
Logon User Anonymous


web.config

<configuration>

<appSettings>
<add key="webpages:Version" value="2.0.0.0"/>
<add key="webpages:Enabled" value="false"/>
<add key="PreserveLoginUrl" value="true"/>
<add key="ClientValidationEnabled" value="true"/>
<add key="UnobtrusiveJavaScriptEnabled" value="true"/>

<!-- STEP 1: Change "value" below to match your application name under
IIS -->
<add key="wwwroot" value="wwwroot\pthapp"/>

<!-- STEP 2: Change "value" below to match your IntraWeb Library (DLL)
module -->
<add key="Application" value="C:\inetpub\wwwroot\pthapp\Training.dll"/>

<!-- STEP 3: Change "value" below to "true" if you are using IWP
(IntraWeb pages). Otherwise leave it as "false" -->
<add key="IWPEnabled" value="false"/>
</appSettings>

<system.web>
<!-- STEP 4: Change "debug" value below to "false" if you are deploying
in PRODUCTION environment -->
<compilation debug="true" targetFramework="4.5"/>
<pages>
<namespaces>
<add namespace="System.Web.Routing"/>
<add namespace="System.Web.WebPages"/>
</namespaces>
</pages>
</system.web>

<system.webServer>
<validation validateIntegratedModeConfiguration="false"/>
<modules runAllManagedModulesForAllRequests="true"/>
</system.webServer>

</configuration>

Lou Feliz

Posts: 114
Registered: 7/16/97
Re: ASPX Deployment
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 28, 2015 8:40 PM   in response to: Lou Feliz in response to: Lou Feliz
Finally Success!

I set ComInitialization in ServerController to ciMultiThread and ASPX app is working fine so far...time to test and see what happens.

Now the decision is do I use ASPX over ISAPI ?

Cheers!

- Lou

Lou Feliz wrote:
Hello,

Tried deploying ASPX app and no luck after a few tries. It does work as
stand alone and ISAPI. I created new version of project specifically for
ASPX making sure it looked similar to the empty ASPX project.

Has anyone had success with this? I would appreciate if you could take a
look at my notes and config below

I have followed steps to deploy as ASPX as outlined at
http://docs.atozed.com/docs.dll/deployment/ASPX%20Deployment.html

Using IW 14.0.37 (Plan to update once I get this working).

Stand Alone server 2008R2
I setup a user appu and group appg

I give group appg full rights to the App folder, web folder and aspx folder

default website root path: c:\inetpub\wwwroot\

ASPX path : c:\inetpub\wwwroot\aspxpth (my intention is to deploy
eventually deploy 2 apps on server)

ASPX path has the bin folder and files where they are supposed to be (as
specified in documentation)

App path : c:\inetpub\wwwroot\pthapp (contains the .dll wwroot folder for
IW app etc....

Created Pool object and application according to the web documentation and
set user to the user created.

updated web.config (see end of message for actual file)

browse localhost\pthapp

HTTP Error 403.14 - Forbidden
The Web server is configured to not list the contents of this directory.

Module DirectoryListingModule
Notification ExecuteRequestHandler
Handler StaticFile
Error Code 0x00000000
Requested URL http://localhost:80/pthapp/
Physical Path C:\inetpub\wwwroot\ASPXPTH\
Logon Method Anonymous
Logon User Anonymous


web.config

<configuration>

<appSettings>
<add key="webpages:Version" value="2.0.0.0"/>
<add key="webpages:Enabled" value="false"/>
<add key="PreserveLoginUrl" value="true"/>
<add key="ClientValidationEnabled" value="true"/>
<add key="UnobtrusiveJavaScriptEnabled" value="true"/>

<!-- STEP 1: Change "value" below to match your application name under
IIS -->
<add key="wwwroot" value="wwwroot\pthapp"/>

<!-- STEP 2: Change "value" below to match your IntraWeb Library (DLL)
module -->
<add key="Application" value="C:\inetpub\wwwroot\pthapp\Training.dll"/>

<!-- STEP 3: Change "value" below to "true" if you are using IWP
(IntraWeb pages). Otherwise leave it as "false" -->
<add key="IWPEnabled" value="false"/>
</appSettings>

<system.web>
<!-- STEP 4: Change "debug" value below to "false" if you are deploying
in PRODUCTION environment -->
<compilation debug="true" targetFramework="4.5"/>
<pages>
<namespaces>
<add namespace="System.Web.Routing"/>
<add namespace="System.Web.WebPages"/>
</namespaces>
</pages>
</system.web>

<system.webServer>
<validation validateIntegratedModeConfiguration="false"/>
<modules runAllManagedModulesForAllRequests="true"/>
</system.webServer>

</configuration>

Chad Hower

Posts: 613
Registered: 3/2/07
Re: ASPX Deployment
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 19, 2015 4:20 AM   in response to: Lou Feliz in response to: Lou Feliz
On 4/28/2015 11:40 PM, Lou Feliz wrote:
Finally Success!

I set ComInitialization in ServerController to ciMultiThread and ASPX app is working fine so far...time to test and see what happens.

Now the decision is do I use ASPX over ISAPI ?

Depends what you want. ASPX generally will be easier to deploy moving
forward.

--
"Programming is an art form that fights back"

Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02