Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: iOS 8.1.3/8.2 Deployment Beta Hotfix for XE7 Pro warning



Permlink Replies: 7 - Last Post: Apr 15, 2015 6:13 AM Last Post By: brent shelton Threads: [ Previous | Next ]
brent shelton

Posts: 29
Registered: 2/14/09
iOS 8.1.3/8.2 Deployment Beta Hotfix for XE7 Pro warning
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 13, 2015 7:39 AM
I installed the XE7 hotfix that was issued Friday April 10th 2015 named iOS 8.1.3/8.2 Deployment Beta Hotfix for XE7 Pro and now my IDE will not start due to a EPackageRegistrationException in module coreide210.bpl at 00031CBB error. I did submit this to Quality Portal. I hope I don't have to reinstall it.

At least I am able to use XE8, but not all my 3rd parties have updated their components. One thing I have found with XE8 is that I can now deploy to an iOS 7.1 iPhone 4 and a iOS8 iPhone 6 Plus with 8.3. I'm using XCode 6.3 on Yosemite.

Regards,
Brent
Eli M

Posts: 1,346
Registered: 11/9/13
Re: iOS 8.1.3/8.2 Deployment Beta Hotfix for XE7 Pro warning
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 13, 2015 9:21 AM   in response to: brent shelton in response to: brent shelton
I applied this to my XE7 Pro + Mobile with the same result. IDE won't launch.
brent shelton

Posts: 29
Registered: 2/14/09
Re: iOS 8.1.3/8.2 Deployment Beta Hotfix for XE7 Pro warning
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 14, 2015 1:21 PM   in response to: Eli M in response to: Eli M
Eli M wrote:
I applied this to my XE7 Pro + Mobile with the same result. IDE won't launch.

Yeah and using the Repair installation option won't fix it either. I am uninstalling and reinstalling. I'll just stick with modifying my entitlement file until there is a verified fix.

Brent
Dirk Carstensen

Posts: 33
Registered: 3/23/00
Re: iOS 8.1.3/8.2 Deployment Beta Hotfix for XE7 Pro warning
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 14, 2015 2:09 PM   in response to: brent shelton in response to: brent shelton
brent shelton wrote:
Eli M wrote:
I applied this to my XE7 Pro + Mobile with the same result. IDE won't launch.

Yeah and using the Repair installation option won't fix it either. I am uninstalling and reinstalling. I'll just stick with modifying my entitlement file until there is a verified fix.

Brent

Same here. Reinstall costs me a day, very frustating :-(
Dirk
Eli M

Posts: 1,346
Registered: 11/9/13
Re: iOS 8.1.3/8.2 Deployment Beta Hotfix for XE7 Pro warning
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 14, 2015 5:07 PM   in response to: brent shelton in response to: brent shelton
Where did you see the coreide error that you got? I got no error. I see it in Task Manager and then not but no error.
brent shelton

Posts: 29
Registered: 2/14/09
Re: iOS 8.1.3/8.2 Deployment Beta Hotfix for XE7 Pro warning
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 15, 2015 6:13 AM   in response to: Eli M in response to: Eli M
Eli M wrote:
Where did you see the coreide error that you got? I got no error. I see it in Task Manager and then not but no error.

When I double-clicked the Delphi XE7 icon I saw 4 error messages.

I may have screwed up when I reinstalled. While trying to fix the issue, I had set my desktop icon with the -r parameter. After I uninstalled without removing the registry settings and reinstalling, I couldn't compile anything. That caused me to have to uninstall including removing the registry settings and then reinstall. I made sure my desktop icon had the default -dDelphi parameter. I had to reinstall all my components. At this point I don't want to try applying the hotfix on my main system.

Brent
Thomas Degen

Posts: 5
Registered: 4/29/04
Re: iOS 8.1.3/8.2 Deployment Beta Hotfix for XE7 Pro warning
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 14, 2015 7:27 AM   in response to: brent shelton in response to: brent shelton
How did you apply this hotfix?
The readme file is not very informative about that step and there is no "setup.exe".
Did you simply copy the files over the already present installation ?
In addition the Readme file ist stating something about "a previous workaround" which should be performed
beforehand but also that without any precise information.

best regards.

Thomas
Eli M

Posts: 1,346
Registered: 11/9/13
Re: iOS 8.1.3/8.2 Deployment Beta Hotfix for XE7 Pro warning
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 14, 2015 5:05 PM   in response to: Thomas Degen in response to: Thomas Degen
http://blogs.embarcadero.com/sarinadupont/2015/01/29/ios-813-app-deployment-steps-for-xe7/

A B C was the previous workaround.

Yeah I just followed the steps in the file.


This Beta hotfix addresses the following issue:
 
Unable to deploy application to iOS device running iOS 8.1.3 or iOS 8.2.
 
This zip contains files to address the issue
 
 
If you performed the previous workaround from Embarcadero, then you should do the following:
 
1. Cd %appdata%
2. Del Embarcadero\BDS\15.0\Entitlement.TemplateiOS.xml
 
 
 
Perform the following steps:
 
1. Copy this zip file to your install directory.
2. Extract the zip
3. cd bin
4. Run tregsvr.bat in administrator mode
5. Copy PAServer\PAServer15b.0.pkg to your Mac and install it.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02