Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Debug info with manifest suddenly breaks application



Permlink Replies: 2 - Last Post: Jan 8, 2015 12:40 AM Last Post By: Sanjay Kanade
Sanjay Kanade

Posts: 16
Registered: 10/26/98
Debug info with manifest suddenly breaks application
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 7, 2015 9:36 PM
I'm using Delphi 2007 for a legacy application. I'm attaching a manifest via a post-build mt.exe run.

It has been working fine for quite some time. Suddenly, on the "debug" build, I have started getting an error as soon as I run it (Windows 7, both 32-bit and 64-bit):

<app> is not a valid win32 application

Clues:
1) If I don't attach the manifest, it runs fine.
2) If I attach the manifest and remove debug information in the Linker options, it runs fine.
3) The "release" build runs fine in any case.

Is it that somehow the application exe size with debug info has gone beyond certain size allowed for manifested apps? The size in debug build is now 31,761 KB.

I can, of course, continue to debug with manifest removed so it's not a critical problem but I would like to fix it. Any ideas?

Thanks.

P.S. Running dependency walker does not reveal anything. Identical results on no error build and error build.
Remy Lebeau (Te...


Posts: 9,447
Registered: 12/23/01
Re: Debug info with manifest suddenly breaks application [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 8, 2015 12:13 AM   in response to: Sanjay Kanade in response to: Sanjay Kanade
Sanjay wrote:

I'm using Delphi 2007 for a legacy application. I'm attaching
a manifest via a post-build mt.exe run.

You don't need to use mt.exe to add a manifest to your app. Just create
a .manifest file with your desired XML, then include it in your app's resources
using a .rc file.

--
Remy Lebeau (TeamB)
Sanjay Kanade

Posts: 16
Registered: 10/26/98
Re: Debug info with manifest suddenly breaks application [Edit]
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 8, 2015 12:40 AM   in response to: Remy Lebeau (Te... in response to: Remy Lebeau (Te...
I changed to the resource file as you suggested and it started working again.

So it seems, the bug might be in that version of mt.exe which somehow corrupts the file when it grows beyond a certain size.

Many thanks,
Sanjay
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02