Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Cannot have simultaneous installations of XE7 and RAD Studio 2010 ??


This question is answered.


Permlink Replies: 2 - Last Post: Nov 19, 2014 11:23 AM Last Post By: Mike Knoblock
Mike Knoblock

Posts: 24
Registered: 11/5/06
Cannot have simultaneous installations of XE7 and RAD Studio 2010 ??  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 19, 2014 10:07 AM
Just installed XE7 on my workstation with Studio2010 already installed. When I run XE7, it works fine as far as I can tell, but when it exits it throws an exception in RTL210.BPL (AV at 50066A9C). Once this happens I can't open RAD Studio 2010 - it displays an error box that says "Can't create c:\users\mjk\appdata\local\temp\EditorLineEnds.ttr - the file is locked by another process". The process is SYSTEM, and I can't release it without restarting the machine altogether.

On a clean machine, of course, I can run Studio 2010 with no problem if I don't run XE7 first. Anyone know of a conflict here? (Windows 7 Pro)

thanks
Remy Lebeau (Te...


Posts: 9,447
Registered: 12/23/01
Re: Cannot have simultaneous installations of XE7 and RAD Studio 2010 ??
Correct
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 19, 2014 10:40 AM   in response to: Mike Knoblock in response to: Mike Knoblock
Mike wrote:

Once this happens I can't open RAD Studio 2010 - it displays an
error box that says "Can't create
c:\users\mjk\appdata\local\temp\EditorLineEnds.ttr - the file is
locked by another process".

Solution for the EditorLineends.ttr issue
http://edn.embarcadero.com/article/44076

--
Remy Lebeau (TeamB)
Mike Knoblock

Posts: 24
Registered: 11/5/06
Re: Cannot have simultaneous installations of XE7 and RAD Studio 2010 ??  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 19, 2014 11:23 AM   in response to: Remy Lebeau (Te... in response to: Remy Lebeau (Te...
{quote:title=Remy Lebeau (TeamB) wrote:}

Solution for the EditorLineends.ttr issue
http://edn.embarcadero.com/article/44076

--
Remy Lebeau (TeamB)

Yes, sir, that works indeed. That seems to be a problem only with RS2010.

I still have XE7 throwing the AV on exit:

"Access violation at address 50066A9C in module 'RTL210.BPL'. Read of address 084529DC"

Do you have any suggestions on that one? Thanks, as always.

Mike
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02