Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: comdef.h: new.h file not found


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 2 - Last Post: Jan 12, 2015 3:15 AM Last Post By: Mike Versteeg
Mike Versteeg

Posts: 118
Registered: 9/16/07
comdef.h: new.h file not found  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 13, 2014 4:06 AM
I have a little 32 bit VCL project that uses DirectShow. When I change XE7 to build a 64 bit version, I get this error. All paths are left on their default setting. Is this a bug in XE7?
Mike Versteeg

Posts: 118
Registered: 9/16/07
Re: comdef.h: new.h file not found  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 13, 2014 7:19 AM   in response to: Mike Versteeg in response to: Mike Versteeg
Turns out the 32 bit build was using new.h from Dinkumware, which is missing in the 64 bit build. So Microsoft's new.h appears to missing entirely. Still not sure if I should find that somewhere, or if I need a (missing) Embarcadero version.
Mike Versteeg wrote:
I have a little 32 bit VCL project that uses DirectShow. When I change XE7 to build a 64 bit version, I get this error. All paths are left on their default setting. Is this a bug in XE7?
Mike Versteeg

Posts: 118
Registered: 9/16/07
Re: comdef.h: new.h file not found  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 12, 2015 3:15 AM   in response to: Mike Versteeg in response to: Mike Versteeg
Same issue now with a 64 bit build on a clean machine. Is this a bug in XE7?
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02