Watch, Follow, &
Connect with Us

Welcome, Guest
Guest Settings
Help

Thread: GAC'ed VB dot Net assembly not appearing under Registered assemblies


This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 3 - Last Post: Aug 17, 2017 3:47 PM Last Post By: Bismark Appah Threads: [ Previous | Next ]
Springer Rider

Posts: 41
Registered: 2/20/00
GAC'ed VB dot Net assembly not appearing under Registered assemblies  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Aug 27, 2014 10:33 AM
I am trying to use a VB dot NET assembly. It is Strongly Named and is successfully Cached. It appears in the C:\Windows\Microsoft.NET\assembly\GAC_MSIL cache log. But it DOES NOT appear in the Registered Assemblies list inside the Import Component tool. In fact, it would seem that Delphi is not display most of the cached assembles and is looking in the wrong directory. Using the ADD button does nothing.

Has anyone successfully GAC'ed and imported a dot net assembly?
Springer Rider

Posts: 41
Registered: 2/20/00
Re: GAC'ed VB dot Net assembly not appearing under Registered assemblies  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 2, 2014 8:35 AM   in response to: Springer Rider in response to: Springer Rider
I managed to GAC the assembly but Delphi looks in the wrong directory for it.
Springer Rider

Posts: 41
Registered: 2/20/00
Re: GAC'ed VB dot Net assembly not appearing under Registered assemblies  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 2, 2014 8:36 AM   in response to: Springer Rider in response to: Springer Rider
answered as best as it is going to be
Bismark Appah

Posts: 14
Registered: 3/13/15
Re: GAC'ed VB dot Net assembly not appearing under Registered assemblies  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Aug 17, 2017 3:47 PM   in response to: Springer Rider in response to: Springer Rider
Springer Rider wrote:
I am trying to use a VB dot NET assembly. It is Strongly Named and is successfully Cached. It appears in the C:\Windows\Microsoft.NET\assembly\GAC_MSIL cache log. But it DOES NOT appear in the Registered Assemblies list inside the Import Component tool. In fact, it would seem that Delphi is not display most of the cached assembles and is looking in the wrong directory. Using the ADD button does nothing.

Has anyone successfully GAC'ed and imported a dot net assembly?

Hi Springer,

You can use the .Net Assembly/WSDL Import tool which is part of the .Net Runtime Library for Delphi to import the .Net library from file or GAC and generate delphi codes from the imported assembly types.

For more information, go to https://crystalnet-tech.com/RuntimeLibrary/RuntimeLibUtilities.aspx

For more information about the .Net Runtime Library for Delphi, go to https://crystalnet-tech.com/RuntimeLibrary/RuntimeLibrary4Delphi.aspx
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02