Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Error while compiling to Android with MyDac components.



Permlink Replies: 4 - Last Post: Oct 1, 2014 4:20 PM Last Post By: Stev Warby
Stev Warby

Posts: 50
Registered: 10/19/14
Error while compiling to Android with MyDac components.
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 1, 2014 4:41 AM
Hi,

I am using depart MyDac TMyConnection & TMyQuery components.

The app compiles on IOS , Win32 , Win 64 & OS10.

I still get the following error when compiling to android device.

[PAClient Error] Error: E2312 Unable to execute '"C:\Users\Public\Documents\Embarcadero\Studio\15.0\PlatformSDKs\adt-bundle-windows-x86-20131030\sdk\build-tools\android-4.4\Aapt.exe" package -f -M "C:\Users\stevew\Documents\Embarcadero\Studio\Projects\BMWRaceDays\MasterDetail\Android\Debug\MasterDetailApplication\AndroidManifest.xml" -F "C:\Users\stevew\Documents\Embarcadero\Studio\Projects\BMWRaceDays\MasterDetail\Android\Debug\MasterDetailApplication\bin\MasterDetailApplication-unsigned.apk" -I "C:\Users\Public\Documents\Embarcadero\Studio\15.0\PlatformSDKs\adt-bundle-windows-x86-20131030\sdk\platforms\android-19\android.jar" -S "C:\Users\stevew\Documents\Embarcadero\Studio\Projects\BMWRaceDays\MasterDetail\Android\Debug\MasterDetailApplication\res" -A "C:\Users\stevew\Documents\Embarcadero\Studio\Projects\BMWRaceDays\MasterDetail\Android\Debug\MasterDetailApplication\assets" "C:\Users\stevew\Documents\Embarcadero\Studio\Projects\BMWRaceDays\MasterDetail\Android\Debug\MasterDetailApplication\library" "C:\Users\stevew\Documents\Embarcadero\Studio\Projects\BMWRaceDays\MasterDetail\Android\Debug\MasterDetailApplication\classes"' (Error 1)
[PAClient Error] Error: E2312 C:\Users\stevew\Documents\Embarcadero\Studio\Projects\BMWRaceDays\MasterDetail\Android\Debug\MasterDetailApplication\res\drawable\splash_image_def.xml:2: error: Error: No resource found that matches the given name (at 'src' with value '@drawable/splash_image').

Is this error related to MyDac?

I can compile other apps to android that do not contain the MyDac components.

Cheers

Mr Warby

Eli M

Posts: 1,346
Registered: 11/9/13
Re: Error while compiling to Android with MyDac components.
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 1, 2014 10:02 AM   in response to: Stev Warby in response to: Stev Warby
Is this project from an older version?

XE7 added an Android splash screen but maybe an older project doesn't have it.

Go to Project Options|Application to configure the splash screen (either added images or disable it).
Markus Humm

Posts: 5,113
Registered: 11/9/03
Re: Error while compiling to Android with MyDac components.
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 1, 2014 12:17 PM   in response to: Stev Warby in response to: Stev Warby
Hello,

if you read the error message carefully you'll notice that it mentiones
a splash screen image it is missing.

Splash screens are indeed new to XE7. it might help if you open the
deployment manager in the IDE and look for any items defined there but
not really present on yopur HDD at that location.

Greetings

Markus
Stev Warby

Posts: 50
Registered: 10/19/14
Re: Error while compiling to Android with MyDac components.
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 1, 2014 2:32 PM   in response to: Markus Humm in response to: Markus Humm
Markus Humm wrote:
Hello,

if you read the error message carefully you'll notice that it mentiones
a splash screen image it is missing.

Splash screens are indeed new to XE7. it might help if you open the
deployment manager in the IDE and look for any items defined there but
not really present on yopur HDD at that location.

Greetings

Markus

Okay thanks for the info,

I have unchecked use splash screen.

I am now getting error :

[DCC Fatal Error] F1026 File not found: 'ldandroid.exe'

Cheers

Mr Warby.

Stev Warby

Posts: 50
Registered: 10/19/14
Re: Error while compiling to Android with MyDac components.
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 1, 2014 4:20 PM   in response to: Stev Warby in response to: Stev Warby
I restarted the IDE and the Android SDK's were missing from the IDE.

I added them again and now it is working.

I am on Yosemite so this could be the issue.

Cheers

Mr Warby
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02