Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: PEGRCPS.DLL missing???


This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 3 - Last Post: Sep 19, 2014 5:18 PM Last Post By: Philip Caracena
Philip Caracena

Posts: 8
Registered: 6/7/11
PEGRCPS.DLL missing???  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 18, 2014 9:30 PM
Not sure where this question belongs so I'll start here. I wrote an application many years ago using Delphi 2 that runs very well on XP, Vista, Windows 7, and Windows 8.1 (64-bit). There are no incompatibilities (or I've successfully circumvented them). I recently made a very few and very minor modifications in that program and re-compiled it as a new application using D2 on the same XP computer that I used for the original app. The plan was to start small, testing as I go, and get to the bigger modifications later. However, the new, barely-changed program will run only on XP. The error message I get trying to run it on my other computers is that "PEGRCPS.DLL" is missing. I never heard of that DLL, Google doesn't find it, and a search of my XP computer says it's not found even on that computer. I haven't changed any of the compiler settings (as far as I know), I've not added any new functions or components, the source paths seem intact, and I get no compiler errors. The first time I ran the new modified program on 64-bit Windows 8.1, it opened and ran fine but the 2nd time I tried to run it I got that error message and I continue to get it. On Vista (32 bit), the PEGRCPS.DLL error message comes up immediately. I'm very puzzled. The only thing I may have changed in the D2 compiler was during my attempt to put the original program into the Repository so I could make it the default for my new application - but I failed miserably to do that and decided to just modify the original code, saving a copy of the original code elsewhere. My Repository failure was due to my inexperience and D2's incomplete online help so it's possible that I changed something inadvertently during my trials, although the build was successful and XP runs it fine. I'd like the new modified program to run on all the above platforms. If the old D2 program can run anywhere, this one should be able to also. Any ideas what that DLL error is all about, why it didn't appear at first in W8, or how I can troubleshoot it or avoid it? Anticipating advice to rewrite this using my XE2, I'd love to but it's far, far beyond me to be able do so. Borland and TurboPower enticed a bunch of amateurs into the fray back in the D1 days and some of us are still around, as uninformed as ever.
Michael Thuma

Posts: 104
Registered: 1/30/00
Re: PEGRCPS.DLL missing???  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 18, 2014 11:54 PM   in response to: Philip Caracena in response to: Philip Caracena
Gigasoft Charting?
http://www.gigasoft.com/netchart/peonlref/chapter1_customer_support.htm

Philip Caracena wrote:
Not sure where this question belongs so I'll start here. I wrote an application many years ago using Delphi 2 that runs very well on XP, Vista, Windows 7, and Windows 8.1 (64-bit). There are no incompatibilities (or I've successfully circumvented them). I recently made a very few and very minor modifications in that program and re-compiled it as a new application using D2 on the same XP computer that I used for the original app. The plan was to start small, testing as I go, and get to the bigger modifications later. However, the new, barely-changed program will run only on XP. The error message I get trying to run it on my other computers is that "PEGRCPS.DLL" is missing. I never heard of that DLL, Google doesn't find it, and a search of my XP computer says it's not found even on that computer. I haven't changed any of the compiler settings (as far as I know), I've not added any new functions or components, the source paths seem intact, and I get no compiler errors. The first time I ran the new modified program on 64-bit Windows 8.1, it opened and ran fine but the 2nd time I tried to run it I got that error message and I continue to get it. On Vista (32 bit), the PEGRCPS.DLL error message comes up immediately. I'm very puzzled. The only thing I may have changed in the D2 compiler was during my attempt to put the original program into the Repository so I could make it the default for my new application - but I failed miserably to do that and decided to just modify the original code, saving a copy of the original code elsewhere. My Repository failure was due to my inexperience and D2's incomplete online help so it's possible that I changed something inadvertently during my trials, although the build was successful and XP runs it fine. I'd like the new modified program to run on all the above platforms. If the old D2 program can run anywhere, this one should be able to also. Any ideas what that DLL error is all about, why it didn't appear at first in W8, or how I can troubleshoot it or avoid it? Anticipating advice to rewrite this using my XE2, I'd love to but it's far, far beyond me to be able do so. Borland and TurboPower enticed a bunch of amateurs into the fray back in the D1 days and some of us are still around, as uninformed as ever.

--
Delphi Programming is fun. Hilarious.
Philip Caracena

Posts: 8
Registered: 6/7/11
Re: PEGRCPS.DLL missing???  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 19, 2014 10:48 AM   in response to: Michael Thuma in response to: Michael Thuma

Hmm. Thanks for that great clue! Gigasoft Charting is, indeed, installed on the XP machine and I see your link says it uses that DLL. I don't need charts in the new app so I'll try deleting references to it and see what happens. It would seem that running my old app would also have demanded that DLL - but I won't require a potential fix to also make sense. Will report back.

Philip Caracena wrote:
Not sure where this question belongs so I'll start here. I wrote an application many years ago using Delphi 2 that runs very well on XP, Vista, Windows 7, and Windows 8.1 (64-bit). There are no incompatibilities (or I've successfully circumvented them). I recently made a very few and very minor modifications in that program and re-compiled it as a new application using D2 on the same XP computer that I used for the original app. The plan was to start small, testing as I go, and get to the bigger modifications later. However, the new, barely-changed program will run only on XP. The error message I get trying to run it on my other computers is that "PEGRCPS.DLL" is missing. I never heard of that DLL, Google doesn't find it, and a search of my XP computer says it's not found even on that computer. I haven't changed any of the compiler settings (as far as I know), I've not added any new functions or components, the source paths seem intact, and I get no compiler errors. The first time I ran the new modified program on 64-bit Windows 8.1, it opened and ran fine but the 2nd time I tried to run it I got that error message and I continue to get it. On Vista (32 bit), the PEGRCPS.DLL error message comes up immediately. I'm very puzzled. The only thing I may have changed in the D2 compiler was during my attempt to put the original program into the Repository so I could make it the default for my new application - but I failed miserably to do that and decided to just modify the original code, saving a copy of the original code elsewhere. My Repository failure was due to my inexperience and D2's incomplete online help so it's possible that I changed something inadvertently during my trials, although the build was successful and XP runs it fine. I'd like the new modified program to run on all the above platforms. If the old D2 program can run anywhere, this one should be able to also. Any ideas what that DLL error is all about, why it didn't appear at first in W8, or how I can troubleshoot it or avoid it? Anticipating advice to rewrite this using my XE2, I'd love to but it's far, far beyond me to be able do so. Borland and TurboPower enticed a bunch of amateurs into the fray back in the D1 days and some of us are still around, as uninformed as ever.

--
Delphi Programming is fun. Hilarious.
Philip Caracena

Posts: 8
Registered: 6/7/11
Re: PEGRCPS.DLL missing???  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Sep 19, 2014 5:18 PM   in response to: Michael Thuma in response to: Michael Thuma
Your clue solved the problem. The DLL was used by an old ProEssentials component I had forgotten about and I can only assume the reason Search didn't find it on the XP computer was that I had misspelled "PEGRCPS". Copying the DLL to the other computers enabled the program to run with no problem. Everything should be so simple. Many thanks!

Michael Thuma wrote:
Gigasoft Charting?
http://www.gigasoft.com/netchart/peonlref/chapter1_customer_support.htm

Philip Caracena wrote:
Not sure where this question belongs so I'll start here. I wrote an application many years ago using Delphi 2 that runs very well on XP, Vista, Windows 7, and Windows 8.1 (64-bit). There are no incompatibilities (or I've successfully circumvented them). I recently made a very few and very minor modifications in that program and re-compiled it as a new application using D2 on the same XP computer that I used for the original app. The plan was to start small, testing as I go, and get to the bigger modifications later. However, the new, barely-changed program will run only on XP. The error message I get trying to run it on my other computers is that "PEGRCPS.DLL" is missing. I never heard of that DLL, Google doesn't find it, and a search of my XP computer says it's not found even on that computer. I haven't changed any of the compiler settings (as far as I know), I've not added any new functions or components, the source paths seem intact, and I get no compiler errors. The first time I ran the new modified program on 64-bit Windows 8.1, it opened and ran fine but the 2nd time I tried to run it I got that error message and I continue to get it. On Vista (32 bit), the PEGRCPS.DLL error message comes up immediately. I'm very puzzled. The only thing I may have changed in the D2 compiler was during my attempt to put the original program into the Repository so I could make it the default for my new application - but I failed miserably to do that and decided to just modify the original code, saving a copy of the original code elsewhere. My Repository failure was due to my inexperience and D2's incomplete online help so it's possible that I changed something inadvertently during my trials, although the build was successful and XP runs it fine. I'd like the new modified program to run on all the above platforms. If the old D2 program can run anywhere, this one should be able to also. Any ideas what that DLL error is all about, why it didn't appear at first in W8, or how I can troubleshoot it or avoid it? Anticipating advice to rewrite this using my XE2, I'd love to but it's far, far beyond me to be able do so. Borland and TurboPower enticed a bunch of amateurs into the fray back in the D1 days and some of us are still around, as uninformed as ever.

--
Delphi Programming is fun. Hilarious.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02