Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: FireDAC Azure IMAGE Field Post Problem



Permlink Replies: 3 - Last Post: Jul 6, 2014 9:53 PM Last Post By: Dmitry Arefiev
Andrew Hill

Posts: 7
Registered: 2/10/04
FireDAC Azure IMAGE Field Post Problem
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jul 3, 2014 1:40 PM
I have a Delphi XE6 Azure application using a bound DevExpress cxGrid. I cannot save large images to the IMAGE field.

DevExpress have finally responded acknowledging the problem with this comment:-

"the problem occurs when you post this value to your DataSet. I believe that this is specific or limitation of Azure or FireDAC components"

Please show me how to save large images (it works perfectly with 30k images, fails with 2meg images) with FireDAC / Azure - Thanks in advance.
Dmitry Arefiev

Posts: 1,406
Registered: 12/7/03
Re: FireDAC Azure IMAGE Field Post Problem
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jul 4, 2014 7:49 PM   in response to: Andrew Hill in response to: Andrew Hill
Please show me how to save large images (it works perfectly with 30k images, fails with 2meg images) with FireDAC / Azure - Thanks in advance.

There is nothing special. Application code developed for FireDAC / SQL Server should work with FireDAC / Azure.

Please provide environment report:
http://docwiki.embarcadero.com/RADStudio/XE6/en/DBMS_Environment_Reports_(FireDAC)

Also what means "cannot save" ? Any error message or misbehaviour ?

--
With best regards,
Dmitry Arefiev / FireDAC Architect
Andrew Hill

Posts: 7
Registered: 2/10/04
Re: FireDAC Azure IMAGE Field Post Problem
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jul 5, 2014 2:32 PM   in response to: Dmitry Arefiev in response to: Dmitry Arefiev
see www.axfite.com.au/test.zip screen video

Edited by: Andrew Hill on Jul 5, 2014 2:34 PM
Dmitry Arefiev

Posts: 1,406
Registered: 12/7/03
Re: FireDAC Azure IMAGE Field Post Problem
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jul 6, 2014 9:53 PM   in response to: Dmitry Arefiev in response to: Dmitry Arefiev

Please ... :)

But from the error message I see that you have old SQL Server ODBC driver. To successfully
work with SQL Azure you should install SQL Server Native Client. More info:
http://docwiki.embarcadero.com/RADStudio/XE6/en/Connect_to_Microsoft_SQL_Server_(FireDAC)

--
With best regards,
Dmitry Arefiev / FireDAC Architect
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02