Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: error "NONE" is not a valid BCD value


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 1 - Last Post: Jun 2, 2014 3:15 PM Last Post By: Dmitry Arefiev
Mary Couette

Posts: 5
Registered: 11/26/09
error "NONE" is not a valid BCD value  
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 28, 2014 2:21 PM
I am setting the MasterFields on a tadtable to a field that is a varchar2(30). One of the values happens to be "NONE" in the mastersource. avltbl->MasterFields = "COL30_1;COL30_2;COL30_9"; // fails on COL30_1

I also receive the same error on setting the IndexFieldNames = "COL30_1" I solved this issue by using the col120_5 which has the three columns concatenated.

None of the fields listed here are numeric.

Thank you,
Mary
Dmitry Arefiev

Posts: 1,406
Registered: 12/7/03
Re: error "NONE" is not a valid BCD value  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jun 2, 2014 3:15 PM   in response to: Mary Couette in response to: Mary Couette
Try to prepare a simple test application, reproducing your issue. And post it to attachments newsgroup. So, I can check it.
Looks like, that some of the detail fields is TBCDField or TFMTBcdField.

--
With best regards,
Dmitry Arefiev / FireDAC Architect
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02