Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: THttpRio https (Wininet) connection problem with no error message


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 8 - Last Post: Feb 5, 2015 11:40 AM Last Post By: Guest
Matevz Lipanje

Posts: 2
Registered: 2/3/11
THttpRio https (Wininet) connection problem with no error message  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 25, 2011 6:21 AM
Hi,

When I invoke a web service I get this exception (Delphi 2007):

ESOAPHTTPEXCEPTION: - URL:https://my.address.com/ws - SOAPAction:"". (the error msg that usually appears before '-' seems to be missing)

On another machine with the same software installed it works fine. (windows xp, internet explorer 8). Wininet.dll seems to be the same version on both machines also.
The connection is not blocked by port as I tried with SOAPUI (java) and got the response from a web service.

Any idea where could be the problem?

Thanks a lot,

Regards,
LM
Jean-Marie Babet

Posts: 460
Registered: 8/17/02
Re: THttpRio https (Wininet) connection problem with no error message  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 29, 2011 11:53 AM   in response to: Matevz Lipanje in response to: Matevz Lipanje
Hello,


When I invoke a web service I get this exception (Delphi 2007):

ESOAPHTTPEXCEPTION: - URL:https://my.address.com/ws - SOAPAction:"".
(the error msg that usually appears before '-' seems to be missing)

On another machine with the same software installed it works fine.
(windows xp, internet explorer 8). Wininet.dll seems to be the same
version on both machines also.
The connection is not blocked by port as I tried with SOAPUI (java) and
got the response from a web service.

Any idea where could be the problem?

It would be very useful to know the WinInet error code. Can you either add a
copy of SOAPHTTPTrans.pas to your project and catch the exception and look
at ESOAPHTTPException.FStatusCode. Or handle the OnWinInetError event
(http://docwiki.embarcadero.com/VCL/XE2/en/SOAPHTTPTrans.THTTPReqResp.OnWinInetError).
I think that event was present in 2007 but I'm not sure.

Cheers,

Bruneau
Matevz Lipanje

Posts: 2
Registered: 2/3/11
Re: THttpRio https (Wininet) connection problem with no error message  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Nov 30, 2011 1:38 AM   in response to: Jean-Marie Babet in response to: Jean-Marie Babet
Hi,

The problem is that it doesn't work on the server where it is impossible to debug.

Is it possible that it has something to do with a security restriciton, maybe proxy..? Besides wininet.dll is there something else that it is necessary for running WS in delphi?
I can't find any difference between the server that does and the server that does not work.

Thanks Bruneau!
Lp
M
Jean-Marie Babet

Posts: 460
Registered: 8/17/02
Re: THttpRio https (Wininet) connection problem with no error message  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Dec 2, 2011 11:51 AM   in response to: Matevz Lipanje in response to: Matevz Lipanje
Hello,


The problem is that it doesn't work on the server where it is impossible
to debug.

Is it possible that it has something to do with a security restriciton,
maybe proxy..? Besides wininet.dll is there something else that it is
necessary for running WS in delphi?
I can't find any difference between the server that does and the server
that does not work.

Could it be that the machine where it fails has a proxy setting? The SOAP
runtimes uses default WinInet so that any LAN settings configured in IE
would affect a SOAP client. This happens here often: folks setup a proxy to
use AppWave and the latter our Bug Tracking Client, known as RAID, stops
working: it uses Delphi SOAP components to communicate with the Server.

I would recommend launching IE on the machine that works and the on that
does not; and compare the LAN/proxy settings.

Cheers,

Bruneau
Adolfo de Bonis...

Posts: 2
Registered: 3/23/08
Re: THttpRio https (Wininet) connection problem with no error message  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 30, 2012 10:48 PM   in response to: Matevz Lipanje in response to: Matevz Lipanje
Matevz Lipanje wrote:
Hi,

When I invoke a web service I get this exception (Delphi 2007):

ESOAPHTTPEXCEPTION: - URL:https://my.address.com/ws - SOAPAction:"". (the error msg that usually appears before '-' seems to be missing)

On another machine with the same software installed it works fine. (windows xp, internet explorer 8). Wininet.dll seems to be the same version on both machines also.
The connection is not blocked by port as I tried with SOAPUI (java) and got the response from a web service.

Any idea where could be the problem?

Thanks a lot,

Regards,
LM

Hey.

I have exactly the same problem with yours. By consuming a webservice with ssl error appears in Windows 7 but Windows XP works perfectly.

Could you fix it?

If so, What was the solution?

Thanks and raludos

Adolfo Bonis

Warren Postma

Posts: 1
Registered: 9/15/11
Re: THttpRio https (Wininet) connection problem with no error message  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 2, 2012 4:24 PM   in response to: Adolfo de Bonis... in response to: Adolfo de Bonis...
It could be a WinInet bug. Can you try switching your SOAP layer to use INDY?

Warren
Adolfo de Bonis...

Posts: 2
Registered: 3/23/08
Re: THttpRio https (Wininet) connection problem with no error message  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Apr 3, 2012 10:07 AM   in response to: Warren Postma in response to: Warren Postma
Warren Postma wrote:
It could be a WinInet bug. Can you try switching your SOAP layer to use INDY?

Warren

Hey.

I suppose so, but should start from 0 since I've never used the Indy ...

Adolfo Bonis

Murilo Junqueira

Posts: 2
Registered: 1/22/11
Re: THttpRio https (Wininet) connection problem with no error message  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jul 15, 2014 9:28 AM   in response to: Matevz Lipanje in response to: Matevz Lipanje
Matevz Lipanje wrote:
Hi,

When I invoke a web service I get this exception (Delphi 2007):

ESOAPHTTPEXCEPTION: - URL:https://my.address.com/ws - SOAPAction:"". (the error msg that usually appears before '-' seems to be missing)

On another machine with the same software installed it works fine. (windows xp, internet explorer 8). Wininet.dll seems to be the same version on both machines also.
The connection is not blocked by port as I tried with SOAPUI (java) and got the response from a web service.

Any idea where could be the problem?

Thanks a lot,

Regards,
LM

in my case I had IE 8 installed, upgraded to 11 and it worked ...
Guest
Re: THttpRio https (Wininet) connection problem with no error message
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 5, 2015 11:40 AM   in response to: Murilo Junqueira in response to: Murilo Junqueira
Hi,

I am using xe7 win8.1 and I have the same problem.

Does someone solved this problem?

Regards,

Luiz

Murilo Junqueira wrote:
Matevz Lipanje wrote:
Hi,

When I invoke a web service I get this exception (Delphi 2007):

ESOAPHTTPEXCEPTION: - URL:https://my.address.com/ws - SOAPAction:"". (the error msg that usually appears before '-' seems to be missing)

On another machine with the same software installed it works fine. (windows xp, internet explorer 8). Wininet.dll seems to be the same version on both machines also.
The connection is not blocked by port as I tried with SOAPUI (java) and got the response from a web service.

Any idea where could be the problem?

Thanks a lot,

Regards,
LM

in my case I had IE 8 installed, upgraded to 11 and it worked ...
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02