Watch, Follow, &
Connect with Us

Please visit our new home
community.embarcadero.com.


Welcome, Guest
Guest Settings
Help

Thread: What Delphi versions the latest FireDac supports?



Permlink Replies: 5 - Last Post: Jan 9, 2015 8:14 AM Last Post By: quinn wildman
Sanjay Kanade

Posts: 16
Registered: 10/26/98
What Delphi versions the latest FireDac supports?
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 7, 2015 9:44 PM
I'm using Delphi XE4. If I buy the latest FireDac, will it support that Delphi version? There is no mention of that in the sales docs. Please add such information.
Dmitry Arefiev

Posts: 1,390
Registered: 12/7/03
Re: What Delphi versions the latest FireDac supports?
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 8, 2015 6:41 AM   in response to: Sanjay Kanade in response to: Sanjay Kanade
I'm using Delphi XE4. If I buy the latest FireDac, will it support that Delphi version? There is no mention of that in the sales docs. Please add such information.

I believe - no. Latest FireDAC version supports only latest RAD Studio version.

--
With best regards,
Dmitry Arefiev / FireDAC Architect
Sanjay Kanade

Posts: 16
Registered: 10/26/98
Re: What Delphi versions the latest FireDac supports?
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 8, 2015 6:50 AM   in response to: Dmitry Arefiev in response to: Dmitry Arefiev
But when it was AnyDac, it always continued supporting old versions so one could buy at any point and use it. This means that if I missed buying FireDAC earlier with Delphi XE4, I have to spend extra money to upgrade to the latest Delphi just for that even when I don't need the newer Delphi? Isn't it a faulty policy? All other Delphi third party components continue supporting old Delphi versions.

Another question: Can I at least buy the old FireDAC version that supports Delphi XE4?

Thanks,
Sanjay
Ronell Recio

Posts: 15
Registered: 7/12/07
Re: What Delphi versions the latest FireDac supports?
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 9, 2015 4:13 AM   in response to: Sanjay Kanade in response to: Sanjay Kanade
Sanjay Kanade wrote:
But when it was AnyDac, it always continued supporting old versions so one could buy at any point and use it. This means that if I missed buying FireDAC earlier with Delphi XE4, I have to spend extra money to upgrade to the latest Delphi just for that even when I don't need the newer Delphi? Isn't it a faulty policy? All other Delphi third party components continue supporting old Delphi versions.

Another question: Can I at least buy the old FireDAC version that supports Delphi XE4?

Thanks,
Sanjay

Hi.

Since AnyDAC was acquired by Embarcadero, the policy is: "If you want the latest version FireDAC (AnyDAC), you need to buy the newest Delphi".

At first when they bought AnyDAC, they said they would support the older versions of Delphi. They delivered the version 8 of FireDac (AnyDac) that support Delphi until XE4 or XE5. After that FireDac became part of Delphi/RAD Studio, leaving all the promise behind about supporting older versions of Delphi.

So, the only way of getting the latest version FireDac (with all the new features and bug fixes) is buying the new Delphi every time Embarcadero make a new release.

As you may know there's a bunch of devs in the same situation of you.
Sanjay Kanade

Posts: 16
Registered: 10/26/98
Re: What Delphi versions the latest FireDac supports?
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 9, 2015 4:39 AM   in response to: Ronell Recio in response to: Ronell Recio
Thanks for your thoughts. Overall, I'm not very happy with the current upgrade policies of Emb. Earlier, in Borland and Codegear days, new upgrade releases were at least an year apart, there were updates of previous version in parallel with the latest, and the cost of upgrade was much lower. Now, they bring out new releases every 6 months that would have been termed "updates" in the old policy. As a result, if you want to keep current, you have to pay expensive upgrade fees every 6 months. Moreover, the policy like the one that we are discussing doesn't let you buy addons for the Delphi version that you bought recently. This includes not only FireDac but stuff like IOS/Android development. Delphi is no longer affordable for small developers, especially when it comes to keeping current with the latest features.

On the other hand, Microsoft has changed a lot from a small developer point of view. Their Action Pack Development & Design includes the latest Visual Studio and several copies of Windows and Office at a very reasonable "yearly" price. The best thing is, since you can keep current with the latest features easily, you don't feel "left out" as is the case here.
quinn wildman

Posts: 849
Registered: 12/2/99
Re: What Delphi versions the latest FireDac supports?
Click to report abuse...   Click to reply to this thread Reply
  Posted: Jan 9, 2015 8:14 AM   in response to: Sanjay Kanade in response to: Sanjay Kanade
Sanjay Kanade wrote:
Another question: Can I at least buy the old FireDAC version that supports Delphi XE4?

Yes, you can still purchase FireDAC for XE4. It will be based on the
FireDAC code base at that time. It is only available by contacting sales
directly. In the US, call (888)233-2224, then select menu choice 1 to
contact sales. For other places, go to www.embarcadero.com, then select
Company | Contact, then select your region.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02