Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Compiler error Indy 10.6.2.0 (revision: 5447)



Permlink Replies: 1 - Last Post: Feb 16, 2018 12:40 PM Last Post By: Remy Lebeau (Te...
Hafedh TRIMECHE

Posts: 107
Registered: 12/29/06
Compiler error Indy 10.6.2.0 (revision: 5447)
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 16, 2018 8:58 AM
[dcc32 Error] IdSSLOpenSSLHeaders.pas(26017): E2267 Previous declaration of 'EVP_OpenUpdate' was not marked with the 'overload' directive
[dcc32 Error] IdSSLOpenSSLHeaders.pas(26020): E2010 Incompatible types: 'PIdC_INT' and 'Integer'
[dcc32 Error] IdSSLOpenSSLHeaders.pas(18644): E2065 Unsatisfied forward or external declaration: 'EVP_OpenUpdate'
[dcc32 Fatal Error] F2063 Could not compile used unit 'IdSSLOpenSSLHeaders.pas'
Remy Lebeau (Te...


Posts: 9,447
Registered: 12/23/01
Re: Compiler error Indy 10.6.2.0 (revision: 5447)
Click to report abuse...   Click to reply to this thread Reply
  Posted: Feb 16, 2018 12:40 PM   in response to: Hafedh TRIMECHE in response to: Hafedh TRIMECHE
Hafedh TRIMECHE wrote:

[dcc32 Error] IdSSLOpenSSLHeaders.pas(26017): E2267 Previous
declaration of 'EVP_OpenUpdate' was not marked with the 'overload'
directive

[dcc32 Error] IdSSLOpenSSLHeaders.pas(26020): E2010 Incompatible
types: 'PIdC_INT' and 'Integer'

[dcc32 Error] IdSSLOpenSSLHeaders.pas(18644): E2065 Unsatisfied
forward or external declaration: 'EVP_OpenUpdate'

[dcc32 Fatal Error] F2063 Could not compile used unit
'IdSSLOpenSSLHeaders.pas'

Fixed.

--
Remy Lebeau (TeamB)
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02