Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Controls go missing on some PCs



Permlink Replies: 4 - Last Post: Oct 13, 2017 7:00 PM Last Post By: Igor Savkic
Yogi Yang

Posts: 57
Registered: 12/23/06
Controls go missing on some PCs
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 9, 2017 11:31 PM
Hello,

In a software I am developing the view comes ups like this; [https://image.ibb.co/jkOsgG/2017_10_10_115339.jpg]

While what is coming up on the Users PC who is testing the master piece is: [https://image.ibb.co/bXjMab/margin001.jpg]

Some controls are missing. Why must this be happening?

Any ideas?

I am using Berlin 10.1.

TIA

Yogi Yang
Olivier Sannier

Posts: 424
Registered: 8/26/01
Re: Controls go missing on some PCs
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 10, 2017 6:32 AM   in response to: Yogi Yang in response to: Yogi Yang
Yogi Yang wrote:
Hello,

In a software I am developing the view comes ups like this; [https://image.ibb.co/jkOsgG/2017_10_10_115339.jpg]

While what is coming up on the Users PC who is testing the master piece is: [https://image.ibb.co/bXjMab/margin001.jpg]

Some controls are missing. Why must this be happening?

Any ideas?

Alignment issues comes to mind, look for Align and Anchor properties,
maybe related to different DPI settings
Yogi Yang

Posts: 57
Registered: 12/23/06
Re: Controls go missing on some PCs
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 10, 2017 6:46 AM   in response to: Olivier Sannier in response to: Olivier Sannier
Olivier Sannier wrote:

Alignment issues comes to mind, look for Align and Anchor properties,
maybe related to different DPI settings

Checked that out already. The Alignment (alNone) and Anchor (akTop and akLeft) properties are proper.

Again this problem is coming on the client's PC. I tested it on two separate PCs and everything comes as expected.
Roy Lambert

Posts: 1,063
Registered: 8/7/01
Re: Controls go missing on some PCs
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 10, 2017 8:03 AM   in response to: Yogi Yang in response to: Yogi Yang
Yogi

I can't get to the images to see what's missing (my browser reports an invalid certificate) so its a wild guess - different versions of Windows with somthing missing from the client machine. I can remember this happening way back (like D4 or thereabouts)

Roy Lambert

Igor Savkic

Posts: 27
Registered: 8/26/01
Re: Controls go missing on some PCs
Click to report abuse...   Click to reply to this thread Reply
  Posted: Oct 13, 2017 7:00 PM   in response to: Yogi Yang in response to: Yogi Yang
In a software I am developing the view comes ups like this;
While what is coming up on the Users PC who is testing the master piece is:
Some controls are missing. Why must this be happening?

Any ideas?

Check if user computer displayed is scalled to value different then yours.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02