Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: Just installed 10.2 Delphi Professional today and its a no-go


This question is not answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 3 - Last Post: May 22, 2017 7:05 AM Last Post By: Sarina DuPont
Frank Yingst

Posts: 175
Registered: 1/19/05
Just installed 10.2 Delphi Professional today and its a no-go  
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 19, 2017 12:58 PM
Every time I start it, it requests registration info.
Every time I start it, it gets an access violation.
Then after it opens, it gets a new error: Cannot change Visible in OnShow or OnHide,
and this is before I even open an project.
Then after that it says

Error

Access violation at address 5005F8A8 in module 'rtl250.bpl'. Read of address FFFFFFFC.

OK Details >>
And then the File menu and the rest of the menu is MISSING! Cannot use the product at all because once I open a project it says Embarcadero RAD Studio for Windows has stopped working. And by the way, I don't have RAD Studio anyway, I just have Delphi.

Are there fixes for this?

I never had any problems with the Beta version.
Jeff Overcash (...

Posts: 1,529
Registered: 9/23/99
Re: Just installed 10.2 Delphi Professional today and its a no-go [Edit]  
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 19, 2017 1:04 PM   in response to: Frank Yingst in response to: Frank Yingst
Frank Yingst wrote:
Every time I start it, it requests registration info.
Every time I start it, it gets an access violation.
Then after it opens, it gets a new error: Cannot change Visible in OnShow or OnHide,
and this is before I even open an project.
Then after that it says

Error

Access violation at address 5005F8A8 in module 'rtl250.bpl'. Read of address FFFFFFFC.

OK Details >>
And then the File menu and the rest of the menu is MISSING! Cannot use the product at all because once I open a project it says Embarcadero RAD Studio for Windows has stopped working. And by the way, I don't have RAD Studio anyway, I just have Delphi.

Are there fixes for this?

I never had any problems with the Beta version.

RAD Studio is the overall IDE, Delphi is a personality within the IDE.

Try installing from the iso if you are having issues with the web installer.

--
Jeff Overcash (TeamB)
(Please do not email me directly unless asked. Thank You)
Learning is finding out what you already know. Doing is demonstrating that you
know it. Teaching is reminding others that they know it as well as you. We are
all leaners, doers, teachers. (R Bach)
Frank Yingst

Posts: 175
Registered: 1/19/05
Re: Just installed 10.2 Delphi Professional today and its a no-go [Edit]  
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 19, 2017 3:09 PM   in response to: Jeff Overcash (... in response to: Jeff Overcash (...
After doing all that (took about 3 hours) the product still won't work. If I attempt to create an application it just says "No platform available for current project". If I open an existing project the compile fails with "Compiler for personality "Delphi.Personality" and platform "Win32" missing or unavailable I think the installer program needs to be outsourced to another company and done over, or am I the only one with this problem? Why did the installer for the Beta version work and this one doesn't?
Sarina DuPont

Posts: 42
Registered: 7/6/11
Re: Just installed 10.2 Delphi Professional today and its a no-go [Edit]  
Click to report abuse...   Click to reply to this thread Reply
  Posted: May 22, 2017 7:05 AM   in response to: Frank Yingst in response to: Frank Yingst
Frank Yingst wrote:
After doing all that (took about 3 hours) the product still won't work. If I attempt to create an application it just says "No platform available for current project". If I open an existing project the compile fails with "Compiler for personality "Delphi.Personality" and platform "Win32" missing or unavailable I think the installer program needs to be outsourced to another company and done over, or am I the only one with this problem? Why did the installer for the Beta version work and this one doesn't?

Hi Frank,

If you previously had a beta build installed, you should delete any beta (Field Test) license that you can find. You can find manual uninstall instructions here:

https://community.embarcadero.com/article/articles-support/174-rad-studio/installation-registration/16501-manual-uninstall-of-rad-studio-delphi-c-builder-10-2

Regards,
Sarina

--
Product Manager, RAD Studio
Embarcadero Technologies, Inc.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02