Watch, Follow, &
Connect with Us

For forums, blogs and more please visit our
Developer Tools Community.


Welcome, Guest
Guest Settings
Help

Thread: RAD 10.2 Tokyo - BDE Installer


This question is answered. Helpful answers available: 2. Correct answers available: 1.


Permlink Replies: 3 - Last Post: Apr 1, 2017 5:54 AM Last Post By: Goran Ekstrom
Goran Ekstrom

Posts: 149
Registered: 1/10/04
RAD 10.2 Tokyo - BDE Installer  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 22, 2017 1:28 PM
The BDE installer claiming to be for 10.2 Tokyo wants to uninstall when I execute it. I guess it is the BDE installer for 10.1 Berlin it wants to uninstall. Shouldn't these BDE installers be RAD version specific?

Regards
Goran
Clayton Arends


Posts: 25
Registered: 7/19/01
Re: RAD 10.2 Tokyo - BDE Installer  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 23, 2017 10:43 AM   in response to: Goran Ekstrom in response to: Goran Ekstrom
I encountered the same problem with the install. It wants to uninstall the existing RAD Studio 10.1 BDE.

I allowed the new setup to uninstall the existing BDE. While it was removed from Windows' "Programs and Features" the accompanying files were not removed from the RAD Studio 10.1 folder. Or, at least I don't think they were. All of the headers, libraries, and bpl files that I've looked for are still there.

I will run some tests and report back if I encounter a problem.
Goran Ekstrom

Posts: 149
Registered: 1/10/04
Re: RAD 10.2 Tokyo - BDE Installer  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 23, 2017 12:12 PM   in response to: Clayton Arends in response to: Clayton Arends
.
Goran Ekstrom

Posts: 149
Registered: 1/10/04
Re: RAD 10.2 Tokyo - BDE Installer  
Click to report abuse...   Click to reply to this thread Reply
  Posted: Mar 31, 2017 2:52 AM   in response to: Clayton Arends in response to: Clayton Arends
So finally:

The BDE Tokyo installer wants to uinstall something the first time it is run. Once that finished it seems nothing is touched (Berlin still works). Then the Tokyo BDE installer needs to be run one more time to do the actual Tokyo installation which works fine.

After doing it a second time on my laptop the linking error for BDE is still there, the line #pragma link "bdertl.lib" needs to be added.
Legend
Helpful Answer (5 pts)
Correct Answer (10 pts)

Server Response from: ETNAJIVE02